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1: INTRODUCTION 

1.1 CPET OVERVIEW 

  

cPet (CSDR Planning and Execution Tool) is designed to handle CSDR (Cost and Software 

Data Reporting) plans and cost reports. cPet deals with two main categories in viewing plans: 

importing and creating documents. Existing plans and cost reports can be imported into cPet 

and easily reviewed and edited. cPet provides warnings where data are missing or invalid. 

The importing process generates an XML version of the document. Furthermore, plans can 

be exported to PDF to resemble the DD Form 2794. 

 

Plans can also be created from scratch using cPet's editing tools. Similar to the imported 

plans, cPet generates an XML version of the new plan, and the data can be viewed in a PDF 

or Excel replica of the DD Form 2794. 

 

In addition to managing CSDR data, cPet provides an automated validation process for cost 

reports. An error log displays warnings pertaining to missing, incomplete, inconsistent, and 

numerically inaccurate data. Based on the validation results, the user can choose to accept or 

reject the report. The end product is a validation letter explaining the results. 

 

The flowchart below shows how cPet is organized into importing and creating CSDR plans, 

as well as importing and validating cost reports. 
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Proceed to Getting Started to follow a series of tutorials relating to importing, creating, and 

validating documents. 
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1.2 WHAT’S NEW 

October 31, 2012 

cPet v. 2.4 Release 

_____________________________________________________________________________________________________________________________________________ 

 Added support for 1921-3 validation 

 Added support for 1921-2, including the following: 

1.  XML schema (i.e. file format) 

2.  XML import/export 

3.  Excel DD Form import/export 

4.  Graphical User Interface for viewing/editing data in cPet 

5.  1921-2 flat file import/export 

6.  1921-2 Validation 

 2011 plans exported as Excel DD 2794 now paginate correctly for better printing 

formats 

 “Number of Units” fields now import correctly from Excel for 2011 version 1921 and 

1921-1, allowing them to be validated. 

___________________________________________ 

Updates for Version 2.3 Release, February 1, 2012 

* Added support for importing and creating new plans and cost reports of the 2011 DID 

version. 

* Contract plans can now be imported or created without the presence of a program plan 

open in cPet. 

* In previous versions of cPet, WBS elements on a contract plan’s WBS Editor were 

highlighted green (by default) if the elements also appeared on the program plan. This green 

highlighting no longer occurs. 

* The “Edit > Insert WBS from Existing Plan” command on a contract plan’s WBS Editor 

has slightly changed. In previous versions, this command would insert only those WBS 
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elements that were checked on the program plan’s RDT. In Version 2.3, the entire program 

plan’s WBS is inserted. 

* There are a few options for creating a new plan: creating a plan from scratch and cloning an 

existing plan. For a new contract plan, there is also the option to create the plan based on a 

parent plan's RDT. 

* It is not necessary to select a contractor before importing or creating a contract plan. 

* There is a single menu item to import or create a contract plan or subcontract plan. For 

2007 and 2011 documents, users can change the Plan Type to “Subcontract” in the Basic Info 

window to differentiate from the Prime Contract. 

* The “Contract Information” tab is added to the Basic Info window for contract plans. This 

tab includes information such as the contract number, contractor name, organization, 

division, and (for the 2011 version) the appropriation and DD 1921-3 required report check 

box. 

* Added support for importing a contractor’s name, division, and location from the DD 2794 

Excel file. Users do not have to select a contractor in cPet before importing a contract plan. 

* When a new contract plan is created, the contractor name will appear as “TBD” until the 

user updates the name under View > Contractors. 

* Provided the option to set the WBS System Type to MIL-HDBK-881A or MIL-STD-881C. 

* Added support for importing 1921-3s. 

* Added new validation rules for 1921s: 

- The contract price must be a number, empty, or "N/A." 

- The contract ceiling must be a number, empty, or "N/A." 

- The summary element "Reporting Contractor FCCM" must have a non-zero Total At 

Completion cost. 

- The Systems Engineering/Program Management WBS element must have a non-zero Total 

At Completion cost. 

- If the Report Cycle on the 1921 Basic Info is marked as "Final," then the summary element 

"Reporting Contractor Undistributed Budget" Total At Completion cost must be zero. 

- If the Report Cycle on the 1921 Basic Info is marked as "Final," then the summary element 

"Reporting Contractor Management Reserve" Total At Completion cost must be zero. 
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- If the Report Cycle on the 1921 Basic Info is marked as "Final," then the summary element 

"Total Price" Total To Date cost must be at least 95% of the Total At Completion cost. 

- If the Report Cycle on the 1921 Basic Info is marked as "Final," then the root element (e.g. 

top level element) To Date cost must be at least 95% of the At Completion cost. This rule 

applies to Nonrecurring, Recurring, and Total costs. 

- The Total Price at Completion should equal the Contract Price. However, if the Contract 

Ceiling is provided, then the Total Price should be between the Contract Price and Contract 

Ceiling. If neither of these scenarios is true, then Remarks should be reported. 

* Added new validation rules for 1921-1s: 

- If there are costs on Line 18 "Total Direct-Reporting Subcontractor Dollars," then an 

explanation should be provided in the Remarks section.   

- If Line 20 “Other Costs Not Shown Elsewhere” is greater than or equal to x% of Line 21 

“Total Cost,” then an explanation should be provided in the Remarks section (the actual 

percentage depends on the document version). 

* Added command to update 2007 cost reports to 2011 versions 

* Updated validation memo 

* Updated the Narrative Text default headings for contract plans to be: 

- Non-Recurring/Recurring Definitions 

- Cost Accounting Standards (CAS) Disclosure Statement Differences 

- 1921-3 Contractor Business Data Report 

- ** (if required) 1921-2 Progress Curve Report 

* Treat WBS elements whose siblings are all N/A as single child elements. One validation 

condition is that an element should not be the single child of another element. The definition 

of "single child" is broadened to include any non-N/A element whose siblings are all N/A. 

Updates for Version 2.2 Interim Release, January 7, 2011 

* Added support for importing 2007 Excel files (xlsx). 

* Removed warning from 1921 validation: "Non-required reporting element omitted from 

1921." 

* Added 1921 and 1921-1 validation warning that flags negative figures. 

Updates for Version 2.2, Nov 2009 
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* Added a new “Flat File” import/export feature. Data can now be imported from a standard 

flat file format into cPet. Also, data already read into cPet can be exported into the flat file 

format. 

* The Program Name for contract plans is now editable within cPet. 

* Added a new validation rule for 1921’s: cPet will report a warning if there is zero cost in 

the Total At Completion column for either the “Reporting Contractor G&A” summary 

element or the “Reporting Contractor Profit/Loss or Fee” summary element. 

* Updated 2003 DD 1921-1 quantity validation. 

* Removed document-level Remarks field from Basic Info of 1921-1. Added Remarks field 

for each WBS Element on the Cost Data of the 1921-1. 

Updates for Version 2.1, Jun 2, 2009 

* Added functionality to export a 1921 and a 1921-1 to Excel 

* Added 1921 and 1921-1 Cost Report Comparison feature 

* Added import warnings for missing summary elements on plans 

* Added Cut/Copy/Paste commands in WBS Editor. WBS Elements can be pasted in Excel, 

and likewise, elements from Excel can be pasted in the WBS Editor 

* Added “Free Edit Mode” in WBS Editor. In Free Edit Mode, parent/child relationships 

among WBS elements are relaxed so that individual elements can be indented and moved 

without changing the indentation or position of other elements. 

Updates for 2.0 Production Jan 13, 2009 

* Moved fields for Total Est. Contract Value and Software Contract Value from the Basic 

Info to the RDT. This change relates to both the program plan and the contract plan. 

* On DD 2794 plan exports, the N/A will now appear in the 1921 column (instead of the 

CWBS column) for WBS elements that do not require cost reports. 

* Added a warning for blank contract numbers in the Conversion Results when importing 

contract plans. 

* Added up/down toolbar buttons in the Narrative Text on the plan Basic Info windows. 

* Added Expand/Collapse All commands to the WBS Editor. 

* Modified the DD 2794 Excel export so that text in fields such as the Preparing 

Organization wrap. 
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Updates for 2.0 Beta Nov 5, 2008 

* Fixed tools used to create a 1921/1921-1 Excel template. The user can now export the cost 

data from a 1921/1921-1 to an Excel template, which can readily be imported into cPet. See 

the updated help topics “Creating a 1921” and “Creating a 1921-1” for details (found under 

Tutorials>Cost Reports). 

* Changed summary element validation for 2003 1921.  If all the subcontractor summary 

elements are blank/zero, then [Root WBS Element] = Total Cost (Less Reporting Contractor 

G&A & Profit or Fee). See the help topic “Validation Rules” for more information. 

* Changed 1921 validation results to include WBS element code for the error, “Child 

elements do not sum to parent element correctly.” 

 

1.3 GETTING STARTED 

Once cPet opens, the main screen is displayed: 

  

 

  

There are a few recommendations to getting started: 

  

Import an Excel-based Program or Contract Plan by selecting File > Import 
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Create a new Program or Contract Plan by selecting File > New 

Open an existing cPet document by selecting File > Open 

Drag and drop cPet files from Windows Explorer into this window 

Select Help to access the built-in Help System 

  

Perhaps the best way to familiarize yourself with cPet is to first import plans, and then create 

new plans. 

  

Proceed to Importing a Program Plan to start. 
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2: TUTORIALS 

2.1 IMPORTING EXISTING PLANS 

2.1.1 IMPORTING A PROGRAM PLAN 

The Import Program Plan command is used to convert DD 2794 Excel files into XML files 

that can then be reviewed and edited in cPet. To import a program plan, start with this 

tutorial and then follow the successive tutorials as listed below: 

  

Viewing the Basic Information 

Viewing the WBS Editor 

Viewing the Submission Events 

  

In the main window of cPet, click File > Import > Import DD 2794 (Program Plan). 

  

 

  

  

Select the file you want to import and click “Open.” 
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Tip: You can import files that use either Excel 2003 (with an xls extension) or Excel 2007 

(with an xlsx extension). 

  

Tip: You must select a program plan that uses the 2003, 2007, or 2011 DD2794 format. 

The plan in this example uses the 2011 format. 

  

 

  

Wait while the file imports. 
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Once the file has finished importing, the Conversion Results window opens. 

  

 

  

  

The green checks   indicate that the data imported correctly, and the yellow warnings   

 indicate errors. Review these Conversion Results to anticipate some of the problems that 

will be seen when comparing the Excel file to the data which imported into cPet. 
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The imported file now appears in the main screen of cPet. 

  

There are three main components of viewing a plan: The Basic Info, WBS Editor, and 

Submission Events. 

  

 

  

Proceed to Viewing the Basic Information  to begin reviewing the program plan. 

  

  

2.1.2 VIEWING THE BASIC INFORMATION 

This tutorial is step one in the three-step process of importing a program plan: 

  

 1. View the Basic Information 

     2. View the WBS Editor 

     3.View the Submission Events
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This tutorial will take you through the first of these steps – viewing the Basic Information. 

  

Click the  icon to view the Basic Info. 

  

 

  

Verify that all the header information imported correctly into cPet. 

  

Click on the “DD2794 Narrative Text” tab of the Basic Info window. 
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Enter the text found in the remarks sections at the bottom of the DD 2794. This field will not 

import; the text must be entered manually or copied and pasted from the source. 

  

Default headings are provided ( “Program Overview,” “Contracting Approach,” and 

“Quantity Overview” for a program plan). However, headings can be added or modified 

using the following icons: 

  

Add a new parent heading 

Add a new sibling heading 

Add a new child heading 

Move entry up on the list 

Move entry down on the list 

Delete the heading 

  

Tip: Images will not copy into the Narrative Text. This window is strictly text only. 
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Tip: The "proper" way to organize the Narrative Text is to have a parent header, followed 

by a child header, followed by the actual descriptive text. For instance, the layout of the 

Narrative Text should be as follows: 

  

Parent Header 

Child Header 

Descriptive Text 

  

Do not type information directly under the first two headers. If you do not follow the above 

layout, the text will not be properly formatted in the Remarks section when exported to PDF 

or Excel. 

  

Save and close the Basic Info window. 

  

Proceed to Viewing the WBS Editor. 

  

  

2.1.3 VIEWING THE WBS EDITOR 

This tutorial is step two in the three-step process of importing a program plan: 

  

     1. View the Basic Information 

 2. View the WBS Editor 

     3.View the Submission Events

  

Click on the  icon in the main window of cPet to view the WBS Editor. 
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View the WBS Editor and verify that each WBS Element has the appropriate form checked. 

  

 

  

Alterations to the WBS Editor (such as adding or moving a WBS element) are discussed in 

the tutorial Editing the WBS Editor. 
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Continue reviewing the imported program plan by proceeding to Viewing the Submission 

Events. 

  

  

2.1.4 VIEWING THE SUBMISSION EVENTS 

This tutorial is step three in the three-step process of importing a program plan: 

  

     1. View the Basic Information 

     2. View the WBS Editor 

3.View the Submission Events

  

Click on the   icon to view the Submission Events. 

  

 

  

View the Submission events and verify that the correct forms are checked and the dates have 

imported. 
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Making changes to the Submission Events window is discussed in the tutorial Editing the 

Submission Events. 

  

You have now finished reviewing your imported plan. Continue to Importing a Contract Plan 

for the tutorial on how to import a contract plan. 

  

2.1.5 IMPORTING A CONTRACT PLAN 

In the main window of cPet, click File > Import > Import DD 2794 (Contract/Subcontract 

Plan). 

  

Tip: It is not necessary to have a program plan open in cPet before importing a contract 

plan. In this tutorial, however, we did already import a program plan. 
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Select the contract plan to be imported and click “Open.” 

  

Tip: You can import files that use either Excel 2003 (with an xls extension) or Excel 2007 

(with an xlsx extension). 

  

Tip: You must select a contract plan that uses the 2003, 2007, or 2011 DD2794 format. 

The plan in this example uses the 2011 format. 
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Wait for the file to import. 

  

The Conversion Results are displayed. Review these results to be aware of importing 

problems. 
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The image below shows both the program plan and contract plan that have been imported 

into cPet. If you wish to indent the contract plan under the program plan, you can drag and 

drop the contract plan. This action will link the documents. 
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View the Basic Information, WBS Editor, and Submission Events of the contract plan as you 

did for the program plan. 

  

Note that the plan type will be marked "Prime Contract" according to the DD 2794 Excel file. 

  

 

  

Notice that compared to the program plan, the Contract Plan Basic Info has an additional tab 

- the Contract Information. 

  

The Contract Information tab is shown below. 
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The Contractor Name, Division, and Location are imported if they are on separate lines in the 

Excel file. For 2011 contract plans, the Organization and the Division are broken out into 

separate fields. 

  

 

  

For 2003 and 2007 contract plans, the contractor name, division, and location should appear 

as follows: 
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You should also check that the contractor appears correctly in the Contractor Selection 

Dialog. 

  

Don’t forget to write remarks in the Narrative Text tab of the Basic Info window. The default 

headings for contract plans are: 

  

- Non-Recurring/Recurring Definitions 

- Cost Accounting Standards (CAS) Disclosure Statement Differences 

- 1921-3 Contractor Business Data Report 

- ** (if required) 1921-2 Progress Curve Report 

  

Importing a subcontract plan is nearly identical to importing a contract plan. Proceed to the 

Importing a Subcontract Plan tutorial to see the difference. 

  

  

2.1.6 IMPORTING A SUBCONTRACT PLAN 

Importing a subcontract plan is a lot like importing a contract plan. 

  

Tip: It is not necessary to have a program plan or prime contract plan open in cPet before 

importing a subcontract plan. In this tutorial, however, we did already import a program 

plan and prime contract plan. 

  

In the main window of cPet, click File > Import > Import DD 2794 (Contract/Subcontract 

Plan). Select the subcontract plan to import. Proceed as you did for the Importing a Contract 

Plan tutorial. 
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For 2007 and 2011 documents, cPet will recognize the Plan Type as subcontract according to 

the Excel File. 

  

 

  

The subcontract plan will have a different icon than the contract plan in cPet's main window. 

  

 

  

  

Once you are comfortable with importing plans, try building a plan from scratch using cPet's 

tools. Start with the Creating a Program Plan tutorial. 

  

  

2.1.7  LINKING DOCUMENTS 

The Linking Documents tool provides a way to link plans or cost reports together. 
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If plans have already been imported into cPet but a contract plan is not associated with a 

particular program plan, for example, then the linking tool is helpful. 

  

In the main window of cPet, click Tools > Link Documents. 

  

Click the desired program plan and contract plan to be linked. 

  

Click Link. 

  

The contract plan is now associated with the program plan. 

  

In the example below, the program plan and the last contract plan displayed are meant to be 

linked. 

  

Before Linking: 
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After Linking: 

  

      

 

  

The second contract plan is now linked under the program plan. 

  

Tip: Subcontract plans can also be linked to contract plans. Similarly, a 1921 can be 

linked to a contract plan, and a 1921-1 can be linked to a 1921. 

  

Situations where this tool might be useful are listed below: 

  

a) If a contract plan was imported under the wrong program plan, the linking tool allows the 

contract plan to be matched up with the correct program plan. 

  

b) If a program plan was re-imported since the original import, the contract plans will no 

longer be connected to the program plan. The linking tool allows for re-association. 
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Tip: Contract plans can also be rearranged in the main window of cPet by dragging and 

dropping one plan onto another. In the example below, the contract plan is being moved 

under the program plan. The yellow arrow  points to the document under which the 

contract plan will be indented. 

  

 

  

  

2.1.8 CONVERTING PLANS TO 2011 VERSION 

If you have already imported a plan in the 2003 or 2007 version but would like to view it in 

the 2011 format, click Tools > Convert to 2011 version on cPet's main window. This 

command can also be accessed through the  icon. 

  

To convert a plan to the 2011 version... 

  

1. Select the plan (program, contract, or subcontract) in the main window of cPet. 

2. Click Tools > Convert to 2011 version. 

3. You will be asked where you want to save the XML version of the new plan. The plan will 

be saved with a default name of "[Plan name] -- 2011 Version." 
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4. Once you save the plan, the plan displayed in cPet will be the 2011 version. 

5. If you would like to view the old version again, you must reopen it from its original saved 

location. 

  

All the information will be copied over. However, you should note the following nuances: 

  

When converting from 2003 to 2011: 

A few fields will be added to the Basic Info (such as the Prime Mission Product). Some 

fields (such as the Approved Plan Number/Review&Ref #) are renamed but contain the same 

information. 

The Contract Information tab of the Basic Info will have additional fields for the 

Appropriation and the Required Reports on the 2011 version. 

The 1921 and 1921-1 columns for the WBS Editor and the Submission events have slightly 

different names, but they basically correspond 

The 2630 column in the WBS Editor of the 2003 version is now called the SRDR column 

in the 2011 version 

The CWBS Dict. column is added to the WBS Editor for the 2011 version. The checkboxes 

in the column will be checked for all elements 

The 1921-4 column will be added to the WBS Editor and the Submission events of the 

2011 version. The checkboxes in this column will be unchecked by default. 

In the Submission Events, the 2630-2 and 2630-3 columns are now called the SRDR Initial 

and SRDR Final columns, respectively, in the 2011 version 

The summary elements for contract plans are slightly different 

  

When converting from 2007 to 2011: 

One column will be added to the WBS Editor and the Submission events of the 2011 

version: 1921-4. The checkboxes in this column will be unchecked by default. 

The Contract Information tab of the Basic Info will have additional fields for the 

Appropriation and the Required Reports on the 2011 version. 
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Tip: Cost reports in the 2007 version can also be converted to the 2011 version. 

  

2.1.9 IMPORTING ERRORS TO AVOID 

The following is a list of common errors that may occur when importing a plan. These errors 

most often occur because the DD 2794 was improperly formatted; a problem that can be 

resolved by following the sample DD 2794, or by editing the fields in cPet. Most of these 

errors are recorded in the Conversion Results, while some are highlighted within cPet. 

  

1. Weapon System Type must be a valid MIL-HDBK-881 specification (e.g. "Aircraft 

System"). 

  

2. cPet may not import Milestone or Submission Type formulas from the Excel file. For 

example, cPet may not recognize a formula such as "IF ('Main Sheet'!C4="B","X","")" that is 

used to identify Milestone B. 

  

3. A WBS item will be highlighted if it is an only child (see below).  The color of the 

warning depends on the Display Colors in the cPet Options. 

  

 

  

Note that an element will also be flagged if it is the only item at that level that has reports 

checked. For example, in the image below, the Telemetry element is highlighted because it is 

the only element at its indenture level that has forms checked. The Integration element shows 

"N/A" and has no forms checked. 
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4. A WBS item will be highlighted if it does not have any columns (not including the CWBS 

column) checked. 

  

5. WBS element indenture level will be determined by the WBS indentation structure in the 

Excel file (as opposed to the WBS item numbers themselves). In the example below, 

"Complete Round" is mistakenly put at the same level as "Ordnance System." cPet will 

mimic this structure and ignore the actual WBS Item Numbers when displaying elements in 

the WBS Editor. 

  

 

  

  

 

  

  

6. Submission event headers will be highlighted (see below). The color of the warning 

depends on the Display Colors in the cPet Options. 
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7. Submission event dates marked as N/A or dates that are invalid will be left blank in cPet 

and highlighted. 

  

Tip: Invalid dates such as 4/31/2007 will not import (April has only 30 days). 

  

8. The Address must be on the correct line in the Excel file in order to import correctly. See 

below for incorrect and correct formatting. Note that cPet tolerates different 2007 address 

formats better than 2003 formats. 

  

2003 Plans 

Incorrect: 

  

 

  

 

  

Correct: 

  

 

  



Tutorials 

33 

 

  

 

  

2007 and 2011 Plans 

Incorrect: 

  

 

(as a merged cell) 

  

Correct: 

  

 

(as a merged cell) 
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(if not merged) 

  

  

9. In the Form field of the submission events, the text must be written in the correct format 

(see below). 

  

2003 Plans 

  

 The submission event form 2630 must have a part specified. 

  

Incorrect: 2630 

Correct: 2630-2, 2630-3 

  

If "2630" is written on the Excel file, cPet will check both parts in the submission 

events. 

  

2007 and 2011 Plans 

  

 The CWBS Dictionary must be written as follows: 

  

Incorrect: WBS Dictionary, WBS Index 

Correct: CWBS Dictionary 

  

 The submission event form 2630 is recognized as follows: 



Tutorials 

35 

  

2630-2 is equivalent to SRDR Initial 

2630-3 is equivalent to SRDR Final 

  

Note: If "2630" is written on the Excel file, cPet will check both parts (SRDR Initial 

and SRDR Final) in the submission events. 

  

 Cost reports may be formatted as follows: 

  

1921-1, 1921-1 Part 1, 1921-1 Part I, 1921-2, 1921-1 Part 2, 1921-1 Part II, 1921-4 

  

10. Excel formatting must resemble that of the original DD Form 2794. If the border around 

a cell(s) is missing, the file may not import at all, or part of the data may not import. In the 

example below, the borders are lacking on the CWBS Dictionary column. WBS elements 

corresponding to the unformatted rows will not import into cPet. 

  

Incorrect: 
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Correct: 

  

 

  

  

  

2.2 CREATING PLANS 

2.2.1 CREATING A PROGRAM PLAN 

2.2.1.1 Creating a Program Plan 

The process of creating a program plan is similar to that of importing a program plan in that 

there are three main components: the Basic Information, WBS Editor, and Submission 

Events. However, whereas you could simply review these components when importing a 

plan, you must manually fill in information when creating a plan. The last tutorial in this 

section, Building the RDT, will be useful later when the contract plan is created. 

  

To start creating a program plan, complete this tutorial and then proceed to Editing the Basic 

Information and continue to follow the rest of the tutorials listed below. 

  

Editing the Basic Information 

Editing the WBS 

Editing the Submission Events 

Building the RDT 
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In the main window of cPet, click File > New > New Program Plan, or just click  

 on the main toolbar. 

  

 

  

The Create Program Plan dialog pops up. Choose whether you would like to create 

a new plan from scratch, or to copy an existing plan open in cPet. 
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In this tutorial, we will create a new plan and use the 2011 format, as new plans 

should typically be created using the most recent version. 

  

The Basic Info dialog appears. Continue to Editing the Basic Information to fill in the 

program plan. 

  

2.2.1.2 Editing the Basic Information 

  

This tutorial is step one in the three-step process of creating a program plan: 

  

 1. Edit the Basic Information 

     2. Edit the WBS 

     3. Edit the Submission Events 

  

The Basic Information window appears after File > New > New Program Plan is 

clicked. Fill in this window with the appropriation information. Note that changing the 

WBS System Type from MIL-STD-881C to MIL-HDBK-881A affects the values in the 

WBS System Type dropdown. 
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Tip: See the Basic Info Dialog for more information on what the fields correspond 

to on the DD Form 2794. 

  

Fill in information in the DD2794 Narrative Text tab. Use the following icons to add 

headings: 

  

Add a new parent heading 

Add a new sibling heading 

Add a new child heading 

Move entry up on the list 

Move entry down on the list 

Delete the heading 
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Save and close the Basic Info window. 

  

Tip: The "proper" way to organize the Narrative Text is to have a parent header, followed 

by a child header, followed by the actual descriptive text. For instance, the layout of the 

Narrative Text should be as follows: 

  

Parent Header 

Child Header 

Descriptive Text 

  

Do not type information directly under the first two headers. If you do not follow the above 

layout, the text will not be properly formatted in the Remarks section when exported to PDF 

or Excel. 

  

Move on to Editing the WBS Editor to continue creating the plan. 

  

  

2.2.1.3 Editing the WBS 

This tutorial is step two in the three-step process of creating a program plan: 

  

     1. Edit the Basic Information 

 2. Edit the WBS 

     3. Edit the Submission Events 

  

In the main window of cPet, click  to view the WBS Editor. 

  

Depending on whether or not "Prompt before providing WBS structure to plans with 

no WBS" is checked in the Options, cPet may or may not automatically fill in the 

WBS Editor. If this option is not checked, then the WBS elements corresponding to 

the program plan's Weapon System Type will appear in the WBS Editor (in this 
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tutorial, these are the elements for a Space System). If this option is checked, you 

will be asked whether or not you want the WBS Editor to be filled in automatically. 

  

Tip: Setting the standard WBS type to MIL-HDBK-881A or MIL-STD-881C affects 

how the WBS elements are auto-populated. 

  

Fill in the required forms next to each WBS element. 

  

 

  

Tip: The four rows which are highlighted pink in the example above indicate that 

there is an error. See Errors to Avoid for more details. In this particular example, 

they are pink because there must be at least one column checked (not including the 

CSWB Dict. column). 

  

Use the following icons to check/uncheck items and to add, edit, or move elements: 

  

Undo 

  

Redo 
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Add a sibling to the selected element 

  

Add a child to the selected element 

  

Delete an item 

  

Copy a WBS element 

  

Cut a WBS element 

  

Paste a WBS element (note that elements can be pasted into cPet or into Excel) 

  

Indent an item 

  

Unindent an item 

  

Move an item up in the list 

  

Move an item down in the list 

  

Provides the option of assigning a WBS number to each item, or clearing the item 

numbers 

  

Free Edit Mode - Turn on Free Edit mode to add, delete, or arrange WBS 

elements easily. See below for more details 
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Expand All (Found under the View Menu)- All the elements in the WBS tree will 

be displayed 

  

Collapse All (Found under the View Menu)- All the elements in the WBS tree will 

be collapsed so that only the root element(s) is displayed 

  

Check (Found under the Edit Menu) - Use the shift or control key to select a few WBS 

items in a certain column. Then click this icon to check all the items in the selection 

  

Uncheck (Found under the Edit Menu) - Use the shift or control key to select a few WBS 

items in a certain column. Then click this icon to uncheck all the items in the selection 

  

Insert Standard WBS (Found under the Edit Menu). Provides the option to insert one of 

the standard WBS's according to either the MIL-HDBK-881A or MIL-STD-881C as 

specified. 

  

To check/uncheck all the elements in a column, right click on the column header and select 

 or  , respectively. 

  

Tip: From the Edit menu, you can Select All or Select Child Elements. These commands 

can be particularly useful if you would like to delete groups of elements from a standardized 

WBS. 

  

Tip: Elements can be copied from the WBS Editor and pasted into Excel. Likewise, 

elements can be copied from Excel and pasted into the WBS Editor. 

  

Tip: Click Edit>Insert WBS from Existing Plan to add WBS elements from a selected 

plan already open in cPet. 
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Free Edit Mode 

  

The Free Edit Mode may be useful when creating new WBS elements or rearranging the 

indentation structure of the elements. Click the icon on the toolbar to turn on 

the Free Edit Mode (the button will turn orange). In Free Edit Mode, parent/child 

relationships among WBS elements are relaxed so that individual elements can be indented 

and moved without changing the indentation or position of other elements. The WBS 

elements will still appear indented under each other, but the Expand ( ) and Collapse ( ) 

icons will no longer be present. The purpose of the Free Edit Mode is to visually organize the 

WBS with ease. Without this mode turned on, a newly added element may not appear where 

you would like it to be in the tree structure. 

  

There are a few things to note when using the Free Edit Mode: 

  

After changing the WBS in Free Edit Mode, the WBS indenture structure will be 

maintained after the mode is turned off. 

WBS elements are indented by four spaces. However, if you indent an element by a single 

space, cPet will interpret this element as being indented by four spaces. 

If you indent an element by more than four spaces, cPet will ignore these extra spaces. If 

you close and reopen the WBS Editor, the element will appear indented by the normal four 

spaces. 

  

Continue to Editing the Submission Events to create the next component of the plan. 

  

  

2.2.1.4 Editing the Submission Events 

This tutorial is step three in the three-step process of creating a program plan: 

  

     1. Edit the Basic Information 

     2. Edit the WBS 
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3.Edit the Submission Events



In the main window of cPet, click  to open the Submission Events: 

  

Use the toolbar at the top of the window to add and edit submission events. A brief 

explanation of the toolbar is given below. 

  

 

  

  

Delete a submission event 

  

Use the shift or control key to select a few submission events in a certain column. 

Then click this icon to check all the items in the selection. 

  

Use the shift or control key to select a few submission events in a certain 

column. Then click this icon to uncheck all the items in the selection. 

  

Add submission event(s). 

  

Add Type – Adds either “Blank” or “Like Current” events 

  

“Blank” = Adds new rows 

“Like Current” = Copies rows from selected row 
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Fill Down Value – When several rows are selected, clicking this icon 

checks/unchecks the boxes in the column according to the first row. This icon can 

also be used to copy dates down a column. 

  

Fill Down Date Value – When multiple rows are selected, clicking this icon 

generates dates down the column. These dates are set apart from each other by a 

certain increment of time. 

  

Insert a row before the selected event (found on Edit menu) 

  

Insert a certain number of rows (quantity depends on numerical value in toolbar; 

found on Edit menu) 

  

Add a row to the end of the submission events list (found on Edit menu) 

  

Add a certain number of rows to the end of the submission events list (quantity 

depends on numerical value in toolbar; same as  icon; found on Edit menu) 

  

Sort and Renumber – Arranges the submission events by As of Date and 

designates an Event Number for each. 

  

Import Events from contract plan - Contract plan submission events can be 

imported into a program plan's submission events. See Import Events from Contract 

Plan for more information. Icon found under the Tools menu of a program plan. 
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To check/uncheck all the events in a column, right click on the column header and select  

or  , respectively. 

  

Tip: From the Edit menu, you can Select All. This command can be particularly useful if 

you would like to either check/uncheck all the submission events, or delete them all. 

  

For practice, use the icons above to add events according to the image below. 

  

 

  

  

Tip: Notice that the dates for Events #2-5 are distributed every three days. Make 

use of the Fill Down Dates icon to easily complete this exercise. 

  

Tip: Use the multi-check icon to check CWBS Dict. for Events #1-3. 

  

Tip: Once an As Of Date is assigned to a submission event, cPet automatically 

generates a Due Date, but this date can easily be changed. 

  

Save and close the Submission Events. 

  

You have now finished creating a program plan. Proceed to Building the RDT to 

understand how to create and export a plan's RDT in cPet. 
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2.2.1.5 Building the RDT 

After a program plan is created, the next step is to build the Resource Distribution Table 

(RDT). It is not necessary to build an RDT in cPet, but an RDT typically accompanies a 

program plan. The RDT can be used to build new contract plans. See WBS Editor of a 

Contract Plan for more information. 

  

In order to view the RDT, at least one contractor must first be chosen. Click on the 

Contractor Selection icon . 

  

In this tutorial, we will select two contractors: 

  

1) *Demo* ABCD Corporation 

2) Sample Contractor 

  

Find these contractors and click “Add.” You might try using the filter feature to search for a 

few key words. Note that if a contractor is absent from the Contractor Selection list, you can 

add it through the Contractor Maintenance. 

  

Tip: For a detailed description of how to add contractors, see the Contractor Selection 

Dialog. 

  

After the contractors are chosen, select the parent plan and click the RDT icon  in the 

main window of cPet (or click View>RDT). 

  

WBS Elements 

The RDT is designed to allocate responsibility to each contractor for every WBS element. 

  

Check which contractor is responsible for which WBS elements. In this tutorial, *Demo* 

ABCD Corporation is responsible for items “Space System” and “SEIT/PM and Other 
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Common Elements” as well as “Ground (1...n as required) through “Launch Vehicle” (the 

last WBS element is not shown in the image below). 

  

 The Sample Contractor is responsible for “Space System” and “Space Vehicle (1...n as 

required)” through “Launch Operations & Mission Support.” 

  

 

  

Use the toolbar at the top of the RDT window to easily check or uncheck items. 

  

  

Check Selection - Use the shift or control key to select a few WBS items in a certain 

column. Then click this icon to check all the items in the selection. 

  

Uncheck Selection - Use the shift or control key to select a few WBS items in a certain 

column. Then click this icon to uncheck all the items in the selection. 
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A few other icons that may be useful are: 

  

If the WBS item name is longer than the width of the column, clicking this button 

Resizes the Column so the entire name can be seen. 

  

Arranges the contractor columns in order of their base year contract value,  from largest to 

smallest. 

  

Moves a contractor column adjacent to the WBS (icon found by right-clicking on a 

column header) 

  

To check/uncheck all the elements in a column, right click on the column header and select 

 or   , respectively. 

  

Tip: From the Edit menu, you can Select All or Select Child Elements. These commands 

can be particularly useful if you would like to check/uncheck groups of WBS elements. 

  

Tip: WBS elements must have item numbers in order for them to be edited in the RDT. 

Items that do not have numbers will be highlighted according to the Options Display color. 

You will be unable to check these elements under any contractor column until you assign 

them numbers in the WBS Editor. 

  

Header Information 

You can also fill in information pertaining to each contractor. Click on a contractor column 

and complete the "Selected Contractor Information" section. This includes the contract 

number, description, contract value, etc. for that contractor. This information will appear on 

the RDT Export (see below). 
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Tip: The Total Est. Contract Value and the Software Contract Value fields for the prime 

contractor will also appear at the top of the Contract Plan's RDT. 

  

To export the RDT to Excel, select the plan and click the   icon on the main toolbar.  

  

Now that you have learned how to create a program plan, proceed to Creating a Contract 

Plan to understand the process behind creating a contract plan. 

  

  

2.2.2 CREATING A CONTRACT PLAN 

2.2.2.1 Creating a Contract Plan 

To create a contract plan, start with this tutorial and then follow the successive tutorials listed 

below: 

  

Basic Information of a Contract Plan 

WBS Editor of a Contract Plan 

Submission Events of a Contract Plan 

  

Tip: It is not necessary to have a program plan open in cPet before creating a contract 

plan. In this tutorial, however, we did already create a program plan. 

  

To begin, click File > New > New Contract/Subcontract Plan. 

  



cPet Help Manual 

52 

 

  

The Create Contract Plan dialog pops up. Select whether you would like to create a 

new plan from scratch, copy an existing plan, or create a plan based on an existing 

plan's RDT (more information on this option is discussed in the WBS Editor of a 

Contract Plan tutorial). 

  

In this tutorial, we will create a new plan and use the 2011 format, as new plans 

should typically be created using the most recent version. 

  

The Basic Information window appears. Proceed to the next tutorial, Basic Information of a 

Contract Plan to continue. 

  

2.2.2.2 Basic Information of a Contract Plan 

  

This tutorial is step one in the three-step process of creating a contract plan: 

  

 1. Edit the Basic Information 

     2. Edit the WBS Editor 
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     3. Edit the Submission Events 

  

The Basic Information window appears after File > New > New Contract/Subcontract Plan is 

clicked. Make sure the "Prime Contract" radio button is selected. 

  

Notice that the Basic Info window of a contract plan has a Contract Information tab, 

whereas this tab is absent for program plans. 

  

When you create a contract plan, the contractor name will appear as "TBD" until you change 

it. You can change the contractor name either in the Basic Info window itself (as shown 

below), or you can change the contractor through the Contractor Selection Dialog. The two 

fields will sync up, meaning that if you change the contractor in one location, then the new 

contractor name will appear in the other location as well. 
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Remember to write any remarks in the Narrative Text tab. Refer to the Basic Info Dialog for 

how to add text headings. 

  

Proceed to WBS Editor of a Contract Plan after you have filled in the information in the 

Basic Info window. 

  

  

2.2.2.3 WBS Editor of a Contract Plan 

This tutorial is step two in the three-step process of creating a contract plan: 

  

     1. Edit the Basic Information 

 2. Edit the WBS Editor 

     3. Edit the Submission Events 

  

Click on the  icon to open the WBS Editor. 

  

Depending on the selections in the cPet Options General tab, cPet may inquire if the contract 

plan’s WBS elements should be filled in according to the WBS items specified on the 

program plan’s RDT. 

  

 

  

  

Clicking Yes will fill in the standard WBS structure elements according to the Weapon 

System selected in the contract plan's Basic Info Dialog. Clicking No will generate a list only 

of the summary elements. 
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You can also insert WBS elements from the program plan. In the WBS Editor of the contract 

plan, click Edit > Insert WBS from Existing Plan. You must then select from which plan to 

insert WBS elements. The entire WBS of the selected plan will be inserted under the selected 

row in the contract plan's WBS Editor. 

  

 

  

  

Using a parent plan's RDT to build a contract plan's WBS 

In this tutorial, we chose to create a new contract plan from scratch. However, there was also 

the option to create a new contract plan based on a selected plan's RDT. If we had chosen this 

option, then the contract plan's WBS would be auto-populated with selected WBS elements 

from the parent plan. 

  

The images below illustrate the relationships between the program plan’s RDT, the program 

plan’s WBS Editor, and the contract plan’s WBS Editor. The purple lines show how the 

elements “Space System” and “SEIT/PM and Other Common Elements” from the program 

plan also appear on the contract plan. cPet automatically checks the required forms in the 
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contract plan’s WBS Editor according to the program plan. Similarly, the red lines show how 

the elements “Ground (1...n as required) through “Launch Vehicle” correlate between the 

plans. 

  

Program Plan RDT 

 

  

Program Plan WBS Editor 
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Contract Plan WBS Editor (with *Demo* ABCD Corporation contractor) 

 

  

  

For more information on creating the WBS structure, refer to the tutorial on Editing the 

WBS. 

  

Continue to Submission Events of a Contract Plan to complete the series of tutorials on 

creating a contract plan. 
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2.2.2.4 Submission Events of a Contract Plan 

This tutorial is step three in the three-step process of creating a contract plan: 

  

     1. Edit the Basic Information 

     2. Edit the WBS Editor 

3.Edit the Submission Events



Click on the  icon to open the Submission Events. 

  

To edit the submission events, see Editing the Submission Events. 

  

Click Tools > Import Events from existing plan to insert program plan events under 

the selected event in the contract plan's submission events. 

  

After you have created a contract plan, continue to the tutorial for Creating a 

Subcontract Plan. 

  

  

2.2.3 CREATING A SUBCONTRACT PLAN 

2.2.3.1 Creating a Subcontract Plan 

To begin, click File > New > New Contract/Subcontract Plan, just as you would as if you 

were creating a prime contract plan. 

  

Tip: It is not necessary to have a program plan or prime contract plan open in cPet before 

creating a subcontract plan. In this tutorial, however, we did already create a program plan 

and contract plan. 

  

The Create Contract Plan dialog appears as usual. We will create a new plan using 

the 2011 version. 
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In the Basic Info dialog, set the Plan Type to "Subcontract." 

  

 

  

Fill in the Basic Info, WBS Editor, and Submission Events as you did for the prime contract 

plan. 

  

  

2.2.4 EXPORTING PLANS 

Plans can be exported to Excel or PDF via the Tools > Export DD 2794 command. This tool 

may be especially useful to users who have created plans in cPet and wish to view the 

information in an alternate form. 

  

To access this option, select a plan in the main window of cPet and click Tools > Export 

DD2794 or click  on the toolbar. 
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Plans may either be exported to Excel or to PDF. 

  

 

  

  

Export to Excel: View a replica of the DD Form 2794 in Excel. Plans that have been 

exported to Excel can also be imported back into cPet if necessary. Note that the submission 
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events and the remarks section will be located on a separate sheet in Excel (even for 2003 

plans). 

  

Export to PDF: View a PDF replica of the DD Form 2794. 

  

Basically all fields on the export will contain information you specified in cPet. However, 

please note that the Contractor Name column is slightly unique. On program plans, the text 

"Refer to RDT" will always be listed in this column. For 2003 and 2007 contract plans, the 

contractor name, division, and location field will be listed on separate lines in the Contractor 

column. For 2011 plans, this information will appear in the Contractor Name/Address field. 

  

  

2.3 COST REPORTS 

2.3.1 IMPORTING A 1921 

The Import DD 1921 command is used to convert DD 1921 Excel files to XML files that 

can then be reviewed and validated in cPet. A 1921 can be imported under a contract plan or 

a subcontract plan open in cPet. 

  

In this tutorial, we will import cost reports for cPet Demonstration Space System (CDSS). 

These plans and cost reports all follow the 2011 DID. Specifically, we will import a 1921 

under the contract plan X-08-Y-C1. 

  

Follow Importing a Contract Plan before using this tutorial to import a 1921. 

  

In the main window of cPet, select the contract plan X-08-Y-C1. Click File > Import > 

Import DD 1921. 
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Select the 1921 to be imported, click Open, and wait for the file to import. 

  

View the Conversion Results to locate errors with the 1921. 

  

The 1921 now appears indented under the contract plan in the main window of cPet. Click 

the Basic Info icon   to view the header fields. 

  

Click the dollar icon  to view the cost data. 

  

Tip: The WBS element names and codes are read-only. If you wish to revise these 

elements, you must do so in Excel and then re-import the 1921. 

  

The summary elements found will be marked with a flag   in the Cost Data. Only data in 

the To Date Total and At Completion Total columns will be imported for summary elements. 
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Note that misspelled summary elements will be imported and validated as if they were 

regular WBS items. 

  

After reviewing the data to make sure it follows the validation rules, the next step is to import 

a 1921-1 or to skip to validation if a 1921-1 is not required. 

  

Tip: If you have made changes to the 1921 within cPet, you can export it back to Excel. 

Select the 1921 in the main window of cPet and click Tools > Export DD Form (or click   

on the toolbar). 

  

  

2.3.2 IMPORTING A 1921-1 

The Import DD 1921-1 command is used to convert DD 1921-1 Excel files into XML files 

that can then be reviewed and validated in cPet. A 1921-1 can be imported after a 1921 has 

been imported. 

  

To import a 1921-1, select the associated 1921 and click File > Import > Import DD 1921-1 

(or just right click on the 1921 and choose Import DD 1921-1). In this tutorial, we will 

import a 1921-1 under the 1921 for CDSS contract plan X-08-Y-C1. If you have not yet 

imported the 1921, see Importing a 1921 before proceeding in this tutorial. 
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Select the 1921-1 to be imported, click Open, and wait for the file to import. 

  

View the Conversion Results to locate errors with the 1921-1. 

  

The 1921-1 now appears indented under the 1921 in the main window of cPet. Click the 

Basic Info icon   to view the header fields. 

  

Click the dollar icon  to view the cost data. 

  

Tip: The WBS element names and codes are read-only. If you wish to revise these 

elements, you must do so in Excel and then re-import the 1921-1. 
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After reviewing the data to make sure it follows the validation rules, the next step is to 

validate the cost report(s). 

  

Tip: If you have made changes to the 1921-1 within cPet, you can export it back to Excel. 

Select the 1921-1 in the main window of cPet and click Tools > Export DD Form (or click 

  on the toolbar). 

  

  

2.3.3 IMPORTING A 1921-2 

  

The Import DD 1921-2 command is used to convert DD 1921-2 Excel files into XML files 

that can then be reviewed and validated in cPet. A 1921-2 can be imported after a 1921 has 

been imported. 

  

To import a 1921-2, select the associated 1921 and click File > Import > Import DD 1921-2 

(or just right click on the 1921 and choose Import DD 1921-2). If you have not yet imported 

the 1921, see Importing a 1921 before proceeding in this tutorial. 
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Select the 1921-2 to be imported, click Open, and wait for the file to import. 

View the Conversion Results to locate errors with the 1921-2. 

The 1921-2 now appears in the main window of cPet. Click the Basic Info icon   

to view the header fields. 

Click the dollar icon   to view the cost data. 

  

Tip: If you have made changes to the 1921-2 within cPet, you can export it back to 

Excel. Select the 1921-2 in the main window of cPet and click Tools > Export DD 

Form (or click   on the toolbar). 
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2.3.4 IMPORTING A 1921-3 

The Import DD 1921-3 command is used to convert DD 1921-3 Excel files into XML 

files that can then be reviewed in cPet. To import a 1921-3, click File > Import > 

Import DD 1921-3. 

 

Select the 1921-3 to be imported, click Open, and wait for the file to import. 

View the Conversion Results to locate errors with the 1921-3. 

The 1921-3 now appears in the main window of cPet. Click the Basic Info icon   

to view the header fields. 

Click the dollar icon   to view the cost data. 

Tip: If you have made changes to the 1921-3 within cPet, you can export it back to 

Excel. Select the 1921-3 in the main window of cPet and click Tools > Export DD 

Form (or click   on the toolbar). 

2.3.5 CREATING A 1921 

Although cPet provides the functionality to create new cost reports, it is recommended that 

the user import the cost reports from the Excel version. 
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In this tutorial, we will create a 2011 DD Form 1921 under the cPet Demonstration Space 

System (CDSS) contract plan X-08-Y-C1. Before proceeding, make sure you have imported 

or created a contract plan in cPet. 

  

In the main window of cPet, select the contract plan X-08-Y-C1. Click File > New > New 

1921. 

  

 

  

Select the document version. Note that new documents should be created using the 2011 

format. 

  

Fill in information in the Basic Info window. Click save, choose the file location, and close 

the window. 

  

The 1921 now appears indented under the contract plan in the main window of cPet. 

  

Click the dollar icon  to view the cost data. Note that all the WBS elements that appeared 

on the contract plan or subcontract plan now appear on the 1921. If you wish to revise a 

WBS element name or code, you must do so on the contract/subcontract plan and then 
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recreate the 1921. Similarly, the WBS element code corresponds to the WBS item number on 

the contract/subcontract plan. 

  

Note that the summary elements will be listed at the bottom and marked with a flag . Only 

data in the To Date Total and At Completion Total columns for the summary elements can be 

edited. 

  

To fill in the cost data... 

You can manually fill in the cost data, or you can use the exporting/importing features to 

complete this section (as described below; Note that these options are only available for 

2003 and 2007 cost reports): 

  

Create an Excel template file based on the WBS elements and the cost columns (e.g. 

Nonrecurring To Date) 

  

Export the cost data to the template file that was created using the icon above 

  

Import cost data into cPet from a template file 

  

To use these features to fill in the cost data, you would first need to create an Excel template 

( ). Then you could fill in the data in Excel. Perhaps you have an automated method of 

populating the data  in Excel. The final step would be to import the data back into cPet ( ). 

There are a few things to note when using these options: 

  

Tip: When data is imported into cPet, the current data in cPet is overwritten. The cost data 

in cPet is made to resemble the data in the Excel file. 
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Tip: It is not possible to use the import feature  to import data from a template file 

belonging to a different program. The number of WBS items must be the same between the 

Excel template file and the cost data in cPet. 

  

Tip: You can also export the entire cost report (including the Basic Info) to Excel using the 

Export tool on the cPet main window. Select the 1921 and click Tools > Export DD Form 

(or click  on the toolbar). 

  

After reviewing the data to make sure it follows the validation rules, the next step is to create 

a 1921-1 or to skip to validation if a 1921-1 is not required. 

  

  

2.3.6 CREATING A 1921-1 

Although cPet provides the functionality to create new cost reports, it is recommended that 

the user import the cost reports from the Excel version. 

  

In this tutorial, we will create a 2011 DD Form 1921-1 under the cPet Demonstration Space 

System (CDSS) 1921. Before proceeding, make sure you have created a 1921. 

  

In the main window of cPet, select the 1921 and click File > New > New 1921-1 (or right-

click on the 1921 and select New 1921-1). 
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Select the document version. Note that new documents should be created using the 2011 

format. 

  

Fill in the Basic Info window. Click save, choose the file location, and close the window. 

  

Click the dollar icon  to view the cost data. Note that all the WBS elements that appeared 

on the 1921 now appear on the 1921-1. If you wish to revise these element names or codes, 

you must first do so in the parent contract plan or subcontract plan, then recreate the 1921, 

and finally recreate the 1921-1. However, if you imported the 1921 instead of creating it in 

cPet, you can revise the elements in the Excel file, import the 1921, and then create the 1921-

1. 

  

To fill in the cost data... 

You can manually fill in the cost data, or you can use the exporting/importing features to 

complete this section (as described below; Note that these options are only available for 

2003 and 2007 cost reports): 
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Create an Excel template file based on the WBS elements, cost categories (e.g. 

Engineering), and cost types (e.g. NonRecurring Reporting Contractor To Date) 

  

Export the cost data to the template file that was created using the icon above 

  

Import cost data into cPet from a template file 

  

To use these features to fill in the cost data, you would first need to create an Excel template 

( ). Then you could fill in the data in Excel. Perhaps you have an automated method of 

populating the data  in Excel. The final step would be to import the data back into cPet ( ). 

There are a few things to note when using these options: 

  

Tip: When data is imported into cPet, the current data in cPet is overwritten. The cost data 

in cPet is made to resemble the data in the Excel file. 

  

Tip: It is not possible to use the import feature  to import data from a template file 

belonging to a different program. The number of WBS items must be the same between the 

Excel template file and the cost data in cPet. 

  

Tip: You can also export the entire cost report (including the Basic Info) to Excel using the 

Export tool on the cPet main window. Select the 1921-1 and click Tools > Export DD Form 

(or click  on the toolbar). 

  

After reviewing the data to make sure it follows the validation rules, the next step is to 

validate the cost report(s). 
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2.3.7 IMPORTING/EXPORTING A FLAT FILE 

A Flat File displays cost report information in an Excel spreadsheet. This file does 

not replace the DD Form 1921, 1921-1 or 1921-2. Rather, it provides an alternative 

way to organize and edit data. A Flat File can be imported into cPet. Similarly, cost 

reports that are open in cPet can be exported to a Flat File. 

Tip: Flat Files apply only to cost reports of the 2007 or 2011 version (not 2003). 

This tutorial includes the following three topics: 

Editing a Flat File 

Importing a Flat File 

Exporting Cost Reports to a Flat File 

Editing a Flat File 

A Flat File template can be obtained on the cPet page of the DCARC website. The 

user can edit this file and import it into cPet (discussed in next section). 

The Flat File can be divided into four sections: Metadata, Summary Elements, Cost 

Data, and Remarks. Note that the WBS Reporting Level currently acts as a 

placeholder and is not used in this version of cPet. 

Metadata 

The first and second column contain the Metadata associated with the cost reports. 

Assuming that both the 1921 and its associated 1921-1 were open in cPet at the 

time of the Flat File export, data in the second column is taken from the 1921 alone. 

This is because the header fields are assumed to be the same between the two cost 

reports. The only time metadata from the 1921-1 will appear in this column is if the 

1921-1 was open in cPet without a parent 1921. 

There are comments in some of the cells in the first column that provide an 

indication of the type of data expected in the second column. For example, the 

comment in the image below indicates that the Contractor Type must be either 

Prime/Associate or Direct-Reporting Subcontractor. 
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Summary Elements 

The summary element costs are listed in the second column towards the bottom. 

These costs correspond to the Total To Date (TD) and Total At Completion (AC) 

summary costs on the 1921. If one of these cells is blank, cPet will provide a 

warning when the Flat File is imported. 

Cost Data 

The 1921 cost data is displayed in the fourth through eleventh columns. To 

understand what the column names mean, see the Definitions sheet on the Flat File. 

The 1921-1 cost data is located after the 1921 data (although the WBS Code, WBS 

Reporting Elements, and Units do correspond to the 1921-1 data in addition to the 

1921 data). Notice that the cost data is stretched horizontally across the sheet. If 

there happen to be any WBS elements that appear on the 1921-1 but not on the 

1921, they will be added to the bottom of the list of elements. 

Note that the total columns do not appear; only the Nonrecurring and Recurring 

columns are listed. Upon importing the Flat File, cPet automatically sums the data in 

the two columns (NR and Rec) to obtain the costs in the Total columns. Similarly, 

the data in the Total columns is not exported to the Flat File. 

Remarks 

The 1921 Remarks are displayed in the second column, last row of the Flat File. 

These are "document level" remarks. That is, the Remarks pertain to the entire 

1921. Alternatively, the Remarks for the 1921-1 are displayed on a row-by-row basis 
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in the column to the right of all the cost data. These remarks correspond to each 

WBS element. 

For information on entering/editing data for the 1921-2, see Progress Curve Reports 

(DD Forms 1921-2) Flat File. 

Importing a Flat File 

Once you have created a Flat File and made any necessary edits in Excel, you can 

import it into cPet. 

Tip: cPet identifies an Excel file as a Flat File by two characteristics: (1) The Data 

Type in cell B1 must be "1921/1921-1 Input," and the Data Version in cell B2 must 

be "2007" or "2011." If these requirements are not satisfied, the Flat File will not 

import. 

Select the contract plan in the cPet main window and click File > Import Flat File. 

Browse for the Flat File and click Open. (Note: The Excel file must be closed before 

you attempt to import it). 

The Conversion Results for Flat Files dialog will pop up. Review these warnings to 

understand what information was left blank in the Flat File. 

The cost report(s) will open in cPet. Whether a 1921 and a 1921-1 are open in cPet 

depends on if there is information in the both the 1921 and the 1921-1 cost data 

section of the Excel file). 

Exporting Cost Reports to a Flat File 

Once a cost report is open in cPet, you can export it to a Flat File. Select the 1921, 

1921-1 or 1921-2 in the cPet main window and click Tools > Export Flat File. 

Alternatively, right click on the cost report and click Export Flat File. 

Tip: Data from both the 1921 and the associated 1921-1 and/or 1921-2 will be 

exported to the Flat File assuming that both are open and linked together in cPet. 

The Export Flat File command will indicate in parentheses whether the 1921, 1921-

1 and or the 1921-2 are being exported. 
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Choose a location to save the document. The file will open in Excel. 

If you make changes in the Flat File, you can re-import it into cPet through the File > 

Import Flat File command. 

  

2.3.8 COMPARING COST REPORTS 

The purpose of the Cost Report Comparison tool is to perform a side-by-side 

comparison of like cost documents. This is particularly useful when comparing 

chronologically related reports. The user can view the WBS of each report to visually 

see discrepancies between the documents. 

To use this tool, open a contract plan and two like reports in cPet. The reports 

should have different As Of Dates. cPet differentiates these reports by referring to 

them as "Earlier Reports" or "Later Reports." The example below has an Earlier and 

Later 1921, as well as an Earlier and Later 1921-1. 
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Click Tools > Compare Cost Reports. The Select Reports to Compare dialog will 

open. Select the "Earlier Report" and the "Later Report." Also choose the contract 

plan against which to compare the reports and click OK. You must choose either two 

1921's or two 1921-1's. 

Tip: You can select 1921's of either document version (2003, 2007, or 2011). 

However, 1921-1's must both be of the 2007 or 2011 version. Any 1921-1's of the 

2003 version will have check boxes that are disabled in the Select Reports to 

Compare dialog. 

Once you click OK on the Select Reports to Compare dialog, the 1921 Cost Report 

Comparison window or the 1921-1 Cost Report Comparison window will appear. The 

reports will be compared against each other and against the "Reference" (the 

contract plan) WBS. 

2.3.9 VALIDATING COST REPORTS 

There are a few different approaches to validating cost reports. 

  

1) Select a 1921 or 1921-1 and click Tools > Validate Individual Document. The 

Validation Results will appear immediately as long as "Skip Validation Wizard when 

validating an individual document" is checked in the Options. Equivalently, you can right-

click on the cost report and select "Validate" to view the validation results for the 1921 or 

1921-1. 
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2) Click Tools > Run Validation Wizard. See the Validation Wizard dialog for information 

pertaining to each of the screens. 

  

3) Validate a cost report through the contract plan's submission events. Open the Submission 

Events for the contract plan or subcontract plan. Select a specific submission event. Click 

Tools > Validate Submission. The Validation Wizard opens midway to the "Pick a 

Submission" screen. The submission event is selected, and the cost reports with the closest 

As Of Date are listed at the bottom. Click Next to proceed with the wizard. See the 

Validation Wizard Dialog for more information. 

  

Tip: The "Pick a Submission" screen can also be accessed directly from the main window 

of cPet. Select a contract plan and click Tools > Validate Submission. The Validation 

Wizard opens to the "Pick a Submission" screen with the contract plan's first submission 

event selected by default. 

  

The chart below shows the steps involved in different validation methods as well as the end 

result of each. Follow the black line to see how the Validation Wizard runs from start to 

finish. Both Validating a Submission methods start in the middle of the Validation Wizard 

with the "Pick a Submission" screen, but they eventually lead to the validation results and 

letter. The Validating an Individual Document leads directly to the validation results without 

generating a letter. The Validating a single cost report option (following the red line) also 

leads to the validation results without the memo files. 

  

See key below for the color scheme. 
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    Key 
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2.3.10 VALIDATION RULES 

The following is a list of checks that cPet performs when validating a cost report. The list is 

organized into requirements for a 1921, 1921-1 and 1921-2. Click on a link to see the details 

associated with each validation check. 

  

Tip: In several of the validation descriptions below, tables are used to explain how rows or 

columns are summed. The blue fields sum to the green fields. 

  

 

  

Tip: Numeric validation checks are based on a 0.2 digit tolerance (disregarding units). 

  

For a particular WBS Element, the following must be true: 

  

1921 

Each WBS Element must have a Code 

The Program Name on the 1921 must match the Program Name on the Contract Plan 

The Approved Plan Number on the 1921 must match the Approved Plan Number on the 

Contract Plan 

The WBS on the 1921 should match the WBS on the Contract Plan 

The WBS Element names must match 

Child elements must sum to the parent element 

The NonRecurring/Recurring/Total figures must sum correctly 

Summary elements must sum correctly 

The Reporting Contractor G&A must be nonzero at completion 

The Reporting Contractor Profit/Loss or Fee must be nonzero at completion 

The To Date figures must be less than or equal to the At Completion figures 

All figures must be positive 

The Reporting Contractor FCCM must be nonzero at completion 
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Final report Undistributed Budget must have zero cost at completion 

Final report Management Reserve must have zero cost at completion 

Final report Total Price To Date cost must be at least 95% of the At Completion cost 

Final report root element To Date cost must be at least 95% of the At Completion cost 

The contract price must be numeric 

The contract ceiling must be numeric 

SE/PM must be non-zero at completion 

Remarks required for contract price overrun or underrun 

  

  

1921-1 

Each WBS Element must have a Code 

Duplicate data should not be provided 

 The Program Name on the 1921-1 must match the Program Name on the Contract Plan 

The Approved Plan Number on the 1921-1 must match the Approved Plan Number on the 

Contract Plan 

The WBS Element names must match 

All WBS Elements found on the 1921-1 must also be on the 1921 and the Contract Plan 

The 1921-1 must include required elements whose costs match those on the 1921 

The Quantity field must match 

The NonRecurring/Recurring/Total figures must sum correctly 

The Group within the data column must sum correctly 

The Data columns must sum correctly 

The Contractor/Subcontractor/Total figures must sum correctly 

Data in the Direct Labor Hours row, the Direct Labor Dollars row, and the Overhead row 

must agree 

The To Date figures must be less than or equal to the At Completion figures 

All figures must be positive 

Remarks required for reports with Total Direct-Reporting Subcontractor data 
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Remarks required if Other Costs Not Shown Elsewhere are greater than or equal to x% of 

Total Costs 

  

1921-2 

Program Name on 1921-2 must match Program Name on Contract Plan 

Approved Plan on 1921-2 must match Approved Plan on Contract Plan 

WBS Element Code must not be blank 

Duplicate WBS Element Codes are not allowed 

WBS Element Code must be on the Contract Plan 

All Required Reporting Elements on the Contract Plan must be included in the 1921-2 file 

WBS Element Name must match WBS Element Name on Contract Plan 

WBS Element Code must be on 1921 report 

Total Direct Recurring Costs reported To Date on the 1921-2 must match corresponding 

Recurring Costs To Date reported on the 1921-1 Report 

Negative values are not permitted on the 1921-2 report 

Sum of reported costs and hours for Completed Units/Lots (Column(s) A) and Work in 

Process (Column B) must equal Total Direct Costs and Hours To Date (Column C) 

Sum of costs reported for 1921-2 functional categories must equal Total Cost of functional 

category 

Sum of costs reported for 1921-2 functional categories and Other Direct Costs must equal 

Total Direct Cost (Line 22) 

Direct Dollars reported for a 1921-2 functional category, must have Direct Hours and vice 

versa 

Comments must be included if costs are reported on the 1921-2 for Total Direct Reporting 

Subcontractors 

Other Direct Costs Not Shown Elsewhere should be less than 10% of total cost (2011 

Version) or 15% (2007 Version) 

  

View 1921-3 validation errors and explanations. 
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1921 

  

Each WBS Element must have a Code 

Every element must be assigned a unique WBS Element Code. There cannot be several 

different WBS element names that all share the same code. 

  

The Program Name on the 1921 must match the Program Name on the Contract Plan 

The 1921 and the contract plan must have the same program name. 

  

The Approved Plan Number on the 1921 must match the Approved Plan Number on the 

Contract Plan 

The 1921 and the contract plan must have the same Approved Plan Number. 

  

The WBS on the 1921 should match the WBS on the Contract Plan 

All WBS elements on the contract plan should appear on the 1921. Even if they are not 

required according to the contract plan's WBS Editor, they should still be included on the 

1921 with zero costs. 

  

Depending on whether a WBS Element is required or not and if the 1921 reports data for that 

element, cPet may or may not issue a warning. Please see the chart below for areas where 

cPet will provide a validation error. 
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The WBS Element names must match 

For a particular element code, the element name must be the same on the 1921 as it is on the 

contract plan. 

  

Child elements must sum to the parent element 

The cost of a parent element must equal the total cost of all its children elements. This must 

be true for each column (i.e. To Date and At Completion values for Nonrecurring, Recurring, 

and Total costs columns). In the table below, the two blue fields must sum to the green field. 

  

 

  

  

The NonRecurring/Recurring/Total figures must sum correctly 

The Nonrecurring and Recurring costs must sum to the Total cost for each element. This 

must be true for both the To Date data and the At Completion data. 



Tutorials 

85 

  

 

  

Summary elements must sum correctly 

Certain summary elements must sum to other elements. These rules are different for 2003 

reports than 2007/2011. See below for specific details. 

  

* Note: Each rule applies to both Total To Date and Total At Completion costs. 

* Note: The Root Element is the top-most parent element of the WBS structure. 

  

2003 Reports 
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2007 and 2011 Reports 
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The Reporting Contractor G&A must be nonzero at completion 

There should be a cost in the Total At Completion column for the summary element 

"Reporting Contractor G&A." 

  

The Reporting Contractor Profit/Loss or Fee must be nonzero at completion 

There should be a cost in the Total At Completion column for the summary element 

"Reporting Contractor Profit/Loss or Fee." For 2003 1921's, this element is referred to as 

"Reporting Contractor's Profit or Fee." 

  

The To Date figures must be less than or equal to the At Completion figures 

For each Nonrecurring, Recurring, or Total cost, the To Date value must be less than or equal 

to the At Completion value. 
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All figures must be positive 

All cost and non-cost items must have positive values. 

  

The Reporting Contractor FCCM must be nonzero at completion 

The summary element "Reporting Contractor FCCM" must have a non-zero Total At 

Completion cost. 

  

Final report Undistributed Budget must have zero cost at completion 

If the Report Cycle on the 1921 Basic Info is marked as "Final," then the summary element 

"Reporting Contractor Undistributed Budget" Total At Completion cost must be zero. Does 

not apply to 2003 1921's. 

  

Final report Management Reserve must have zero cost at completion 

If the Report Cycle on the 1921 Basic Info is marked as "Final," then the summary element 

"Reporting Contractor Management Reserve" Total At Completion cost must be zero. Does 

not apply to 2003 1921's. 

  

Final report Total Price To Date cost must be at least 95% of the At Completion cost 

If the Report Cycle on the 1921 Basic Info is marked as "Final," then the summary element 

"Total Price" Total To Date cost must be at least 95% of the Total At Completion cost. Does 

not apply to 2003 1921's. 

  

Final report root element To Date cost must be at least 95% of the At Completion cost 
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If the Report Cycle on the 1921 Basic Info is marked as "Final," then the root element (e.g. 

top level element) To Date cost must be at least 95% of the At Completion cost. This rule 

applies to Nonrecurring, Recurring, and Total costs. Does not apply to 2003 1921's. 

  

The contract price must be numeric 

The contract price on the Basic Info of a 1921 must be a number, empty, or "N/A." 

  

The contract ceiling must be numeric 

The contract ceiling on the Basic Info of a 1921 must be a number, empty, or "N/A." 

  

SE/PM must be non-zero at completion 

The Systems Engineering/Program Management WBS element must have a non-zero Total 

At Completion cost. 

  

Remarks required for contract price overrun or underrun 

The contractor should report a total price at completion that is equal to the contract price, or 

for incentive contracts, is between the contract price and the contract ceiling. If the contract 

price represents an underrun or an overrun, an explanation must be provided in the Remarks 

section. Note that cPet does not check whether or not there is text in the Remarks section; 

rather, cPet is merely providing a warning that remarks should be provided for this situation. 

Also note that for 2003 1921's, the "Total Price" is considered equivalent to the "Total Cost 

(Through Reporting Contractor's G&A & Profit or Fee)" summary element. 

  

The following table outlines different scenarios that cPet uses to validate this rule, where TP 

= Total Price, CP = Contract Price, and CC = Contract Ceiling. 

  

Condition Result cPet Error Description 

TP < CP and CC = 0 Warning Total price at completion is less 

than contract price. Remarks 

required. 
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TP > CP and CC = 0 Warning Total price at completion is 

greater than contract price. 

Remarks required. 

TP = CP and CC = 0 OK -- 

CC > TP > CP OK -- 

CC < TP < CP Warning Total Price at completion is less 

than contract price. Remarks 

required. 

  

  

1921-1 

  

Each WBS Element must have a Code 

Every element must be assigned a unique WBS Element Code. 

  

Duplicate data should not be provided 

For 2003 cost reports, there should be only one page per element. For example, an element 

cannot have two recurring pages. For 2007 and 2011 reports, this rule extends to the more 

general requirement that an element should not appear on the 1921-1 more than once. 

  

The Program Name on the 1921-1 must match the Program Name on the Contract Plan 

The 1921-1 and the contract plan must have the same program name. 

  

The Approved Plan Number on the 1921-1 must match the Approved Plan Number on the 

Contract Plan 

The 1921-1 and the contract plan must have the same Approved Plan Number. 

  

The WBS Element names must match 

For a particular element code, the element name must be the same on the 1921-1 as it is on 

the contract plan. 
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All WBS Elements found on the 1921-1 must also be on the 1921 and the Contract Plan 

All elements on the 1921-1 must appear on the parent 1921. In addition, all elements on the 

1921-1 must be on the contract plan. 

  

The 1921-1 must include required elements whose costs match those on the 1921 

If the contract plan requires a WBS Element, the 1921-1 must include that element. An 

exception to the rule is if the parent 1921 has zero costs. In this case, a 1921-1 need not be 

provided. However, if a 1921-1 is provided, the costs between the 1921 and 1921-1 must 

match (see table below). 

  

Depending on whether a WBS Element is required or not and if the 1921-1 reports data for 

that element, cPet may or may not issue a warning. Please see the chart below for areas 

where cPet will provide a validation error. 

  

 

  

Another important validation rule that cPet uses for 2003 reports is the 95/5 Rule. If either 

the Nonrecurring cost or the Recurring cost is greater than 95% of the Total cost of the 1921 
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(in the At Completion columns), then the 1921-1 can report zero NonRecurring and 

Recurring costs. Even if the corresponding costs on the 1921 are non-zero, the NonRecurring 

and Recurring costs may be zero on the 1921-1. However, if the costs for either of these 

categories is nonzero on the 1921-1, cPet must still verify that the costs match between the 

1921 and the 1921-1. 

  

  

The Quantity field must match 

The Number of Units/Quantity fields must match between the 1921 and the 1921-1. When 

validating this rule for 2003 documents, cPet looks at the value on the Total page alone (i.e. 

the NonRecurring and Recurring pages are not validated). 

  

Furthermore, a validation check is performed for the quantity field across pages of a 2003 

1921-1. The rules are summarized below: 

  

If the 1921 is not present, do not validate the quantities. 

If the 1921 is present, and the 95/5 does not apply, ensure the quantities are 

consistent. 

If the 1921 is present, and the 95/5 rule does apply, raise a warning only if the 

Nonrecurring quantity (and/or the Recurring quantity) is not blank and is not consistent 

with the Total quantity. 

  

The table below outlines some of the possible cases: 
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The NonRecurring/Recurring/Total figures must sum correctly 

The figure in the NonRecurring column and the figure in the Recurring column must sum to 

the figure in the Total column for each cost category. Note: This validation rule applies to 

2007 and 2011 documents only. 

  

 

  

  

The Group within the data column must sum correctly 

The cost data in a column must sum to the total figure for each cost category (e.g. Total 

Engineering Dollars). 
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The Data columns must sum correctly 

The sum of the total figures of each cost category (e.g. Total Engineering Dollars + Total 

Manufacturing Dollars +...) must equal the Summary Total Cost for each column. 
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The Contractor/Subcontractor/Total figures must sum correctly 

This validation rule applies to 2003 1921-1's only. For any given row, the To Date figure for 

the Reporting Contractor and the Subcontractor must sum to the To Date figure in the Total 

column. The same must be true for the At Completion values. 

  

 

  

  

  

Data in the Direct Labor Hours row, the Direct Labor Dollars row, and the Overhead row 

must agree 

For each cost category (e.g. Engineering, Manufacturing, etc.) and each column, the 

following must be true: 

  

1) If there is data in the "Direct Labor Hours" category for a WBS Element, then there must 

be data in the "Direct Labor Dollars" category for that element (or vice versa). 

  

2) If there is data in the "Direct Labor Dollars" category for a WBS Element, then there must 

be data in the "Overhead" category for that element (or vice versa). 

  

For 2007 and 2011 documents, these rules apply to all direct labor categories. For example, if 

there is a value in the Direct Manufacturing Labor Dollars category, then there must also be a 

value in the Direct Manufacturing Labor Hours category as well as the Manufacturing 

Operations Overhead Dollars category. 

  

The To Date figures must be less than or equal to the At Completion figures 
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For a particular cost row, the To Date figure must be less than or equal to the At Completion 

value for the Reporting Contractor columns, the Subcontractor columns, and the Total 

columns. 

  

 

  

All figures must be positive 

All cost and non-cost items must have positive values. 

  

Remarks required for reports with Total Direct-Reporting Subcontractor data 

If there are costs on Line 18 "Total Direct-Reporting Subcontractor Dollars," then an 

explanation should be provided in the Remarks section. These remarks should include the 

subcontractor name, city, state, and the corresponding subcontract prices for each direct 

reporting subcontractor. Note that cPet does not validate whether or not there is text in the 

Remarks section; rather, cPet is merely providing a warning that remarks should be provided 

for this situation. Does not apply to 2003 1921-1's. 

  

Remarks required if Other Costs Not Shown Elsewhere are greater than or equal to x% of 

Total Costs 

For 2003 and 2007 reports, if the costs in Line 20 ("Other Costs Not Shown Elsewhere") are 

greater than or equal to 15% of the Total Cost in Line 21, then an explanation should be 

provided in the Remarks section. For 2011 reports, remarks should be provided if Line 20 

costs are greater than or equal to 10% of Line 21 costs. These remarks should include 

information regarding the cost composition and should identify each of the costs comprising 

Line 20 as direct or overhead. Note that cPet does not validate whether or not there is text in 

the Remarks section; rather, cPet is merely providing a warning that remarks should be 

provided for this situation. 
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1921-2 

  

Program Name on 1921-2 does not match Program Name on Contract Plan 

The Program Name on the 1921-2 must match the Contract Plan. 

  

Approved Plan on 1921-2 does not match Approved Plan on Contract Plan 

The Approved Plan Number on the 1921-2 must match the Contract Plan. 

  

Blank WBS Element Code found for reporting elements on 1921-2 

One or more WBS elements are missing a WBS element code on the 1921-2 form.  View the 

Reading Pane to see the corresponding element names. 

  

Duplicate WBS Element Code found for reporting elements on 1921-2 

Duplicate WBS element codes were found to be listed more than once on the 1921-2 file. 

 This error may also be triggered if two different WBS elements share a single code. 

  

WBS Element Code not found on Contract Plan 

There is WBS Element Code on the 1921-2 form that is not found on the Contract Plan.  

  

Required Reporting Element omitted from 1921-2 file 

A WBS element that has a requirement for 1921-2 reporting in Column 13d (1921-2) on the 

Contract Plan. 

  

WBS Element Name does not match WBS Element Name on Contract Plan 

The WBS Element Name reported on the 1921-2 does not match the Element Name on the 

Contract Plan.  The issue is, most likely, due to misspelling or slight modifications to the 

Element Name. 

  

WBS Element Code from 1921-2 report not found on 1921 report 
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There is WBS Element Code on the 1921-2 form that is not found on the 1921 report.  

  

Total Direct Recurring Costs reported To Date on the 1921-2 do not match corresponding 

Recurring Costs To Date reported on the 1921-1 Report 

Total Direct Recurring Costs and Hours To Date (Column C) reported on the 1921-2 report 

does not match the Total Recurring Costs and Hours To Date (Column B) reported on the 

1921-1 report for the following corresponding fields: Direct Engineering Labor Hours & 

Dollars, Direct Tooling Labor Hours & Dollars, Direct Quality Control Hours & Dollars, 

Direct Manufacturing Hours & Dollars, Raw Materials Dollars, Purchased Parts Dollars, 

Purchased Equipment Dollars, Total Direct Reporting Subcontract Dollars, Other Direct 

Costs Not Shown Elsewhere. 

  

Negative costs found on 1921-2 report 

Negative values are not permitted on the 1921-2 report unless accompanied by a comment in 

the Remarks section. 

  

Sum of reported costs and hours for Completed Units/Lots (Column(s) A) and Work in 

Process (Column B) does not equal Total Direct Costs and Hours To Date (Column C) 

For each row on the 1921-2 report, Columns A plus B, must equal C for both costs and 

hours. 

  

Sum of costs reported for 1921-2 functional categories does not equal Total Cost of 

functional category 

Line 15 (Total Direct Manufacturing Operations Dollars) must equal the sum of Lines 9, 10, 

12, and 14).  Line 20 (Total Direct Material Dollars) must equal the sum of Lines 16, 17, 18, 

and 19. 

  

Sum of costs reported for 1921-2 functional categories and Other Direct Costs does not 

equal Total Direct Cost (Line 22) 

Line 22 (Total Direct Cost) must be equal to the sum of Lines 7, 15, 20, and 21. 
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Direct Dollars reported for a 1921-2 functional category, without Direct Hours and vice 

versa 

For each functional category on the 1921-2 (Engineering, Tooling, Quality Control, and 

Manufacturing), if hours are reported, dollars must also be reported, and vice versa. 

  

Cost reported on the 1921-2 for Total Direct Reporting Subcontractors 

If costs are reported in Line 19 (Total Direct-Reporting Subcontractor Dollars), then a 

comment must be included in the Remarks section with information on the subcontractor’s 

name and total dollar value of the contract. 

  

Other Direct Costs Not Shown Elsewhere are greater than 10% of total cost (2011 Version) 

or 15% (2007 Version) 

If costs reported in Line 21 (Other Direct Costs Not Shown Elsewhere) pass the threshold, 

then a comment in required in the Remarks section of the 1921-2 report. 

  

  

1921-3 Validation Errors and Explanations 

  

Duplicate Sections A & B provided for Fiscal Year 

The prior, current and future years must all be submitted on separate worksheets in one Excel 

file.  Each 1921-3 submission must contain the following:  Sections A and B (Page 1) must 

be completed for the Prior Year, Current Year, and at least three future years.  Sections C – F 

(Page 2) must only be completed once for each submission. 

  

Sections A & B not provided for Prior Year, Current Year, and/or Previous Fiscal Year 

Sections A and B (Page 1) must be completed for the Prior Year, Current Year, and at least 

three future years. 

  

Reported figure is negative 
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All costs and hours must be reported in thousands, rounded to the nearest tenth.  If costs or 

hours are negative, there must be an explanation in the Remarks section. 

  

Costs for other efforts are greater than or equal to 15% of Total Cost 

Lines 11 (Other DoD Effort), 12 (Other Government Effort), or 13 (Commercial Effort) that 

equal 15% or more of the total dollars or hours in Line 14 (Total Direct Costs and Hours 

Base), details of the composition of these lines must be provided in the Remarks section. 

  

Line 14 (Total Direct Costs and Hours Base) does not equal the sum of Lines 1-13 

Line 14 must be the sum of all costs or hours reported for that column in Lines 1 – 13. This 

must be provided in Line 14 in Columns f, g, i, j, k, m, and n. 

  

Line 14a (Total Direct Workers) not reported 

Line 14a must be the average number of employees in the FPR unit for each year reporting. 

The average is the sum of the employees at the end of each month divided by the number of 

months being reported. The total direct workers must include all direct workers in the FPR 

unit and may not equal the sum of the rows. 

  

Costs reported for Other functional category 

If the contractor reports cost, hours or manpower for an additional functional category in 

Columns l, m, or n, the other functional cost categories must be identified in the Remarks 

section. 

  

Costs reported for Other Miscellaneous are greater than or equal to 15% of Total Cost 

If reported costs or hours in Line 25 (Other Miscellaneous) in Columns p, q, s, t, u, w, x, y, or 

z are more than 15% of the hour or dollar totals  provided in Lines 27 or 28, details on the 

composition of Line 25 (Other Miscellaneous) must be provided in the Remarks section. 

  

Total Indirect Costs and Hours do not equal the sum of costs or hours reported 
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Line 27 (Total Indirect Costs and Hours) must equal the sum of all costs or hours reported for 

that column in Lines 15 – 26. This must be provided in Line 27 in Columns p, q, s, t, u, w, 

and x. cPet should classify this as an error. 

  

Total G&A Costs and Hours do not equal the sum of costs or hours reported 

Line 28 (Total G&A Costs and Hours) must equal the sum of lines 15 – 26 in Columns y and 

z. 

  

Indirect/Direct Cost Rate does not match calculated cost rate 

Line 29 is calculated by dividing the indirect costs in Line 27 (Total Indirect Cost and Hours) 

by the direct costs in Line 14 (Total Direct Cost and Hours).  If the calculated number is 

different from the contractor calculated rate, which may have applied another methodology 

for calculating indirect rates, then cPet will provide a “warning” and the contractor must 

provide the methodology used and calculations in the Remarks section. 

  

G&A Rate/Direct + Indirect does not match calculated cost rate 

Line 30 is calculated in Column Y by dividing the G&A costs in Line 28 in Column y by the 

total direct (Line 14, Columns f, I, k, and m) and indirect costs (Line 27, Columns p, s, u, and 

w).   The contractor is permitted to calculate G&A using a different methodology, if they 

provide the method and calculation in the Remarks section. 

  

Total FPR Unit Revenue not reported 

Section E (Total FPR Unit Revenue Sales) should exceed costs--if applicable, for a certain 

fiscal year. By taking the sum of all direct (Section A, Line 14, Columns f, I, k, and m)  and 

indirect (Section B, Line 27, Columns p, s, u, and w, Line 28, Column Y) costs from the page 

1 for the prior or current year, and checking that the sum of all costs on page 1 does not 

exceed FPR Unit Revenue for the prior or current year. Thus, if a large loss is reported, the 

contractor could be asked to ensure this is correct and to provide an explanation in the 

Remarks section. 
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Dollars reported without associated Hours, Hours reported without associated Dollars 

If labor dollars are reported, then labor hours must also be reported.  If labor hours are 

reported, then labor hours must also be reported. 

  

Hours reported without associated Workers, Workers reported without associated Hours 

If workers are reported, then labor hours must also be reported.  If labor hours are reported, 

then workers must also be reported. 

  

Reported hours per worker are greater than 2,500 

If the number of workers is divided by the number of hours, and the number of hours per 

employee is greater than 2500 per year, cPet will generate a warning.  An explanation in the 

Remarks section should be included. 

  

Reported Dollars per Hour are greater than 1,000 

If the calculated labor rate exceeds $1,000/hour, cPet will generate a warning.  If the rate is 

correct, the contractor should include an explanation in the Remarks section. 

  

Reported Hours per Worker are greater than 10,000 

If the calculated hours per worker exceed 10,000 hours, cPet will generate a warning.  If the 

figure is correct, the contractor should include a comment in the Remarks section. 

  

Labor rates from Section D do not match labor costs from Sections A 

The labor rates reported in Section D (Direct Labor Rates) should be the same as labor costs 

reported in Section A (Direct Cost Categories).  If not, cPet will generate a warning and the 

contractor should include an explanation in the Remarks section. 
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3: DIALOGS 

 

3.1 1921 BASIC INFO DIALOG 

The DD Form 1921, "Cost Data Summary Report," provides cost data from contractors for 

both recurring and nonrecurring costs. The Basic Info window displays the information 

relevant to the contractor and the associated contract plan. Four pages outline the header 

information found on the DD 1921, and a brief description of each is provided below. Please 

click a link below to view information pertaining to the appropriate version of the document 

and the desired page number. 

  

2003 DID                                  2007 DID                            2011 DID 

Page 1                                      Page 1                       Page 1 

Page 2                                      Page 2                       Page 2 

Page 3                                      Page 3                       Page 3 

Page 4                                      Page 4                       Page 4 

  

  

2003 DID 

  

Page 1 

  

The DD 1921 shares the same Program Name (Item 1a) as the program plan and contract 

plan. 

  

The Approved Plan Number (Item 1b) is the number assigned to the contract plan or 

subcontract plan for which the data are reported. 

  

The Dollars In field (Item 2) represents the units of the cost data. The Dollars In is typically 

in thousands of dollars. 

  

The Type Action (Item 3) is either Contract, RFP, or Program Estimate. Choosing one of 

these radio buttons causes different fields to be displayed. 
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If the Type Action is Contract, enter the Contract Number and the Latest Amendment 

Number of the contract plan for which the data are reported. 

  

Page 2 

  

The Appropriation (Item 4) refers to the contract funding: either RDT&E (Research, 

Development, Test, and Evaluation) or Procurement. If the funding is neither RDT&E nor 

Procurement, click "Other" and type details of the funding in the text field to the right. 

  

Click Multi-Year Contract if the contract is funded for several fiscal years. 

  

The Report As Of (Item 5) is the date of the submission event for which the data are 

reported. This date follows the MM/DD/YY format. 

  

The Contract Price Estimate (Item 9) is the cost of the contract through the Report Date. 

  

Enter the Contract Ceiling (Item 10) for the contract. 

  

The Contractor Type (Item 11a) is either Prime or Associate, or Subcontractor depending 

on the contract plan associated with the 1921. 

  

Page 3 

  

The Contractor Name and Address (Item 11b) is the contact information for the (prime or 

sub) contractor. 

  

The Customer Name (Item 12) is the name of the prime contractor responsible for the 

subcontractor. Leave blank if the report is submitted by the prime contractor. 

  

The Point of Contact Information, i.e. the POC Name (Item 14a), Department (Item 14b), 

E-mail (Item 14d), and Phone/Fax (Items 14c and 14e), is the contact information for the 

individual who prepared the report. 

  

  

Page 4 

  

The Remarks (Item 13) section provides an area for any other information that might be 

relevant to the data or the report in general. 

  

  

2007 DID 

  

Page 1 
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The DD 1921 shares the same Program Name as the program plan and contract plan. The 

name corresponds to Item 1a "MDAP" of the DD Form 1921. 

  

The Phase (Item 1b) is one of the following four: 

A (Technology development) 

B (System Development and Demonstration) 

LRIP (Low-rate Initial Production) 

Production (Full-rate Production) 

  

The Prime Mission Product (Item 2) is the military designation or the type of product. 

  

The Contractor Type (Item 3) is either Prime/Associate, or Subcontractor depending on the 

contract plan associated with the 1921. 

  

The Contractor Name and Address (Item 4) is the contact information for the (prime or 

sub) contractor. 

  

The Customer Name (Item 6) is the name of the prime contractor responsible for the 

subcontractor. Leave blank if the report is prepared by the prime contractor. 

  

Page 2 

  

The Contract Type (Item 7) must be one of the following nineteen: 

CS - Cost Sharing 

CPAF - Cost Plus Award Fee 

CPFF - Cost Plus Fixed Fee 

CPIF - Cost Plus Incentive Fee 

CPIF(PI) - Cost Plus Incentive Fee (With Performance Incentives) 

FFP - Firm Fixed Price 

FPIF - Fixed Price Incentive, Firm Target 

FPIST - Fixed Price Incentive, Successive Targets 

FPIST(PI) - Fixed Price Incentive, Successive Targets (With Performance 

Incentive) 

FPIFT(PI) - Fixed Price Incentive, Firm Target (With Performance Incentive) 

FPAF - Fixed Price Award Fee 

FP/EPA - Fixed Price with Economic Price Adjustment 

FP/PPR - Fixed Price with Prospective Price Redetermination 

FP/RPR - Fixed Ceiling Price with Retroactive Price Redetermination 

FFP/LOET - Firm Fixed Price, Level of Effort Term 

LC - Letter Contract and Undefinitized Contractual Action (UCA) 

OC - Other Contracts 

MC - Contracts with multiple Contract Types by Contract Line Item Numbers 

(CLINS) 

NA - Not Applicable 
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The Contract Price (Item 8) is the cost of the contract through the Report Date. 

  

Enter the Contract Ceiling (Item 9) for the contract. 

  

The Type Action block corresponds to Item 10 on the DD 1921. The Contract Number 

(Item 10a) is that of the associated contract plan. The Latest Modification (Item 10b) is the 

number of the most recent contract modification. The Solicitation Number (Item 10c) is 

used for data relating to a solicitation according to the Defense Federal Acquisition 

Regulation Supplement (DFARS) 215.403-5. The Name (Item 10d) corresponds to that of 

the associated contract plan. 

  

The Appropriation (Item 12) is either RDT&E (Research, Development, Test and 

Evaluation), Procurement, or O&M (Operating and Maintenance). The Appropriation 

represents the contract funding. If the funding comes from multiple sources, check the 

appropriate boxes and note the percentage breakdown in the remarks section of Page 4. 

  

The Start Date (Item 11a) and End Date (Item 11b) correspond to the time frame of the 

Period of Performance. The dates must be entered in YYYYMMDD format in order to 

import correctly into cPet. 

  

Page 3 

  

The Report Cycle (Item 13) is either Initial, Interim, or Final. The Initial Report represents 

the groundwork for the 1921 and serves the purpose of presenting the data in accordance 

with the Data Item Description. The Interim Report is any report submitted between the 

Initial and Final stages. The Final Report represents the complete 1921 report. 

  

The Approved Plan Number (Item 5) is the number assigned to the contract plan or 

subcontract plan. 

  

The Submission Number (Item 14) is the submission event number for which the data are 

reported. 

  

The Resubmission Number (Item 15) represents the number of times the DD 1921 has been 

submitted. The original submission is marked by "0," and the first resubmission by "2." 

  

The Report As Of (Item 16) is the date of the submission event for which the data are 

reported. The date must be entered in YYYYMMDD format in order to import correctly into 

cPet. 

  

The Point of Contact Information, i.e. the Name (Item 17), Department (Item 18), E-mail 

(Item 20), and Phone (Item 19), is the contact information for the individual who prepared 

the report. The Date Prepared (Item 21) is the date corresponding to the 1921. The date 

must be entered in YYYYMMDD format in order to import correctly into cPet. 
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Page 4 

  

The Remarks (Item 22) section provides an area for any other information that might be 

relevant to the data or the report in general. 

  

2011 DID 

Page 1 

The DD 1921 shares the same Program Name as the program plan and contract plan. The 

name corresponds to Item 1a "Major Program" of the DD Form 1921. 

  

The Phase (Item 1b) is one of the following four: 

               Pre-A (Material Solution Analysis) 

A (Technology development) 

B (Engineering and Manufacturing Development) 

C-LRIP (Low-Rate Initial Production) 

C-FRP (Production and Deployment - Full-rate Production) 

O&S (Operations and Support) 

  

The Approved Plan Number (Item 5) is the number assigned to the contract plan or 

subcontract plan. 

  

The Submission Number (Item 14) is the submission event number for which the data are 

reported. 

  

The Resubmission Number (Item 15) represents the number of times the DD 1921 has been 

submitted. The original submission is marked by "0," and the first resubmission by "2." 

  

The Report As Of (Item 16) is the date of the submission event for which the data are 

reported. The date must be entered in YYYYMMDD format in order to import correctly into 

cPet. 

  

The Report Cycle (Item 13) is either Initial, Interim, or Final. The Initial Report represents 

the groundwork for the 1921 and serves the purpose of presenting the data in accordance 

with the Data Item Description. The Interim Report is any report submitted between the 

Initial and Final stages. The Final Report represents the complete 1921 report. 

  

The Point of Contact Information, i.e. the Name (Item 17), Department (Item 18), E-mail 

(Item 20), and Phone (Item 19), is the contact information for the individual who prepared 

the report. The Date Prepared (Item 21) is the date corresponding to the 1921. The date 

must be entered in YYYYMMDD format in order to import correctly into cPet. 

  

  

Page 2 
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The Reporting Organization Type (Item 3) is either Prime/Associate Contractor, or Direct-

Reporting Subcontractor, or Government depending on the contract plan associated with the 

1921. 

  

The Performing Organization Name and Address (Item 4a) is the contact information for 

the (prime or sub) contractor. 

  

The Division Name and Address (Item 4b) displays the name of the contractor division and 

location. 

  

The Customer Name (Item 6) is the name of the prime contractor responsible for the 

subcontractor. Leave blank if the report is prepared by the prime contractor. 

 

Page 3 

The Contract Type (Item 7) must be one of the following nineteen: 

CS - Cost Sharing 

CPAF - Cost Plus Award Fee 

CPFF - Cost Plus Fixed Fee 

CPIF - Cost Plus Incentive Fee 

CPIF(PI) - Cost Plus Incentive Fee (With Performance Incentives) 

FFP - Firm Fixed Price 

FPIF - Fixed Price Incentive, Firm Target 

FPIST - Fixed Price Incentive, Successive Targets 

FPIST(PI) - Fixed Price Incentive, Successive Targets (With Performance 

Incentive) 

FPIFT(PI) - Fixed Price Incentive, Firm Target (With Performance Incentive) 

FPAF - Fixed Price Award Fee 

FP/EPA - Fixed Price with Economic Price Adjustment 

FP/PPR - Fixed Price with Prospective Price Redetermination 

FP/RPR - Fixed Ceiling Price with Retroactive Price Redetermination 

FFP/LOET - Firm Fixed Price, Level of Effort Term 

LC - Letter Contract and Undefinitized Contractual Action (UCA) 

TM - Time and Materials 

OC - Other Contracts 

MC - Contracts with multiple Contract Types by Contract Line Item Numbers 

(CLINS) 

NA - Not Applicable 

  

The Contract Price (Item 8) is the cost of the contract through the Report Date. 

  

Enter the Contract Ceiling (Item 9) for the contract. 

  

The Type Action block corresponds to Item 10 on the DD 1921. The Contract Number 

(Item 10a) is that of the associated contract plan. The Latest Modification (Item 10b) is the 

number of the most recent contract modification. The Solicitation Number (Item 10c) is 
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used for data relating to a solicitation according to the Defense Federal Acquisition 

Regulation Supplement (DFARS) 215.403-5. The Name (Item 10d) corresponds to that of 

the associated contract plan. The Order/Lot Number (Item 10e) field contains (if 

applicable) the task order (TO), delivery order (DO), or Lot Number (Lot), followed by the 

number. 

  

The Appropriation (Item 12) is either RDT&E (Research, Development, Test and 

Evaluation), Procurement, or O&M (Operating and Maintenance). The Appropriation 

represents the contract funding. If the funding comes from multiple sources, check the 

appropriate boxes and note the percentage breakdown in the remarks section of Page 4. 

  

The Start Date (Item 11a) and End Date (Item 11b) correspond to the time frame of the 

Period of Performance. The dates must be entered in YYYYMMDD format in Excel in 

order to import correctly into cPet. 

  

Page 4 

The Remarks (Item 22) section provides an area for any other information that might be 

relevant to the data or the report in general. 

  

  

For a more detailed explanation of the header fields, see the following Data Item 

Descriptions: 

  

2007 DD Form 1921-2 Data Item Description 

2011 DD Form 1921-2 Data Item Description  

  

  

  

3.2 1921 COST DATA 

The Cost Data dialog can be reached by selecting the 1921 and clicking the  icon. 

  

The Contract Line Item (found only on 2003 1921s) corresponds to a particular WBS 

Element. 

  

The Reporting Elements correspond to the WBS Elements on the 1921. These elements 

should match the affiliated contract plan's WBS elements where a 1921 is required. 

  

The WBS Element Code corresponds to the code of that element on the contract plan. 

  

http://cade.osd.mil/CSDR/ArchiveForms.aspx
http://cade.osd.mil/CSDR/FormsReporting.aspx
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The Number of Units To Date/At Completion represents the total units. On 2003 1921s, 

the units are formatted as xx/xx, where the first number is the units produced and given to the 

government. The second number is the units that the contractor will use when carrying out 

the contract. For 2007 1921s, see the 2007 DID for calculating the number of units. 

  

The Costs Incurred To Date and At Completion are subdivided into three categories: 

Nonrecurring costs, Recurring costs, and Total costs. For each WBS element, the 

Nonrecurring and Recurring figures must sum to the Total figure. Furthermore, the costs for 

children elements must sum correctly to the cost of the parent element. The cost To Date 

must be less than or equal to the cost At Completion. For a complete list of requirements 

pertaining to the cost data, see Validation Rules. 

  

Tip: For more information, see the 2007 DID and 2011 DID. 

  

Use the following icons when importing or exporting cost data (Note: This feature is useful 

when creating a new 1921). This feature is only available for 2003 and 2007 1921's. 

  

Create an Excel template file based on the WBS elements and the cost columns (e.g. 

Nonrecurring To Date) 

  

Export the cost data to the template file that was created using the icon above 

  

Import cost data into cPet from a template file 

  

  

3.3 1921 COST REPORT COMPARISON 

This dialog appears after an "Earlier" 1921 and a "Later" 1921 have been chosen through the 

Select Reports to Compare dialog. 

The Comparison Options are displayed at the top, followed by the cost data. 

The WBS Tracking legend indicates which WBS elements appear on the Earlier report, the 

Later report, and the contract plan (the "Reference"). If the triangle icon ( or ) is shaded, 

then the WBS element appears on the report (Earlier or Later, respectively). For example, the 

symbol " " indicates that the WBS item is found on the Earlier report but not the Later. 

The shaded rectangle in the center indicates that the element appears on the contract plan. If 

the triangle/rectangle is not shaded, then the WBS element is not present on that report/plan. 

In the example above, the right arrow is not shaded. Thus the WBS element does not appear 

on the Later report. 

http://cade.osd.mil/CSDR/ArchiveForms.aspx
http://cade.osd.mil/CSDR/ArchiveForms.aspx
http://cade.osd.mil/CSDR/FormsReporting.aspx
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The gray areas in the cost data ( ) reinforce the WBS Tracking symbols; the WBS 

element may not appear on one or more report. 

Tip: It may be easier to see where data is missing from a report if you choose Group for 

the Arrangement under the Column Options (see below). 

Uncheck Show Reference WBS if you do not wish to see elements appearing on either 

report, only the contract plan. 

A WBS element with a hyperlink indicates that there is a mismatch between the element 

names. Click on the hyperlink to understand this mismatch in the WBS Naming 

Discrepancies dialog. The element name may be different between the contract plan, the 

Earlier Report, and/or the Later Report. 

Different columns/rows of data will be displayed depending on specified options. For 

instance, you can check which columns to show (# of Units, Nonrecurring, Recurring, and 

Total for both To Date and At Completion). 

 

  

The Columns Options allows you to change the column colors and group the columns in 

different arrangements. 
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You can select how Anomalies are displayed. cPet will indicate an anomaly if the cost from 

the Earlier report is greater than the cost from the Later Report. For instance, if the Earlier To 

Date Recurring is $2,000 and the Later To Date Recurring is $1,000 for a particular WBS 

element, then those costs will be highlighted pink as long as "Highlight anomalies" is 

checked. 

  

 

  

  

3.4 1921 VALIDATION RESULTS 

The Validation Results dialog appears immediately after validating an individual document 

or after running the Validation Wizard. The data is grouped in two categories: 1921 vs 

Contract Plan and 1921 Internal. The first category contains a list of problems with the cost 

data on the 1921 as compared to the contract plan's WBS Editor. The second category 

contains numeric checks on the 1921 itself. 

  

The dialog is laid out in three columns: The Location, Description, and Error Magnitude: 
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The Location column displays the validated item. Each item is marked with either a Warning 

 ( )  or an error  ( ) depending on the severity. The categories which contain no 

problems are marked by  . 

  

The Description column lists the type of error found. Click on an error to view the 

associated details in the Reading Pane at the bottom of the window. You can hide this 

Reading Pane by clicking the  icon at the top of the dialog. 

  

The Error Magnitude represents the difference between related costs. 

  

Tip: For these numeric validations,  only the error with the greatest magnitude will be 

reported for each WBS Element. In fixing the major error, many smaller errors will most 

likely be fixed as well. 

  

Click the Filter icon  to sort the validation results by Location or by Error Magnitude. 

Results are listed by Location by default, which means that within each category (1921 vs 

Contract Plan and 1921 Internal), the errors appear in the order of the elements on the Excel 

file. If you choose to sort by Error Magnitude, then the numeric errors will be listed with the 

error of largest magnitude first. Click Hide Warnings to hide the warnings ( ) and only 

display the errors ( ). 

  

The information found in the Validation Results can be exported to Excel by clicking . 

  

The following table lists some possible errors that may occur when validating a 1921. 
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Validation Results for DD Form 1921 

Error Description 

1921 vs Contract Plan   

Blank WBS Element Code found for reporting 

elements from 1921 

One or more WBS elements do not have an 

element code on the 1921. View the Reading Pane 

to see the corresponding element names. This error 

may occur because a summary element (which 

does not have a code) was misspelled, causing 

cPet to not recognize the element as a summary 

item. Check the 1921 Basic Info to see if cPet 

tagged the item with a flag (indicating summary 

element status). 

Redundant data provided for reporting element 

from 1921 

There is excessive data for a particular WBS 

Element. This error may occur because an element 

is listed on more than one sheet of the Excel file. 

This error may also be triggered because two 

different WBS Element names share a single code. 

Required reporting element omitted from 1921 A WBS Element that is required by the contract 

plan is not found on the 1921. 

Program Name on 1921 does not match 

Program Name on Contract Plan. 

The Program Name should be the same on the 

1921 as on the parent contract plan. 

Approved Plan Number on 1921 does not 

match Approved Plan Number on Contract Plan. 

The Approved Plan Number should be the same 

on the 1921 as on the parent contract plan. 

Required reporting element from 1921 reports 

zero cost for Total At Completion 

A WBS Element that is required by the contract 

plan reports no costs in the Total At Completion 

column of the 1921. All required elements must 

have costs. 

Non-required reporting element from 1921 A WBS Element that is not required by the 

contract plan reports non-zero costs on the 1921. 
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reports non-zero costs Although the WBS of the 1921 should match that 

of the contract plan, the costs should be zero for 

non-required elements. 

Reporting element from 1921 not found on 

Contract Plan 

There is an element on the 1921 that is not found 

on the contract plan's WBS Editor. cPet bases this 

validation check on the element code (as opposed 

to the element name). 

WBS Element Name on 1921 does not match 

WBS Element Name on Contract Plan 

The WBS element name on the contract plan is not 

the same as that on the 1921 for a particular WBS 

element code. This problem is most likely due to 

misspelling or slight modifications to the name. 

1921 Internal   

Child elements do not sum to parent element 

correctly 

The cost of a parent element must equal the sum 

of the cost of all the children elements for each 

cost column (i.e. To Date Non-Recurring). The 

Reading Pane lists the relevant cost column as 

well as the calculate value, reported value, and the 

difference between the two. The reported value is 

the figure listed on the 1921. The calculated value 

is the sum of the children elements, which is a sum 

among all the worksheets of the 1921. Differences 

within 0.2 digits (disregarding the units) are not 

considered errors. See Validation Rules for more 

information. 

NonRecurring/Recurring/Total figures do not 

sum correctly 

The Total must equal the sum of the Non-

Recurring and Recurring figures for a particular 

WBS element. The error details show whether the 

problem occurs in the To Date or At Completion 

column. The calculated value, the reported value, 
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and the difference between the two are also listed. 

See Validation Rules for more information. 

Systems Engineering/Program Management 

reports zero cost at completion 

The Systems Engineering/Program Management 

WBS element must have a non-zero Total At 

Completion cost. 

Summary elements do not sum correctly 

  

Certain rules must be followed when summing 

summary elements. Please see Validation Rules 

for a detailed list of which elements are supposed 

to sum. 

Reporting Contractor G&A reports zero cost at 

completion 

There should be a cost in the Total At Completion 

column for the summary element "Reporting 

Contractor G&A." 

Reporting Contractor Profit/Loss or Fee reports 

zero cost at completion 

There should be a cost in the Total At Completion 

column for the summary element "Reporting 

Contractor Profit/Loss or Fee." 

Reporting Contractor FCCM reports zero cost 

at completion 

The summary element "Reporting Contractor 

FCCM" must have a non-zero Total At 

Completion cost. 

Report marked Final, but Reporting Contractor 

Undistributed Budget does not report zero cost at 

completion (does not apply to 2003 1921's) 

If the Report Cycle on the 1921 Basic Info is 

marked as "Final," then the summary element 

"Reporting Contractor Undistributed Budget" 

Total At Completion cost must be zero. 

Report marked Final, but Reporting Contractor 

Management Reserve does not report zero cost at 

completion (does not apply to 2003 1921's) 

If the Report Cycle on the 1921 Basic Info is 

marked as "Final," then the summary element 

"Reporting Contractor Management Reserve" 

Total At Completion cost must be zero. 

Report marked Final, but total price to date is 

less than 95% of total price at completion (does 

not apply to 2003 1921's) 

If the Report Cycle on the 1921 Basic Info is 

marked as "Final," then the summary element 

"Total Price" Total To Date cost must be at least 
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95% of the Total At Completion cost. 

Report marked Final, but root element cost to 

date is less than 95% of cost at completion (does 

not apply to 2003 1921's) 

If the Report Cycle on the 1921 Basic Info is 

marked as "Final," then the root element (e.g. top 

level element) To Date cost must be at least 95% 

of the At Completion cost. This rule applies to 

Nonrecurring, Recurring, and Total costs. 

Could not interpret contract price The contract price is a field in the Basic Info of the 

1921. The contract price must be a number, empty, 

or "N/A." 

Could not interpret contract ceiling The contract ceiling is a field in the Basic Info of 

the 1921. The contract ceiling must be a number, 

empty, or "N/A." 

Reported figure is negative All figures must have positive values. 

To Date figure is greater than At Completion 

figure 

The To Date cost must be less than or equal to the 

At Completion cost for a given element and 

column (Non-Recurring, Recurring, or Total). See 

Validation Rules for more information. 

Total price at completion is less/greater than 

contract price. Remarks required 

The Total Price at Completion should equal the 

Contract Price. However, if the Contract Ceiling is 

provided, then the Total Price should be between 

the Contract Price and Contract Ceiling. If neither 

of these scenarios is true, then Remarks should be 

reported. 

  

  

3.5 1921-1 BASIC INFO DIALOG 

The DD Form 1921-1, "Functional Cost-Hour Report," provides cost data on both recurring 

and nonrecurring costs organized by functional category. The Basic Information window 

displays the metadata pertaining to the contractor and the report. Several pages outline the 

header information found on the DD 1921-1, and a brief description of each is provided 
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below. Please click a link below to view information pertaining to the appropriate version of 

the document and the desired page number. 

  

2003 DID                                   2007 DID                                2011 DID 

Page 1                                       Page 1                           Page 1 

Page 2                                       Page 2                           Page 2 

            Page 3                           Page 3 

             

  

2003 DID 

  

Page 1 

  

The DD 1921-1 shares the same Program Name (Item 1a) as the program plan and contract 

plan. This is also the same name as on the parent 1921. 

  

The Approved Plan Number (Item 1b) is the number assigned to the contract plan or 

subcontract plan for which the data are reported. 

  

The Report As Of (Item 2) is the date of the submission event for which the data are 

reported. This date follows the MM/DD/YY format. 

  

The FY Funded field (Item 3) corresponds to the fiscal year of the data. 

  

The Dollars In field (Item 5) represents the units of the cost data. The Dollars In is typically 

in thousands of dollars. 

  

The Hours In field (Item 6) represents the units of the labor hours of the cost data. The 

Hours In is typically in thousands of hours. 

  

The Reporting Contractor information (Item 4b) pertains to the POC name and address of 

the contractor reporting the data. 

  

The Type Action (Item 10) is either Contract, RFP, or Program Estimate. Choosing one 

of these radio buttons causes different fields to be displayed. 
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If the data are reported based on a contract estimate, the Type Action is Contract. Enter 

the Contract Number and the Latest Amendment Number of the contract plan for 

which the data are reported. 

  

If the data are reported based on a Request for Proposal, the Type Action is RFP. Enter 

the RFP Number. 

  

If the data are reported based on a program estimate, the Type Action is Program 

Estimate. Enter the Estimate. 

  

The Appropriation (Item 16) refers to the contract funding: either RDT&E (Research, 

Development, Test, and Evaluation) or Procurement. 

  

  

Page 2 

  

The Contractor Type (Item 4a) is either Prime or Associate, Subcontractor, or Subcontract 

(By Reporting Contractor) depending on the contract plan associated with the 1921-1. The 

Subcontract option is for a prime contractor who is preparing data in place of nonreporting 

subcontractors. Different fields appear depending on which contractor type is selected. 

  

For Prime or Associate contractors, there are no additional fields. 

  

For Subcontractors, enter the name of the Prime Contractor (i.e. the Customer; Item 

7a) and the Contract Number of the prime contract plan. 

  

For the Subcontract (By Reporting Contractor) type, enter the Subcontractor Name 

(Item 7b) and Address (Item 4b). Enter the Number of Reporting Subcontractors 

(Item 9) if there are subcontractors with CCDR reporting requirements. Enter the 

Subcontract Number (Item 8) for any subcontract plans that have CCDR requirements. 

Click Add to enter the subcontract number, and click Delete to remove the entry. 

  

Click Multi-Year Contract (Item 11) if the contract is funded from several fiscal years. For 

such contracts, enter all the fiscal years and click Add for each. Click Delete to remove any 

entries. If, on the other hand, the funding is from just one fiscal year, do not check Multi-

Year Contract. In this case, enter the single fiscal year and click Add. 

  

  

2007 DID 
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Page 1 

  

The DD 1921-1 shares the same Program Name as the program plan and contract plan for 

which the form is imported against. This is also the same name as the parent 1921. The 

program name corresponds to Item 1a "MDAP" of the DD Form 1921-1. 

  

The Phase (Item 1b) is one of the following four: 

A (Technology development) 

B (System Development and Demonstration) 

LRIP (Low-rate Initial Production) 

Production (Full-rate Production) 

  

The Prime Mission Product (Item 2) is the military designation or the type of product. 

  

The Contractor Type (Item 3) is either Prime or Associate, or Subcontractor depending on 

the contract plan associated with the 1921-1. 

  

The Contractor Name and Address (Item 4) is the contact information for the (prime or 

sub) contractor. 

  

The Customer Name (Item 6) is the name of the prime contractor responsible for the 

subcontractor. Leave blank if the report is prepared by the prime contractor. 

  

  

Page 2 

  

The Type Action block corresponds to Item 7 on the DD 1921. The Contract Number (Item 

7a) is that of the prime contract plan. The Latest Modification (Item 7b) is the number of the 

most recent contract modification. The Solicitation Number (Item 7c) is used for data 

relating to a solicitation according to the Defense Federal Acquisition Regulation 

Supplement (DFARS) 215.403-5. The Name (Item 7d) corresponds to that of the prime 

contract plan. 

  

The Appropriation (Item 21) is either RDT&E (Research, Development, Test and 

Evaluation), Procurement, or O&M (Operating and Maintenance). The Appropriation 

represents the funding of the WBS element. If the funding comes from multiple sources, 

check the appropriate boxes. 
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The Start Date (Item 8a) and End Date (Item 8b) correspond to the time frame of the 

Period of Performance. The dates must be entered in YYYYMMDD format in Excel in 

order to import correctly into cPet. 

  

  

Page 3 

  

The Report Cycle (Item 9) is either Initial, Interim, or Final. The Initial Report represents 

the groundwork for the 1921-1 and serves the purpose of presenting the data in accordance 

with the Data Item Description. The Interim Report is any report submitted between the 

Initial and Final stages. The Final Report represents the complete 1921-1 report. 

  

The Approved Plan Number (Item 5) is the number assigned to the contract plan or 

subcontract plan. 

  

The Submission Number (Item 10) is the submission event number for which the data are 

reported. 

  

The Resubmission Number (Item 11) represents the number of times the DD 1921-1 has 

been submitted. The original submission is marked by "0," and the first resubmission by "2." 

  

The Report As Of (Item 12) is the date of the submission event for which the data are 

reported. The date must be entered in YYYYMMDD format in order to import correctly into 

cPet. 

  

The Point of Contact Information, i.e. the Name (Item 13), Department (Item 14), E-mail 

(Item 16), and Phone (Item 15), is the contact information for the individual who prepared 

the report. The Date Prepared (Item 17) is the date corresponding to the 1921-1. The date 

must be entered in YYYYMMDD format in Excel in order to import correctly into cPet. 

  

  

2011 DID 

Page 1 

The DD 1921-1 shares the same Program Name as the program plan and contract plan for 

which the form is imported against. This is also the same name as the parent 1921. The 

program name corresponds to Item 1a "MDAP" of the DD Form 1921-1. 

  

The Phase (Item 1b) is one of the following four: 

     Pre-A (Material Solution Analysis) 
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A (Technology development) 

B (Engineering and Manufacturing Development) 

C-LRIP (Low-Rate Initial Production) 

C-FRP (Production and Deployment - Full-rate Production) 

O&S (Operations and Support) 

  

The Prime Mission Product (Item 2) is the military designation or the type of product. 

  

The Approved Plan Number (Item 5) is the number assigned to the contract plan or 

subcontract plan. 

  

The Submission Number (Item 10) is the submission event number for which the data are 

reported. 

  

The Resubmission Number (Item 11) represents the number of times the DD 1921-1 has 

been submitted. The original submission is marked by "0," and the first resubmission by "2." 

  

The Report As Of (Item 12) is the date of the submission event for which the data are 

reported. The date must be entered in YYYYMMDD format in Excel in order to import 

correctly into cPet. 

  

The Report Cycle (Item 9) is either Initial, Interim, or Final. The Initial Report represents 

the groundwork for the 1921-1 and serves the purpose of presenting the data in accordance 

with the Data Item Description. The Interim Report is any report submitted between the 

Initial and Final stages. The Final Report represents the complete 1921-1 report. 

  

The Point of Contact Information, i.e. the Name (Item 13), Department (Item 14), E-mail 

(Item 16), and Phone (Item 15), is the contact information for the individual who prepared 

the report. The Date Prepared (Item 17) is the date corresponding to the 1921-1. The date 

must be entered in YYYYMMDD format in Excel in order to import correctly into cPet. 

  

  

Page 2 

The Reporting Organization Type (Item 3) is either Prime/Associate Contractor, or Direct-

Reporting Subcontractor, or Government depending on the contract plan associated with the 

1921-1. 

  

The Performing Organization Name and Address (Item 4a) is the contact information for 

the (prime or sub) contractor. 
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The Division Name and Address (Item 4b) displays the name of the contractor division and 

location. 

  

The Customer Name (Item 6) is the name of the prime contractor responsible for the 

subcontractor. Leave blank if the report is prepared by the prime contractor. 

  

Page 3 

The Type Action block corresponds to Item 7 on the DD 1921-1. The Contract Number 

(Item 7a) is that of the associated contract plan. The Latest Modification (Item 7b) is the 

number of the most recent contract modification. The Solicitation Number (Item 7c) is used 

for data relating to a solicitation according to the Defense Federal Acquisition Regulation 

Supplement (DFARS) 215.403-5. The Name (Item 7d) corresponds to that of the associated 

contract plan. The Order/Lot Number (Item 7e) field contains (if applicable) the task order 

(TO), delivery order (DO), or Lot Number (Lot), followed by the number. 

  

The Appropriation (Item 21) is either RDT&E (Research, Development, Test and 

Evaluation), Procurement, or O&M (Operating and Maintenance). The Appropriation 

represents the contract funding. If the funding comes from multiple sources, check the 

appropriate boxes. 

  

The Start Date (Item 8a) and End Date (Item 8b) correspond to the time frame of the 

Period of Performance. The dates must be entered in YYYYMMDD format in Excel in 

order to import correctly into cPet. 

  

For a more detailed explanation of the header fields, see the following Data Item 

Descriptions: 

  

2007 DD Form 1921-2 Data Item Description 

2011 DD Form 1921-2 Data Item Description  

  

  

3.6 1921-1 COST DATA 

The Cost Data dialog can be reached by selecting the 1921-1 and clicking the  icon. 

  

http://cade.osd.mil/CSDR/ArchiveForms.aspx
http://cade.osd.mil/CSDR/FormsReporting.aspx
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The WBS Element names and item numbers correspond to those on the 1921-1. These 

elements should match the affiliated contract plan's WBS elements where a 1921-1 is 

required. 

  

The 1921-1 cost data for the 2003 version is presented in a slightly different format than for 

the 2007 and 2011 version. However, for both, there is a separate sheet of data for each WBS 

Element. 

  

For the 2003 version, click on a Cost Type (NonRecurring, Recurring, or Total) radio 

button to view the data for each. The cost categories (Engineering through Total Cost) are 

listed in the shaded area. The columns are arranged by Reporting Contractor, 

Subcontractor, and the Total of the two, including both To Date figures and At 

Completion figures. 

  

For the 2007 and 2011 version, all the data for a particular element is listed on a single sheet. 

The cost categories are again listed in the shaded area. However, the columns are arranged by 

To Date figures and At Completion figures, each including the Nonrecurring, Recurring, 

and Total values. 

  

Note that the Quantity field is at the top of each page for the 2003 version. Equivalently, the 

Number of Units field is at the top of the 2007 and 2011 versions. 

  

Tip: For more information on what the fields signify, see the 2007 DID and 2011 DID. 

  

Tip: For information on the requirements that the data figures must satisfy, see the 

Validation Rules. 

  

Use the following icons when importing or exporting cost data (Note: This feature is useful 

when creating a new 1921-1). This feature is only available for the 2003 and 2007 versions. 

  

http://cade.osd.mil/CSDR/ArchiveForms.aspx
http://cade.osd.mil/CSDR/FormsReporting.aspx
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Create an Excel template file based on the WBS elements, cost categories (e.g. 

Engineering), and cost types (e.g. NonRecurring Reporting Contractor To Date) 

  

Export the cost data to the template file that was created using the icon above 

  

Import cost data into cPet from a template file 

  

  

3.7 1921-1 COST REPORT COMPARISON 

This dialog appears after an "Earlier" 1921-1 and a "Later" 1921-1 have been chosen through 

the Select Reports to Compare dialog. 

The Comparison Options are displayed at the top, followed by the cost data. 

The WBS Tracking legend indicates which WBS elements appear on the Earlier report, the 

Later report, and the contract plan (the "Reference"). If the triangle icon ( or ) is shaded, 

then the WBS element appears on the report (Earlier or Later, respectively). For example, the 

symbol " " indicates that the WBS item is found on the Earlier report but not the Later. 

The shaded rectangle in the center indicates that the element appears on the contract plan. If 

the triangle/rectangle is not shaded, then the WBS element is not present on that report/plan. 

In the example above, the right arrow is not shaded. Thus the WBS element does not appear 

on the Later report. 

The gray areas in the cost data ( ) reinforce the WBS Tracking symbols; the cost 

data may not appear on one or more report. 

Tip: It may be easier to see where data is missing from a report if you choose Group for 

the Arrangement under the Column Options (see below). 

Uncheck Show Reference WBS if you do not wish to see elements appearing on either 

report, only the contract plan. 

A WBS element with a hyperlink indicates that there is a mismatch between the element 

names. Click on the hyperlink to understand this mismatch in the WBS Naming 
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Discrepancies dialog. The element name may be different between the contract plan, the 

Earlier Report, and/or the Later Report. 

Different columns/rows of data will be displayed depending on specified options. For 

instance, you can check which columns to show (Nonrecurring, Recurring, and Total for 

both To Date and At Completion). 

 

  

The Columns Options allows you to change the column colors and group the columns in 

different arrangements. 

  

 

  

You can select how Anomalies are displayed. cPet will indicate an anomaly if the cost from 

the Earlier report is greater than the cost from the Later Report. For instance, if the Earlier To 

Date Recurring is $2,000 and the Later To Date Recurring is $1,000 for a particular row, then 

those costs will be highlighted pink as long as "Highlight anomalies" is checked. 
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3.8 1921-1 VALIDATION RESULTS 

The Validation Results dialog appears immediately after validating an individual document 

or after running the Validation Wizard. The data is grouped in three categories: 1921-1 vs 

Contract Plan, 1921-1 vs 1921, and 1921-1 Internal. The first category contains a list of 

problems with the cost data on the 1921-1 as compared to the contract plan's WBS Editor. 

The second category validates the data on the 1921-1 in relation to the data on the 1921. The 

third contains numeric checks on the 1921-1 itself. 

  

The dialog is laid out in three columns: The Location, Description, and Error Magnitude: 

  

The Location column displays the validated item. Each item is marked with either a Warning 

 ( )  or an error  ( ) depending on the severity. The categories which contain no 

problems are marked by  . 

  

The Description column lists the type of error found. Click on an error to view the 

associated details in the Reading Pane at the bottom of the window. You can hide this 

Reading Pane by clicking the  icon at the top of the dialog. 

  

The Error Magnitude represents the difference between related costs. 

  

Tip: For these numeric validations, only the error with the greatest magnitude will be 

reported for each WBS Element (and for each page, if relevant). In fixing the major error, 

many smaller errors will most likely be fixed as well. 
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Click the Filter icon  to sort the validation results by Location or by Error Magnitude. 

Results are listed by Location by default, which means that within each category, the errors 

appear in the order of the elements on the Excel file. If you choose to sort by Error 

Magnitude, then the numeric errors will be listed with the error of largest magnitude first. 

Click Hide Warnings to hide the warnings ( ) and only display the errors ( ). 

  

The information found in the Validation Results can be exported to Excel by clicking . 

  

The following table lists some possible errors that may occur when validating a 1921-1. 

  

  

Validation Results for DD Form 1921-1 

Error Description 

1921-1 vs Contract Plan   

Blank WBS Element Code found for reporting 

elements from 1921-1 

One or more WBS elements do not have an 

element code on the 1921-1. View the Reading 

Pane to see the corresponding element names. 

Required reporting element omitted from 

1921-1 submission 

A WBS Element that is required by the Contract 

Plan is missing from the 1921-1 report. Note: This 

error does not occur if the value in the Total At 

Completion column of the parent 1921 is zero. 

Redundant data provided for reporting element 

from 1921-1 

A WBS Element is repeated on the 1921-1. This 

may be an error because the "Total," "Recurring," 

or "Nonrecurring" pages were marked incorrectly. 

Program Name on 1921-1 does not match 

Program Name on Contract Plan 

The Program Name should be the same on the 

1921-1 as on the parent contract plan. 

Approved Plan Number on 1921-1 does not 

match Approved Plan Number on Contract Plan 

The Approved Plan Number should be the same 

on the 1921-1 as on the parent contract plan. 
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WBS Element Name on 1921-1 does not match 

WBS Element Name on Contract Plan 

The WBS element name on the contract plan is 

not the same as that on the 1921-1 for a particular 

WBS element code. This problem is most likely 

due to misspelling or slight modifications to the 

name. 

Reporting element from 1921-1 not found on 

Contract Plan 

All elements that are on the 1921-1 should also be 

listed in the contract plan's WBS Editor. 

1921-1 vs 1921   

Corresponding costs on 1921-1 and 1921 do 

not match 

This error occurs when the cost data for an 

element on the 1921 is not the same as the data on 

the "Total Cost (Direct and Overhead)" row on the 

1921-1 for each cost type. 

Corresponding quantities on 1921-1 and 1921 

do not match 

The Number of Units field on the 1921 must 

match the Quantity field on the Total page of the 

1921-1 (for both To Date and At Completion 

figures). 

Reporting element from 1921-1 not found on 

1921 

All WBS Elements that are on the 1921-1 should 

also be on the parent 1921. cPet bases this 

validation check on the element code, not the 

element name. 

1921-1 Internal   

NonRecurring/Recurring/Total figures do not 

sum correctly (does not apply to 2003 1921-1's) 

The data in the Non-Recurring and Recurring 

pages must sum to the Total page for each 

element, column (e.g. Reporting Contractor), and 

row (e.g. Engineering Direct Labor Hours). 

Group within data column does not sum 

correctly 

The cost data in each column must sum to the total 

for that cost category (e.g. Total Engineering 

Dollars). See Validation Rules for more 

information. 
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Data column does not sum correctly The sum of the total figures of each cost category 

(e.g. Total Engineering Dollars + Total 

Manufacturing Dollars +...) must equal the 

Summary Total Cost for each column. See 

Validation Rules for more information. 

Contractor/Subcontractor/Total figures do not 

sum correctly (applies only to 2003 1921-1's) 

For any given WBS element, the sum of the 

Reporting Contractor data and the Subcontractor 

data in the To Date columns must equal that in the 

Total column for each row. The same must be true 

for the At Completion values. See Validation 

Rules for more information. 

Reported figure is negative All figures must have positive values. 

Nonrecurring/Recurring/Total quantities do not 

match (applies only to 2003 1921-1's) 

The quantity fields must have the same value 

across all pages. That is, Nonrecurring = 

Recurring = Total Quantity 

Data reported for Direct Labor Dollars but not 

for Direct Labor Hours 

If there is data in the Direct Labor Dollars field for 

a particular element, cost type, and column, then 

there must be data in the Direct Labor Hours field. 

Data reported for Overhead but not for Direct 

Labor 

If there is data in the Overhead field for a 

particular element, cost type, and column, then 

there must be data in the Direct Labor fields. The 

Direct Labor fields include Labor Hours and 

Labor Dollars for 2003 reports, and Tooling, 

Quality, Manufacturing, etc for 2007 reports. 

Data reported for Direct Labor Hours but not 

for Direct Labor Dollars 

If there is data in the Direct Labor Hours field for 

a particular element, cost type, and column, then 

there must be data in the Direct Labor Dollars 

field. 

Data reported for Direct Labor but not for If there is data in any of the Direct Labor fields for 
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Overhead a particular element, cost type, and column, then 

there must be data in the Overhead field. 

To Date figure is greater than At Completion 

figure 

For every cost category, the To Date figure must 

be less than or equal to the At Completion value 

for all sets of columns (Reporting Contractor, 

Subcontractor, and Total columns). 

Data reported for Total Direct-Reporting 

Subcontractor. Remarks required (does not apply 

to 2003 1921-1's) 

If there are costs on Line 18 "Total Direct-

Reporting Subcontractor Dollars," then an 

explanation should be provided in the Remarks 

section.   

Other Costs Not Shown Elsewhere are greater 

than or equal to x% of total cost. Remarks 

required 

For 2003 and 2007 reports, if the costs in Line 20 

("Other Costs Not Shown Elsewhere") are greater 

than or equal to 15% of the Total Cost in Line 21, 

then an explanation should be provided in the 

Remarks section. For 2011 reports, remarks 

should be provided if Line 20 costs are greater 

than or equal to 10% of Line 21 costs. 

  

  

3.9 1921-2 BASIC INFO DIALOG 

The 1921-2 form is the Progress Curve Report.  It captures all direct, recurring costs incurred 

to date, by unit or lot.  It breaks the costs per unit/lot into Completed, Work in Process, and 

Total Costs Incurred To Date.  The form provides characteristics, as required by the 

government Program Office.  It also breaks costs and hours into functional categories, 

including engineering, manufacturing, tooling, quality control, raw materials and purchased 

parts. 

  

2007 DID                                2011 DID 

Page 1                           Page 1 

Page 2                           Page 2 
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Page 3                           Page 3 

  

  

  

2007 DID 

Page 1 

  

The DD 1921-2 shares the same Program Name as the program plan and contract plan 

for which the form is imported against. This is also the same name as the parent 

1921. The program name corresponds to Item 1 "Major Program" of the DD Form 1921-2.  

 

 The Phase (Item 1b) is one of the following: 

 

 

 Pre-A (Material Solution Analysis) 

 

 

 A (Technology development) 

 

 

 B (Engineering and Manufacturing Development) 

 

 

 C-LRIP (Low-Rate Initial Production) 

 

 

 C-FRP (Production and Deployment - Full-rate Production) 

 

 

 O&S (Operations and Support) 

 

 

The Prime Mission Product (Item 2) is the military designation or the type of product. 

 

The Contractor Type (Item 3) is either Prime or Associate, or Subcontractor depending 

on the contract plan associated with the 1921-2. 

 

The Contractor Name and Address (Item 4) is the contact information for the (prime 

or sub) contractor. 
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The Approved Plan Number (Item 5) is the number assigned to the contract plan or 

subcontract plan. 

 

The Customer Name (Item 6) is the name of the prime contractor responsible for the 

subcontractor. Leave blank if the report is prepared by the prime contractor.  

 

Page 2 

  

The Type Action block corresponds to Item 7 on the DD 1921. The Contract Number (Item 

7a) is that of the prime contract plan. The Latest Modification (Item 7b) is the number of the 

most recent contract modification. The Solicitation Number (Item 7c) 

is used for data relating to a solicitation according to the Defense Federal Acquisition 

Regulation Supplement (DFARS) 215.403-5. The Name (Item 7d) corresponds to that of 

the prime contract plan. 

 

The Appropriation (Item 21) is either RDT&E (Research, Development, Test and 

Evaluation), Procurement, or O&M (Operating and Maintenance). The Appropriation 

represents the funding of the WBS element. If the funding comes from multiple sources, 

check the appropriate boxes. 

 

The Start Date (Item 8a) and End Date (Item 8b) correspond to the time frame of the Period 

of Performance. The dates must be entered in YYYYMMDD format in Excel in order 

to import correctly into cPet. 

  

Page 3 

The Report Cycle (Item 9) is either Initial, Interim, or Final. The Initial Report represents 

the groundwork for the 1921-2 and serves the purpose of presenting the data in accordance 

with the Data Item Description. The Interim Report is any report submitted between the 

Initial and Final stages. The Final Report represents the complete 

1921-2 report. 

 

The Approved Plan Number (Item 5) is the number assigned to the contract plan or 

subcontract plan. 

 

The Submission Number (Item 10) is the submission event number for which the data are 

reported. 

 

The Resubmission Number (Item 11) represents the number of times the DD 1921-2 has 

been submitted. The original submission is marked by "0," and the first resubmission by "2." 
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The Report As Of (Item 12) is the date of the submission event for which the data are 

reported. The date must be entered in YYYYMMDD format in order to import correctly 

into cPet. 

 

The Point of Contact Information, i.e. the Name (Item 13), Department (Item 14), 

E-mail (Item 16), and Phone (Item 15), is the contact information for the individual who 

prepared the report. The Date Prepared (Item 17) is the date corresponding to the 1921-2. 

The date must be entered in YYYYMMDD format in Excel in order to import correctly into 

cPet. 

  

2011 DID 

Page 1 

  

The DD 1921-2 shares the same Program Name as the program plan and contract plan 

for which the form is imported against. This is also the same name as the parent 

1921. The program name corresponds to Item 1a "Major Program" of the DD Form 1921-2. 

 

The Phase (Item 1b) is one of the following: 

 

 

 Pre-A (Material Solution Analysis) 

 

 

 A (Technology development) 

 

 

 B (Engineering and Manufacturing Development) 

 

 

 C-LRIP (Low-Rate Initial Production) 

 

 

 C-FRP (Production and Deployment - Full-rate Production) 

 

 

 O&S (Operations and Support) 

 

 

The Prime Mission Product (Item 2) is the military designation or the type of product. 
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The Approved Plan Number (Item 5) is the number assigned to the contract plan or 

subcontract plan. 

 

The Submission Number (Item 10) is the submission event number for which the data 

are reported. 

 

The Resubmission Number (Item 11) represents the number of times the DD 1921-2 has 

been submitted. The original submission is marked by "0," and the first resubmission 

by "2." 

 

The Report As Of (Item 12) is the date of the submission event for which the data are 

reported. The date must be entered in YYYYMMDD format in Excel in order to import 

correctly into cPet. 

 

The Report Cycle (Item 9) is either Initial, Interim, or Final. The Initial Report 

represents the groundwork for the 1921-2 and serves the purpose of presenting the 

data in accordance with the Data Item Description. The Interim Report is any report 

submitted between the Initial and Final stages. The Final Report represents the complete 

1921-2 report. 

 

The Point of Contact Information, i.e. the Name (Item 13), Department (Item 14), 

E-mail (Item 16), and Phone (Item 15), is the contact information for the individual 

who prepared the report. The Date Prepared (Item 17) is the date corresponding to 

the 1921-2. The date must be entered in YYYYMMDD format in Excel in order to import 

correctly into cPet. 

  

Page 2 

  

The Reporting Organization Type (Item 3) is either Prime/Associate Contractor, or 

Direct-Reporting Subcontractor, or Government depending on the contract plan associated 

with the 1921-2. 

 

The Performing Organization Name and Address (Item 4a) is the contact information 

for the (prime or sub) contractor. 

 

The Division Name and Address (Item 4b) displays the name of the contractor division 

and location. 

 

The Customer Name (Item 6) is the name of the prime contractor responsible for the 
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subcontractor. Leave blank if the report is prepared by the prime contractor. 

   

Page 3 

  

The Type Action block corresponds to Item 7 on the DD 1921-2. The Contract Number 

(Item 7a) is that of the associated contract plan. The Latest Modification (Item 

7b) is the number of the most recent contract modification. The Solicitation Number 

(Item 7c) is used for data relating to a solicitation according to the Defense Federal 

Acquisition Regulation Supplement (DFARS) 215.403-5. The Name (Item 7d) corresponds 

to that of the associated contract plan. The Order/Lot Number (Item 7e) field contains 

(if applicable) the task order (TO), delivery order (DO), or Lot Number (Lot), followed 

by the number. 

 

The Appropriation (Item 21) is either RDT&E (Research, Development, Test and 

Evaluation), Procurement, or O&M (Operating and Maintenance). The Appropriation 

represents the contract funding. If the funding comes from multiple sources, check the 

appropriate boxes. 

 

The Start Date (Item 8a) and End Date (Item 8b) correspond to the time frame of the Period 

of Performance. The dates must be entered in YYYYMMDD format in Excel in order 

to import correctly into cPet.  

 

For a more detailed explanation of the header fields, see the following Data Item 

Descriptions: 

  

2007 DD Form 1921-2 Data Item Description 

2011 DD Form 1921-2 Data Item Description  

 

3.10 1921-2 COST DATA 

The Cost Data dialog can be reached by selecting the 1921-2 and clicking the   icon. Note 

that the fields are described based on the May 2011 version of the DD Form 1921-2. The 

form is primarily used for viewing the data. WBS elements cannot be edited on this form, but 

Unit/Lot data can be modified. 

  

WBS Elements 

http://cade.osd.mil/CSDR/ArchiveForms.aspx
http://cade.osd.mil/CSDR/FormsReporting.aspx
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The WBS Element names and item numbers correspond to those on the 1921-2. These 

elements should match the affiliated contract plan's WBS elements where a 1921-2 is 

required. 

  

Units/Lots 

As specified by the user’s approved contract plan (DD Form 2794), the Units/Lots 

Completed drop-down will display either “Unit Total” or “Lot Total”.  This classification 

may be different for each WBS element. 

  

Data Element Information 

The data element information is displayed for each Completed Unit/Lot, Work in Progress, 

and Total Direct Costs and Hours Incurred to Date.  

  

The Models element corresponds to Line 1 (Model and Series).  The user can enter the 

model or series number associated with the individual WBS element.  The form allows the 

user to enter different model and series information for different WBS elements.  If a lot 

includes more than one series of a model, identify the number and series designation of each 

in Item 22 (Remarks). 

  

The First Unit element corresponds to Line 2 (First Unit) on the 1921-2 report. This should 

be a numerical entry.  This number should be equal to one plus the sum of all prior units (if 

any) since the inception of a program/model, regardless of the number of contracts under 

which the model has been procured. 

  

The Last Unit element corresponds to Line 3 (Last Unit) on the 1921-2 report. This should 

also be a numerical entry.  This represents the unit number of the last unit of the lot or the 

applicable unit number 

  

The Concurrent Units/Lots element corresponds to Line 4 (Concurrent Units/Lots) on the 

1921-2 report. Concurrent Units/Lots are items that are produced at the same time as the 
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units that apply to the contract being reported. Included in this category are items for 

commercial (domestic or foreign) delivery or delivery to the other DoD Components or 

programs (e.g. Military Assistance Program) which are acquired under separate contractual 

efforts. 

  

Characteristics  

The next section contains technical characteristics for a given WBS element. For example, 

Line 5a (Weight), 5b (Speed), and 5c (Power). Values for these characteristics can be alpha-

numeric. 

  

Labor Hours and Cost Data 

The associated 1921-2 cost and hour data is reported in the next section.  Note only 

Recurring data is displayed. 

  

Remarks 

Any associated comments for a given WBS element are shown in the “Remarks” field. 

 

3.11 1921-2 VALIDATION RESULTS 

The Validation Results dialog appears immediately after validating an individual document 

or after running the Validation Wizard. The data is grouped in three categories: 1921-2 vs 

Contract Plan, 1921-2 vs 1921, 1921-2 vs 1921-1,and 1921-2 Internal. The first category 

contains a list of problems with the cost data on the 1921-2 as compared to the contract plan's 

WBS Editor. The second category validates the data on the 1921-2 in relation to the data on 

the 1921. The third category validates the data on the 1921-2 in relation to the data on the 

1921-1. The fourth contains numeric checks on the 1921-2 itself. 

  

The dialog is laid out in three columns: The Location, Description, and Error Magnitude: 
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The Location column displays the validated item. Each item is marked with either a Warning 

 ( )  or an error  ( ) depending on the severity. The categories which contain no 

problems are marked by  . 

  

The Description column lists the type of error found. Click on an error to view the 

associated details in the Reading Pane at the bottom of the window. You can hide this 

Reading Pane by clicking the   icon at the top of the dialog. 

  

The Error Magnitude represents the difference between related costs. 

  

Tip: For these numeric validations, only the error with the greatest magnitude will be 

reported for each WBS Element (and for each page, if relevant). In fixing the major error, 

many smaller errors will most likely be fixed as well. 

  

Click the Filter icon  to sort the validation results by Location or by Error Magnitude. 

Results are listed by Location by default, which means that within each category, the errors 

appear in the order of the elements on the Excel file. If you choose to sort by Error 

Magnitude, then the numeric errors will be listed with the error of largest magnitude first. 

Click Hide Warnings to hide the warnings ( ) and only display the errors ( ). 

  

The information found in the Validation Results can be exported to Excel by clicking . 

  

The following table lists some possible errors that may occur when validating a 1921-2. 

  

Validation Results for DD Form 1921-2 

Warning/Error Description 

1921-2 vs Contract Plan   

Blank WBS Element Code 

found for reporting elements on 

1921-2 

One or more WBS elements are missing a WBS element code 

on the 1921-2 form.  View the Reading Pane to see the 

corresponding element names. 
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 Duplicate WBS Element 

Code found for reporting 

elements on 1921-2 

Duplicate WBS element codes were found to be listed more 

than once on the 1921-2 file.  This error may also be 

triggered if two different WBS elements share a single code. 

Required Reporting Element 

omitted from 1921-2 file 

A WBS element that has a requirement for 1921-2 reporting 

in Column 13d (1921-2) on the Contract Plan. 

 Program Name on 1921-2 

does not match Program Name 

on Contract Plan 

The Program Name on the 1921-2 must match the Contract 

Plan. 

 Approved Plan on 1921-2 

does not match Approved Plan 

on Contract Plan 

The Approved Plan Number on the 1921-2 must match the 

Contract Plan. 

 WBS Element Code not 

found on Contract Plan 

There is WBS Element Code on the 1921-2 form that is not 

found on the Contract Plan.  

 WBS Element Name does 

not match WBS Element Name 

on Contract Plan 

The WBS Element Name reported on the 1921-2 does not 

match the Element Name on the Contract Plan.  The issue is, 

most likely, due to misspelling or slight modifications to the 

Element Name. 

1921-2 vs 1921   

 WBS Element Code from 

1921-2 report not found on 1921 

report 

There is WBS Element Code on the 1921-2 form that is not 

found on the 1921 report.  

1921-2 vs 1921-1   

Total Direct Recurring Costs 

reported To Date on the 1921-2 

do not match corresponding 

Recurring Costs To Date 

reported on the 1921-1 Report 

Total Direct Recurring Costs and Hours To Date (Column C) 

reported on the 1921-2 report does not match the Total 

Recurring Costs and Hours To Date (Column B) reported on 

the 1921-1 report for the following corresponding fields: 

Direct Engineering Labor Hours & Dollars, Direct Tooling 

Labor Hours & Dollars, Direct Quality Control Hours & 

Dollars, Direct Manufacturing Hours & Dollars, Raw 

Materials Dollars, Purchased Parts Dollars, Purchased 

Equipment Dollars, Total Direct Reporting Subcontract 

Dollars, Other Direct Costs Not Shown Elsewhere. 

1921-2 Internal   

 Sum of reported costs and 

hours for Completed Units/Lots 

(Column A) and Work in 

For each row on the 1921-2 report, Columns A plus B, must 

equal C for both costs and hours. 
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Process (Column B) does not 

equal Total Direct Costs and 

Hours To Date (Column C) 

Sum of costs reported for 

1921-2 functional categories 

does not equal Total Cost of 

functional category 

Line 15 (Total Direct Manufacturing Operations Dollars) 

must equal the sum of Lines 9, 10, 12, and 14).  Line 20 

(Total Direct Material Dollars) must equal the sum of Lines 

16, 17, 18, and 19. 

 Sum of costs reported for 

1921-2 functional categories 

and Other Direct Costs does not 

equal Total Direct Cost (Line 

22) 

Line 22 (Total Direct Cost) must be equal to the sum of Lines 

7, 15, 20, and 21. 

Negative costs found on 

1921-2 report 

Negative values are not permitted on the 1921-2 report unless 

accompanied by a comment in the Remarks section. 

 Direct Dollars reported for a 

1921-2 functional category, 

without Direct Hours and vice 

versa 

For each functional category on the 1921-2 (Engineering, 

Tooling, Quality Control, and Manufacturing), if hours are 

reported, dollars must also be reported, and vice versa. 

Cost reported on the 1921-2 

for Total Direct Reporting 

Subcontractors 

If costs are reported in Line 19 (Total Direct-Reporting 

Subcontractor Dollars), then a comment must be included in 

the Remarks section with information on the subcontractor’s 

name and total dollar value of the contract. 

Other Direct Costs Not 

Shown Elsewhere are greater 

than 10% of total cost (2011 

Version) or 15% (2007 

Version) 

If costs reported in Line 21 (Other Direct Costs Not Shown 

Elsewhere) pass the threshold, then a comment in required in 

the Remarks section of the 1921-2 report. 

  

3.12 1921-3 BASIC INFO DIALOG 

The DD Form 1921-3, "Contractor Business Data Report," provides direct and 

indirect cost data across various contracts. The Basic Information window (View > 

Basic Info) displays the metadata pertaining to the contractor and the report. A 

couple tabs outline the header information found on the DD 1921-3, and a brief 

description of each is provided below. Click a link below to view information 
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pertaining to the desired tab. Note that the fields are described based on the May 

2011 version of the DD Form 1921-3. 

Report Info 

Remarks 

Report Info 

The Contractor Name/Address (Item 1) includes the reporting contractor's name 

and address. 

The FPR Unit (Item 2) shows the Forward Pricing Rate (FPR) unit (e.g. plant, site, 

business unit) of the report. 

The Implementing Contract Number (Item 3) refers to the number of the contract 

which has the 1921-3 reporting requirement. 

The Point of Contact section contains the report preparer's name (Item 7), 

department (Item 8), e-mail (Item 10), phone (Item 9), and the date prepared 

(Item 11). 

Remarks 

The Remarks tab corresponds to the Remarks section on Page 2 of the 1921-3. 

Note that any remarks found on the DD 1921-3 will not import into cPet; the text 

must be manually copied into cPet. However, any text copied or written into the 

Remarks section of cPet will be exported to Excel (Tools > Export DD Form). 

3.13 1921-3 COST DATA 

The Cost Data dialog can be reached by selecting the 1921-3 and clicking the   icon. Click 

a link below to view information pertaining to the desired page. Note that the fields are 

described based on the May 2011 version of the DD Form 1921-3. 

Page 1 

Page 2 

  

Page 1 

The "Page 1" tab in cPet contains information from various worksheets marked as "Page 1" 

in the DD 1921-3 Excel file. Each worksheet in the Excel file corresponds to a Report on the 

left side of the dialog in cPet. Click on a Report to view the applicable costs. 
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The Data Period (Item 4) identifies how the year of reported costs (Prior Year, Current 

Year, or Future Year). 

The Fiscal Year (Item 5) displays the year of the reported costs. 

The Start Date and End Date (Item 6) refer to the dates reported in the fiscal year. 

The data is separated by direct costs by program, and indirect costs by category. Refer to 

the Data Item Description found on the DCARC website for a complete description of all the 

fields and column headers. 

Page 2 

The "Page 2" tab in cPet contains information for the "Page 2" worksheet in the DD 1921-3 

Excel file. The direct labor rates by functional category are listed. Refer to the Data Item 

Description for a description of all the fields on this form. 

  

3.14 1921-3 VALIDATION RESULTS 

The Validation Results dialog appears immediately after validating an individual document 

or after running the Validation Wizard.  

  

The dialog is laid out in three columns: The Location, Description, and Error Magnitude: 

  

The Location column displays the validated item. Each item is marked with either a Warning 

 ( )  or an error  ( ) depending on the severity. The categories which contain no 

problems are marked by  . 

  

The Description column lists the type of error found. Click on an error to view the 

associated details in the Reading Pane at the bottom of the window. You can hide this 

Reading Pane by clicking the   icon at the top of the dialog. 

  

The Error Magnitude represents the difference between related costs. 
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Tip: For these numeric validations, only the error with the greatest magnitude will be 

reported for each WBS Element (and for each page, if relevant). In fixing the major error, 

many smaller errors will most likely be fixed as well. 

  

Click the Filter icon  to sort the validation results by Location or by Error Magnitude. 

Results are listed by Location by default, which means that within each category, the errors 

appear in the order of the elements on the Excel file. If you choose to sort by Error 

Magnitude, then the numeric errors will be listed with the error of largest magnitude first. 

Click Hide Warnings to hide the warnings ( ) and only display the errors ( ). 

  

The information found in the Validation Results can be exported to Excel by clicking . 

  

The following table lists some possible errors that may occur when validating a 1921-3. 

  

  

Validation Results for DD Form 1921-3 

Error Description 

Reported column total does not match calculated 

total 

This error may occur for a variety of reasons. Line 14 

(Page 1) must be a sum of Lines 1-13 for each 

column of costs/hours. Similarly, Line 27 (Page 1) 

must be a sum of Lines 15-26 for each column of 

costs/hours. Line 28 (Page 1) must be a sum of Lines 

15-26 in Columns Y and Z. 

Sections A & B (Page 1) provided for fewer than 

three Future Years 

Sections A and B (Page 1) must be completed for the 

Prior Year, Current Year, and at least three future 

years. 

Reported figure is negative Costs and hours should be positive figures (other than 

Line 26, Credits) 
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Ratio of hours to workers implies relative scale 

may be incorrect 

  

Costs for other efforts are greater than or equal 

to 15% of total cost. Remarks required 

  

Hours were reported but workers were not   

Costs for Other Miscellaneous is greater than or 

equal to 15% of total cost. Remarks required 

  

Hours per worker exceeds 2500 hours per year. 

Remarks required 

The ratio of hours per worker should be fewer than 

2500 for Sections A, B, and D. Note that all hours on 

the 1921-3 should be reported in thousands. 

Costs reported for Other functional category. 

Remarks required 

  

Labor rates from Section D do not match labor 

costs from Sections A. Remarks may be required. 

  

Combined costs exceed Total FPR Unit 

Revenue. Remarks may be required. 

Remarks required if the Total FPR Unit Revenue 

(Section E) is greater than the sum of all direct 

(Section A, Line 14, Columns F, I, K, M) and indirect 

(Section B, Line 27, Columns P, S, U, W and Line 28 

Column Y) costs from Page 1 of the Prior or Current 

year. 

 

3.15 PROGRAM AND CONTRACT PLAN BASIC INFO DIALOG 

Basic Information Tab 

  

The Basic Info includes all the header information of a DD 2794 form. View and edit the 

program name, address, contract information, report date, etc. 
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The Plan Type shows whether the plan is a program plan, contract plan, or subcontract plan. 

The plan type is determined based on the selection to import/create a program plan or 

contract plan from the File menu in cPet. For imported contract plans, cPet reads the Excel 

file to determine if the plan is a prime contract or a subcontract. For new contract plans, the 

default plan type is "Prime Contract." If you are creating a new subcontract plan, you must 

mark the "subcontract" radio button in the Basic Info. 

  

Tip: For 2003 plans, the Plan Type will be marked as Program or Contract (subcontract 

plans will be marked as "contract" as well). 

  

The Program Name is the name of the program plan/contract plan. 

  

Choose the Phase/Milestone of the plan. Note that the name of the phase varies slightly 

across different versions of the plan. 

  

     Pre-A (Material Solution Analysis; Found only on 2011 plans) 

A (Technology development) 

B (Engineering and Manufacturing Development) 

C-LRIP (Low-Rate Initial Production) 

C-FRP (Production and Deployment - Full-rate Production) 

O&S (Operations and Support; Found only on 2011 plans) 

  

The Prime Mission Product (only found on 2007 and 2011 plans) is the military designation 

or the type of product. 

  

Choose a WBS System Type, outlined by either the MIL-HDBK-881 or MIL-STD-881C 

specifications (dependent on the selection at the top of the Basic Info dialog). For new plans, 

the WBS System chosen will affect how the WBS elements are auto-populated assuming the 

option to "Prompt before providing WBS structure to plans with no WBS" is turned on. 
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Check Initial Submission if this is the first version of the plan. Check Change if there are 

other revisions of the plan approved by the CAPE. 

  

The Preparing Organization is the organization responsible for the plan. 

  

The Review and Reference Number/Approved Plan Number is the plan number provided 

by the Defense Cost and Resource Center (DCARC). 

  

The As of Date/Current Submission Date is the date when the plan was submitted by the 

reporting organization. 

  

The Report Date/Last Approved Plan Date is the date of the most recent revision of the 

plan. 

  

Enter the Point of Contact  information (name, address, phone/fax, and E-mail). 

  

Contract Information Tab 

Contract plans will have an additional tab in the Basic Info window to store the contract 

information. 

  

The contractor name, division, and location is listed, as well as the contract number. See 

Importing a Contract Plan for the proper way to format the contractor information in the 

Excel file so that it will import into the proper fields in cPet's Basic Info. 

  

Tip: If you edit the contractor name, division, or location in the Basic Info, then the 

Contractor Selection Dialog will update accordingly. 

  

For 2011 plans, there are a few additional fields on the Contract Information Tab for the 

appropriation and the DD 1921-3 requirement. 
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DD 2794 Narrative Text Tab 

  

The Narrative Text tab is designed to accommodate the Remarks found at the bottom of the 

DD 2794. This field will not be imported; the text must be entered manually or copied and 

pasted from the source. 

  

Default headings are provided for your convenience. For program plans, these are “Program 

Overview,” “Contracting Approach,” and "Quantity Overview.” For contract plans, these are 

"Non-Recurring/Recurring Definitions," "Cost Accounting Standards (CAS) Disclosure 

Statement Differences," "1921-3 Contractor Business Data Report," and "** (if required) 

1921-2 Progress Curve Report." 

  

Headings can be added or modified using the following icons: 

  

Add a new parent heading 

Add a new sibling heading 

Add a new child heading 

Move entry up on the list 

Move entry down on the list 

Delete the heading 

  

Tip: Images will not copy into the Narrative Text. This window is strictly text only. 

  

Tip: The "proper" way to organize the Narrative Text is to have a parent header, followed 

by a child header, followed by the actual descriptive text. For instance, the layout of the 

Narrative Text should be as follows: 

  

Parent Header 

Child Header 
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Descriptive Text 

  

Do not type information directly under the first two headers. If you do not follow the above 

layout, the text will not be properly formatted in the Remarks section when exported to PDF 

or Excel. 

  

  

3.16 CONTRACTOR MAINTENANCE DIALOG 

The Contractor Maintenance allows you to add, edit, or delete contractors on the Contractor 

Selection list. However, changes to the contractor list will only be reflected in your own copy 

of cPet. The Contractor Maintenance feature exists for the convenience of the user. 

  

Use the toolbar icons to manage the contractor list: 

  

Delete a contractor, division, or location. Notice that you can only delete entries that 

you created. 

  

Expand the list – View all of the divisions and locations under each contractor 

  

Collapse the list – Display just the contractor names 

  

Display the filter feature – Search for a contractor by typing in keywords 

  

Add a contractor – Add a new contractor to the list 

  

Add a division – Add a new division under the selected contractor 

  

Add a location – Add a new location under the selected division 
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The Legend shows that the  icon represents a contractor's name, the  icon represents 

the contractor's division, and the  icon represents the contractor's location. 

  

The Contractors column displays all the contractors currently available in the user's 

Contractor Selection list. 

  

The Contractor Details displays the information relevant to the selected contractor. When 

adding a new contractor, you may choose to fill in the DUNS Code, the Effective Date, the 

Obsolete Date, and the Notes. 

  

Use the Filter to search for contractors within the list (click  to display the filter). The 

filtered contractors are highlighted in the color specified by the cPet Display Options. The 

following icons may be helpful: 

  

  

Clear filter field 

  

Move to the previous entry in the filtered list 

  

Move to the next entry down in the filtered list 

  

  

Tip: New contractors appear green  

  

The user has the option to export the contractor list. Click File > Export User-Defined Data 

to save an XML copy of the contractor list (including user-added contractors). If you later 

install a different version of cPet, you may wish to import this data to retain information 



Dialogs 

151 

regarding contractors, divisions, and locations you may have added. Click File > Import 

User-Defined Data to import the contractor list that was previously exported. 

  

  

3.17 CONTRACTOR SELECTION DIALOG 

Contractors for a contract plan or subcontract plan can be added, renamed, or deleted through 

the Contractor Selection Dialog. 

  

The Legend shows that the  icon represents a contractor's name, the  icon represents 

the contractor's division, and the  icon represents the contractor's location. 

  

To select a contractor, search the Available Contractors list for the desired contractor, 

division, and location. If the contractor you want is not on the list, refer to the Contractor 

Maintenance Dialog  to add that contractor. 

  

Click Add to assign a contractor. If you are viewing the Contractor Selection Dialog of a 

contract plan, then clicking the Add button will add a subcontractor, which will appear 

indented under the contractor for the plan. 

  

Click Remove to remove the contractor from the Selected Contractors list. 

  

Click Replace to replace the contractor on the Selected Contractors list with the chosen 

contractor on the Available Contractors list. 

  

Tip: If you change the chosen contractor in the Contractor Selection Dialog, then the 

contractor information will update accordingly in the Basic Information as well, and vice 

versa. The two dialogs will remain in sync. 
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When you import a contract plan, the contractor will show a warning icon in the 

Contractor Selection Dialog. Search for the corresponding contractor in the Available 

Contractors list and click Replace to update the contractor name, division, and location to 

match one of cPet's contractors. 

  

 

  

When you create a new contract plan, "TBD" will appear in the contractor field. Go to the 

Contractor Selection dialog to search for the appropriate contractor in the Available 

Contractors list. Click Replace to update the TBD contractor with the actual contractor. 

  

You can define a Short Name for each contractor. This abbreviated name will appear in the 

Contractor column on a PDF export (does not apply to 2011 DD 2794 version). See 

Exporting Plans for more details. 

  

Use the Contractor List Filter to quickly find the desired contractor by typing in a few 

keyword and using the icons below. The filtered contractors are highlighted in the color 

specified by the cPet Display Options. 
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Clear filter field 

  

Move to the previous entry in the filtered list of contractors 

  

Move to the next entry in the filtered list of contractors 

  

  

The following icons may be useful in managing the contractor list: 

  

Expand the list – View all of the divisions and locations under each contractor 

  

Collapse the list – Display just the contractor names 

  

Display the filter and additional contractor info 

  

Add a contractor to the selection list (same as clicking Add) 

  

Add a Contractor TBD - Use this feature if you are unsure of which contractor to select. 

Use Replace to substitute the Contractor TBD with a known contractor 

  

Replace a contractor on the Selected Contractors list with a contractor on the Available 

Contractors list (same as clicking Replace) 

  

Replace a contractor on the Selected Contractors list with a Contractor TBD 

  

Remove a contractor from the Selected Contractors list (same as clicking Remove) 
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Move the selected contractor up in the list 

  

Move the selected contractor down in the list 

  

Attempts to repair faulty contractors (i.e. those contractors marked by a yellow warning 

 ) 

  

  

The Legend on the upper right-hand side of the window shows the type of contractor in the 

Selected Contractors list. 

  

Displays contractors from the Available Contractors list 

  

Displays Anonymous contractors (i.e. Contractor TBD) that the user added with the icons 

 or  

  

Displays Faulty contractors (i.e. contractors that are not on the Available Contractors list). 

These faulty contractors may be the result of removing a contractor through Contractor 

Maintenance, so the contractor in question does not appear on the Available Contractors list 

anymore. Use the  icon to attempt to repair faulty contractors. In addition, contractors of 

imported plans will have the warning sign until you map them to cPet defined contractors. 

  

Contractors added by the user through Contractor Maintenance will appear green  

  

The *Demo* ABCD Corporation can be used as a temporary contractor if you are 

unsure which contractor to use. This contractor's function is the same as that of an 

anonymous contractor . 
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3.18 CONVERSION RESULTS FOR COST REPORTS 

The Conversion Results dialog appears immediately after importing a document. The 

window contains a checklist of fields that were or were not successfully imported into cPet. 

The green checks   indicate that the data imported correctly, and the yellow warnings  

 indicate errors. Review this validation window to anticipate some of the problems that will 

be seen when comparing the Excel file to the data which imported into cPet. 

  

The Description column contains a list of all the fields cPet reviewed to ensure that the 

information imported. 

  

For fields that did not import or fields that were left blank in the Excel file, the Error Type 

is marked as a warning. 

  

The Location references the problematic area on the Excel file. The sheet name is listed in 

quotations, followed by the column and row numbers. 

  

The bottom portion of the window is dedicated to the error log description. For each field 

(whether it is marked with a green check or a yellow warning), cPet displays details 

pertaining to the selected field. The value found on the Excel file is listed. You can hide this 

Reading Pane by clicking the  icon at the top of the window. 

  

The information found in the Conversion Results can be exported to Excel by clicking . 

  

cPet checks whether or not the summary elements imported correctly. All the recognized 

summary elements will be marked with a green check . 

  

The table below lists possible errors that may occur when importing a 1921 or 1921-1. 
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For errors in the header fields, see the 1921 Basic Info Dialog or the 1921-1 Basic Info 

Dialog to understand what information belongs in those fields. 

  

  

Conversion Results for Cost Reports 

Error Description 

Reporting Element has a blank WBS Element 

Code 

The WBS Element is missing an element code. On 

a 1921, this error often occurs because a summary 

element is misspelled and is thus not recognized 

as a summary element. Since summary elements 

do not have codes, the fix to this error would be to 

correct the spelling of the element name. 

Reporting Element has a blank WBS Element 

Name 

For each row on the 1921 that has an Element 

Code, there should be a corresponding WBS 

Element Name. Similarly, each page on the 1921-

1 must have an Element Code. 

Reporting Element is redundant This error occurs when an element is repeated in 

an Excel file. The element might be on different 

sheets of the workbook. If so, the sheet and 

location will be listed in the error details under 

"Address of Prior Element." 

To Date/At Completion cost contains one or 

more cells with a formula that could not be 

evaluated properly 

This warning may occur when there is an error 

with a formula in the Excel file. Review the file to 

correct this error, and then re-import the cost 

report. 

To Date/At Completion Cost does not contain 

a valid decimal number 

This error occurs when there is text in the cost 

field instead of a number. For example, "Not 

Available" will trigger this error. 

Cost Hour Report for Reporting Element has a Either Recurring, Non-Recurring, or Total must be 
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blank Cost Type (applies only to 2003 1921-1's) checked in the Cost Type field of the 2003 1921-

1. Go back to the Excel file, check the appropriate 

cost type, and re-import the 1921-1. 

Cost Type for Cost Hour Report for Reporting 

Element contains one or more cells with a formula 

that could not be evaluated properly (applies only 

to 2003 1921-1's) 

This warning may occur when there is an error 

with a formula in the Cost Type section of the 

Excel file. Review the file to correct this error, and 

then re-import the cost report. 

Cost Type for Cost Hour Report for Reporting 

Element contains multiple check marks (applies 

only to 2003 1921-1's) 

This warning occurs when two or more Cost 

Types (such as Recurring, NonRecurring, or 

Total) are checked in Block 14 of the Excel file 

Summary Element Missing (applies to 1921s) All summary elements must be accounted for on a 

1921. If a summary element is misspelled, cPet 

will not recognize it as a summary element, and 

this warning will appear. 

  

  

3.19 CONVERSION RESULTS FOR FLAT FILES 

The Conversion Results dialog appears immediately after importing a document. The 

window contains a checklist of fields that were or were not successfully imported into cPet. 

The green checks   indicate that the data imported correctly, and the yellow warnings  

 indicate errors. Review this validation window to anticipate some of the problems that will 

be seen when comparing the Excel file to the data which imported into cPet. 

The Description column contains a list of all the fields cPet reviewed to ensure that the 

information imported. 

For fields that did not import or fields that were left blank in the Excel file, the Error Type 

is marked as a warning. 

The Location references the problematic area on the Excel file. The sheet name is listed in 

quotations, followed by the column and row numbers. 
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The bottom portion of the window is dedicated to the error log description. For each field 

(whether it is marked with a green check or a yellow warning), cPet displays details 

pertaining to the selected field. The value found on the Excel file is listed. You can hide this 

Reading Pane by clicking the  icon at the top of the window. 

The information found in the Conversion Results can be exported to Excel by clicking . 

Refer to the Flat File Tutorial for detailed information on Flat Files. 

The table below lists possible errors that may occur when importing a 1921 or 1921-1. 

Tip: cPet identifies an Excel file as a Flat File through two characteristics: (1) The Data 

Type in cell B1 must be "1921/1921-1 Input," and the Data Version in cell B2 must be either 

"2007" or "2011." If these requirements are not satisfied, the Flat File will not import. 

Conversion Results for Flat Files 

Error Description 

Metadata Fields Rows 4-34 must be filled in properly on the 

Flat File. This means that Column B must 

contain text that is nonblank, a valid decimal 

number, and a valid formula (if applicable). 

Dates must be in the format YYYYMMDD. 

In addition, any 1921 Remarks associated 

with the cost report should be placed in cell 

next to "DD 1921 Remarks" at the bottom 

left of the page. 1921-1 Remarks should be 

placed in under the "Remarks" section at the 

far right of the data (you must scroll over in 

the Excel sheet to see this section). 

Reporting Elements   

Reporting Element has a blank WBS 

element code 

Every WBS Element must have a code. Fill 

in the column "WBS Code" for each element 

on the Flat File. 

WBS Code has a formula that could not This warning occurs when there is an invalid 
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be evaluated properly formula in Column D of the Excel file. 

Reporting Element has no name Fill in the column "WBS Reporting 

Elements" for every row that has a WBS 

Code on the Flat File. 

Reporting element name has a formula 

that could not be evaluated properly 

This warning occurs when there is an invalid 

formula in Column E of the Excel file. 

Quantity has a formula that could not be 

evaluated properly 

The Units TD or AC column has a formula 

containing an error. 

Cost has a formula that could not be 

evaluated properly 

The 1921 or 1921-1 cost data contains a 

formula with an error. 

Cost is not a valid decimal number This error may occur when there is text in 

the cost field instead of a number 

Summary Costs cPet looks in the cells near the bottom left of 

the page for the summary costs. The 

Conversion Results provides a warning 

when one or more of these fields is left 

blank. 

  

3.20 CONVERSION RESULTS FOR PLANS 

The Conversion Results dialog appears immediately after importing a document. The 

window contains a checklist of fields that were or were not successfully imported into cPet. 

The green checks   indicate that the data imported correctly, and the yellow warnings  

 indicate errors. Review this validation window to anticipate some of the problems that will 

be seen when comparing the Excel file to the data which imported into cPet. 
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The Description column contains a list of all the fields cPet reviewed to ensure that the 

information imported. 

  

For fields that did not import or fields that were left blank in the Excel file, the Error Type 

is marked as a warning. 

  

The Location references the problematic area on the Excel file. The sheet name is listed in 

quotations, followed by the column and row numbers. 

  

The bottom portion of the window is dedicated to the error log description. For each field 

(whether it is marked with a green check or a yellow warning), cPet displays details 

pertaining to the selected field. The value found on the Excel file is listed. You can hide this 

Reading Pane by clicking the  icon at the top of the window. 

  

The information found in the Conversion Results can be exported to Excel by clicking . 
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The following table lists possible errors that may occur when importing a 2003 or 2007 

program or contract plan. 

  

Conversion Results for DD Form 2794 

Error Fix for 2003 Version Fix for 2007 Version Fix for 2011 Version 

Metadata 

An error occurred 

with one or more of 

the Basic Information 

fields (Items1a 

through 9). See the 

error descriptions 

below. 

An error occurred 

with one or more of 

the Basic Information 

fields (Items 1a 

through 9). See the 

error descriptions 

below. 

An error occurred 

with one or more of 

the Basic Information 

fields (Items 1a 

through 10). See the 

error descriptions 

below. 

Program Name left 

blank 
Fill in Item 1a. 

Fill in Item 1a. 

  
Fill in Item 1a. 

Prime Mission 

Product left blank 
N/A Fill in Item 1b. Fill in Item 1c. 

Milestone left blank Fill in Item 1b. Fill in Item 1c. Fill in Item 1b. 

Milestone/Submission 

Type contains one or 

more cells with a 

formula that could not 

be evaluated properly. 

This error often 

occurs when there is 

a formula referencing 

another sheet in 

Excel. Delete the 

formula and mark the 

box with a "X" and 

re-import, or mark 

selection within cPet. 

This error often 

occurs when there is 

a formula referencing 

another sheet in 

Excel. Delete the 

formula and mark 

box with a "X" and 

re-import, or mark 

selection within cPet. 

This error often 

occurs when there is 

a formula referencing 

another sheet in 

Excel. Delete the 

formula and mark 

box with a "X" and 

re-import, or mark 

selection within cPet. 

Milestone/Submission 

Type contains 

multiple check marks. 

One or more box is 

checked in this field. 

Revise Excel 

document and re-

import, or select 

correct item within 

cPet. 

One or more box is 

checked in this field. 

Revise Excel 

document and re-

import, or select 

correct item within 

cPet. 

One or more box is 

checked in this field. 

Revise Excel 

document and re-

import, or select 

correct item within 

cPet. 

Weapon System Type 

(MIL_STD-881 

Appendix Used) left 

blank 

Fill in Item 2a. Fill in Item 2. Fill in Item 2. 
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Weapon System Type 

(MIL_STD-881 

Appendix Used) does 

not appear to contain 

a valid MIL-HDBK-

881 specification 

The Weapon System 

Type must be one of 

the following nine 

items: Surface 

Vehicle System, 

Space System, Sea 

System, Ordnance 

System, Missile 

System, 

Electronic/Automated 

Software System, 

Aircraft System, 

UAV System, or 

System of Systems. 

The Weapon System 

Type must be one of 

the following nine 

items: Surface 

Vehicle System, 

Space System, Sea 

System, Ordnance 

System, Missile 

System, 

Electronic/Automated 

Software System, 

Aircraft System, 

UAV System, or 

System of Systems. 

The Weapon System 

Type must be one of 

the following nine 

items: Surface 

Vehicle System, 

Space System, Sea 

System, Ordnance 

System, Missile 

System, 

Electronic/Automated 

Software System, 

Aircraft System, 

UAV System, or 

System of Systems. 

Submission Type left 

blank 
Fill in Item 3. 

Fill in Item 3. 

  
Fill in Item 3. 

Date As Of left blank Fill in Item 4. N/A N/A 

Report Date left blank Fill in Item 5. N/A N/A 

Date As Of/Report 

Date does not contain 

a valid date 

Dates must be in the 

MM/DD/YYYY 

format. Dates cannot 

be left as N/A. 

N/A 

  
N/A 

Current Submission 

Date left blank 
N/A 

Fill in Item 4. 

  
Fill in Item 4. 

Last Approved Plan 

Date left blank 
N/A 

Fill in Item 5. 

  
Fill in Item 5. 

Last Approved Plan 

Date does not contain 

a valid date 

N/A 

Dates must be in 

YYYYMMDD 

format. Dates cannot 

be left as N/A. 

Dates must be in 

YYYYMMDD 

format. Dates cannot 

be left as N/A. 

Name/Address does 

not appear to contain 

a valid combination 

of city, state, and zip 

code 

Most likely cause for 

this error is incorrect 

format or placement 

of address on Excel 

file. See Importing 

Errors to Avoid for 

more information. 

Also note that states 

Most likely cause for 

this error is incorrect 

format or placement 

of address on Excel 

file. See Importing 

Errors to Avoid for 

more information. 

Also note that states 

Most likely cause for 

this error is incorrect 

format or placement 

of address on Excel 

file. See Importing 

Errors to Avoid for 

more information. 

Also note that states 
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must be abbreviated 

(e.g. "California" 

must be written as 

"CA.") 

must be abbreviated 

(e.g. "California" 

must be written as 

"CA.") 

must be abbreviated 

(e.g. "California" 

must be written as 

"CA.") 

Name/Address left 

blank 
Fill in Item 6a. 

Fill in Item 6a. 

  
Fill in Item 6a. 

Telephone Number 

left blank 
Fill in Item 6b. Fill in Item 6b. Fill in Item 6b. 

Fax Number left 

blank 
Fill in Item 6c. Fill in Item 6c. Fill in Item 6c. 

Email Address left 

blank 
Fill in Item 6d. Fill in Item 6d. Fill in Item 6d. 

Plan Type left blank N/A N/A Fill in Item 7. 

Preparing 

Organization left 

blank 

Fill in Item 8. 
Fill in Item 8. 

  
Fill in Item 8. 

Review and 

Reference Number 

left blank 

Fill in Item 9. N/A N/A 

Approved Plan 

Number left blank 
N/A 

Fill in Item 9. 

  
Fill in Item 10. 

Contract Number left 

blank 

Fill in the Contract 

Number in column 13 

on the row 

corresponding to the 

first WBS item. 

Fill in the Contract 

Number in column 

12b on the row 

corresponding to the 

first WBS item. 

Fill in Item 9b. 

WBS 

There must be at least 

one element in Item 

11. 

There must be at least 

one element in Item 

11. 

There must be at least 

one element in Item 

11. 

Summary Element 

Missing 

All summary 

elements must be 

accounted for. If a 

summary element is 

misspelled, cPet will 

not recognize it as a 

summary element, 

and this warning will 

appear. 

All summary 

elements must be 

accounted for. If a 

summary element is 

misspelled, cPet will 

not recognize it as a 

summary element, 

and this warning will 

appear. 

All summary 

elements must be 

accounted for. If a 

summary element is 

misspelled, cPet will 

not recognize it as a 

summary element, 

and this warning will 

appear. 
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WBS Element has a 

blank WBS Element 

Code 

Fill in column 10a for 

program plans, and 

column 10b for 

contract plans 

Fill in column 10a for 

program plans, and 

column 10b for 

contract plans 

Fill in column 11a for 

program plans, and 

column 11b for 

contract plans 

WBS Element has a 

blank WBS Element 

Name 

Fill in column 11 for 

all WBS elements 

Fill in column 11 for 

all WBS elements 

Fill in column 12 for 

all WBS elements 

Required Reports for 

WBS Element 

contains invalid text 

Text in columns 14a-

d should be "X" or 

"N/A" 

Text in columns 13a-

e should be "X" or 

"N/A" 

Text in columns 13a-

f should be "X" or 

"N/A" 

Submissions 

There must be at least 

one submission event 

in Item 15. 

There must be at least 

one submission event 

in Item 14. 

There must be at least 

one submission event 

in Item 14. 

As Of Date/Due Date 

for Submission Event 

does not contain a 

valid date 

Dates must be in the 

MM/DD/YYYY 

format to import 

correctly. Dates 

cannot be marked 

TBD. An example of 

an invalid date is 

4/31/2005, where 

April has only 30 

days. 

Dates must be in the 

YYYYMMDD 

format to import 

correctly. Dates 

cannot be marked 

TBD. An example of 

an invalid date is 

20050431, where 

April has only 30 

days. 

Dates must be in the 

YYYYMMDD 

format to import 

correctly. Dates 

cannot be marked 

TBD. An example of 

an invalid date is 

20050431, where 

April has only 30 

days. 

Event Forms for 

Submission Event 

does not appear to 

contain any valid 

form names 

Possible submission 

event forms (Item 

15b) are 1921, 1921-

1, 1921-2, 2630-2, 

and 2630-3. 

Submission event 

forms (Item 14b) 

must be valid. 

Submission event 

forms (Item 14b) 

must be valid. 

  

  

  

3.21 CREATE CONTRACT PLAN 

This dialog pops up when File>New>New Contract/Subcontract Plan is clicked. Three 

options are available: 

  

Inherit from parent plan (using RDT) 
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Choose this option if you would like to create a new contract plan based on a program plan's 

RDT. Alternatively, you may with to create a new subcontract plan based on a contract plan's 

RDT. See the WBS Editor of a Contract Plan tutorial for more information. 

  

Click the "..." button next to the "Select open plan" field to pop up the Select Plan dialog. 

Choose a plan who's RDT you would like to use as a basis for creating the new contract plan. 

Note that prior to completing this step, you must first have edited the selected plan's RDT 

and assigned WBS elements to a particular contractor. 

  

Click the "..." button next to the "Select contractor" field to pop up the Select a Contractor 

dialog. Choose a contractor whose WBS elements are checked in the parent plan's RDT. 

Prior to completing this step, you must have assigned a contractor to the chosen 

plan through the Contractor Selection Dialog. 

  

When you click OK on the "Create Contract Plan" dialog, a new plan will be created which 

contains the WBS elements as checked in the selected parent's plan's RDT for the selected 

contractor. 

  

Create New Plan 

Select this option to create a new contract plan from scratch. Choose which plan version 

(2003, 2007, or 2011) to use. 

  

Close Existing Plan 

Select this option to create a copy of an existing contract plan that is open in cPet. Click the 

"..." button to pop up the Select Plan dialog to choose the appropriate plan. 

  

  

3.22 CREATE PROGRAM PLAN 

This dialog pops up when File>New>New Program Plan is clicked. Two options are 

available: 
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Create New Plan 

Select this option to create a new program plan from scratch. Choose which plan version 

(2003, 2007, or 2011) to use. 

  

Clone Existing Plan 

Select this option to create a copy of an existing program plan that is open in cPet. Click the 

"..." button to pop up the Select Plan dialog to choose the appropriate plan. 

  

  

3.23 IMPORT DIALOG 

The Import dialog allows you to select which plan or cost report you want to import. All 

documents must be in Excel format. An XML equivalent will be created upon importing the 

document. 

  

  

3.24 EXPORT DIALOG 

After creating a program plan or contract plan, the document can be exported to PDF or 

Excel. This feature generates a copy of all the information stored in cPet. The result is a 

duplicate of what the plan would look like using the DD2794 format. 

  

Export to Excel to view the plan in an Excel format. 

  

Export to PDF to view a PDF version of the plan. 

  

Click Immediately view exported file if you want to view the document after the export has 

been generated. 

  

Tip: Plans that were exported to Excel can also be imported back into cPet. 
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3.25 LINK DOCUMENTS DIALOG 

The Link Documents Dialog provides a method for rearranging plans or cost reports. The 

following type of documents can be linked together: 

  

  Program plan and contract plan 

  Contract plan and subcontract plan 

  Contract plan and 1921 

  1921 and 1921-1 

  

To link a contract plan to a program plan, click on each document in the Link Documents 

Dialog. The document names will be displayed at the bottom of the dialog. Click Link when 

you have selected the appropriate plans. The contract plan will now be indented under the 

program plan. 

  

To link a subcontract plan to a contract plan, first click the prime contract plan and then click 

the subcontract plan. The document names are displayed at the bottom of the dialog under 

"Parent" and "Child." Click Link. The subcontract plan will now be indented under the prime 

contract plan. 

  

Tip: The order that the plans are selected is important. If you first click on a subcontract 

plan and then click on the prime contract plan, the prime will be incorrectly indented under 

the sub. 

  

Follow a similar procedure to link a 1921 to a contract plan, or to link a 1921-1 to a 1921. 

  

Tip: Documents can also be linked directly by dragging and dropping them within the 

main window of cPet. See Linking Documents for more information. 
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3.26 NEW CONTRACTOR 

This screen will appear after clicking the  icon in the Contract Maintenance window or 

after clicking Edit > Add Contractor. 

  

Enter the name of the contractor and click OK. 

  

New contractors will appear green  to represent a user-defined contractor. These added 

contractors will only appear in your copy of cPet. To export this list of contractors, click File 

> Export User-Defined Data. In another copy of cPet, you may then click File > Import 

User-Defined Data to import this list, including contractors that were previously user-

defined. 

  

  

3.27 OPEN DIALOG 

The Open dialog allows you to select and open a plan or cost report that has previously been 

imported or created. The document must therefore be in XML format. 

  

The Open dialog can be reached through File > Open, or by clicking on the  icon on the 

toolbar. 

3.28 OPTIONS DIALOG 

Click on one of the links below to view options for each of the tabs within the cPet Options 

dialog: 

  

General Options 

Display Options 

Validation Options 

Import Options 

  

General Options 

WBS System Type 
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Set the default WBS System Type (MIL-HDBK-881A or MIL-STD-881C). This option 

affects which WBS System Type is auto-selected when the Basic Info or the WBS Editor is 

opened. 

  

Prompt before providing WBS structure to plans with no WBS 

When a new plan is created and a Weapon System Type is selected, cPet will ask the 

following question upon opening the WBS Editor: "Should cPet fill in the Program/Contract 

Plan's empty WBS structure with the standard WBS structure for plan's weapon system 

type?" Clicking Yes will generate a list of elements according to the chosen Weapon System 

Type as specified in the Basic Information. Clicking No will leave the WBS Editor blank. 

  

  

Display Options 

  

Filtered Contractors in Contractors List 

Changes color of filtered contractors in the Contractor Selection list or in Contractor 

Maintenance. 

  

Invalid Rows 

Changes color of invalid rows in the Submission Events, WBS Editor, and RDT. 

  

Reset to Defaults 

After changing one or more display colors, click this button to reset back to the default 

colors. 

  

Validation Options 

Skip Validation Wizard when validating an individual document 

If this option is checked, the Validation Wizard is skipped when validating an individual 

document (select the cost report and click Tools > Validate Individual Document). All the 
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validation questions are skipped, and validation results window is displayed. No validation 

letter will be generated. 

  

Allow multi-line validation data 

This option changes the display of the validation results data that are exported to Excel. 

Checking this option allows the row width to expand in Excel to accommodate entries with 

large amounts of data. If this option is not checked, then the columns are made wider to 

display all the data on one line. 

  

Import Options 

  

Overwrite old cPet XML files 

Replace XML files when a plan or cost report is imported more than once. 

  

Generate validation XLS files 

When a document is imported, a validation file is generated in Excel. This file is a replica of 

the plan or cost report, except with errors highlighted in orange, and successfully imported 

areas marked in green. 

  

Overwrite old validation XLS files 

Replace validation XLS files when a plan or cost report is imported more than once. 

  

Expand integers to one decimal place when importing WBS Element Codes ("1" --> 

"1.0") 

cPet expands the WBS Element Codes for program plans and contract plans to one decimal 

upon import. If “1,” “2,” or “3” are listed on the Excel file for instance, then these numbers 

will be displayed as “1.0,” “2.0,” “3.0” in the WBS Editor. 
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3.29 RDT DIALOG 

The Resource Distribution Table (RDT) provides a way to organize WBS elements according 

to assigned contractors. The RDT may accompany a program plan or contract plan. 

  

Before opening the RDT, at least one contractor must be chosen through the Contractor 

Selection Dialog. 

  

When viewing the program plan's RDT, all contractors assigned to the program plan will be 

listed in columns to the right of the window. To the left is a list of all the elements in the 

program plan's WBS Editor. Check which contractor is responsible for which WBS element. 

Use the toolbar at the top of the window to easily check or uncheck items. Useful icons and 

their functions are described below. 

  

Check Selection - Use the shift or control key to select a few WBS items in a certain 

column. Then click this icon to check all the items in the selection. 

  

Uncheck Selection - Use the shift or control key to select a few WBS items in a certain 

column. Then click this icon to uncheck all the items in the selection. 

  

A few other icons that may be useful are: 

  

If the WBS item name is longer than the width of the column, clicking this button 

Resizes the Column so the entire name can be seen. 

  

Arranges the contractor columns in order of their contract value,  from largest to 

smallest. 

  

Moves a contractor column adjacent to the WBS (icon found by right-clicking on a 

column header) 
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To check/uncheck all the elements in a column, right click on the column header and select 

 or   , respectively. 

  

Tip: From the Edit menu, you can Select All or Select Child Elements. These commands 

can be particularly useful if you would like to check/uncheck groups of WBS elements. 

  

Information relevant to each contractor is listed at the top of the window. Click on different 

contractor columns to view and edit the information for each contractor. Note that the RDT 

for program plans and contract plans is slightly different. 

  

Program RDT 

The Program RDT displays information for the prime contractor(s). The Contractor name 

for the selected contractor is listed at top. Fill in the Contract Number and Description for 

the prime contract plan. Also enter information for the Total Est. Contract Value and 

Software Contract Value (including units). Finally, fill in the fields for the Government 

Organization or PARM, CSDR Direct Reporting per CWIPT, and SRDR Direct 

Reporting per CWIPT. 

  

Contract RDT 

The Contract RDT displays information for both the prime contractor and the 

subcontractor(s). The "Contractor Information" at the top of the RDT pertains to the prime 

contractor. The Contractor name and number are read-only fields. They correspond to the 

information that was brought into cPet when the Excel version of the contract plan was 

imported. Or, for contract plans that were created within cPet, the Contract Number 

corresponds to the number that was specified in the Basic Info. If the Total Est. Contract 

Value and the Software Contract Value were filled in on the parent RDT, these fields will 

be brought over to the contract plan. 
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The "Selected Subcontractor Information" pertains to the contract plan's subcontractors. 

Click on a different subcontractor column to view the corresponding information. 

  

To export the RDT to Excel, click the   icon on the main toolbar.  

  

Tip: When the RDT of a program plan is exported, the header information under the Prime 

Contractor column(s) will be filled in. However, cPet will not export any information to the 

Program Office column. 

  

Tip: When the RDT of a contract plan is exported, all the header information will be filled 

in. cPet will export data pertaining to the prime contractor and all the subcontractors. 

  

Tip: WBS elements must have item numbers in order for them to be edited in the RDT. 

Items that do not have numbers will be highlighted according to the Options Display color. 

You will be unable to check these elements under any contractor column until you assign 

them numbers in the WBS Editor. 

  

See WBS Editor of a Contract Plan to visually understand how the program plan's RDT 

relates to the WBS Editor of the program plan and the contract plan. 

  

  

3.30 SELECT A CONTRACT PLAN DIALOG 

3.30.1 IMPORT EVENTS FROM CONTRACT PLAN 

  

This dialog can be accessed through a program plan's submission events, under Tools > 

Import Events from Contract Plan. 

  

Submission events from a contract plan can be imported into a program plan's submission 

events. To do this, follow these steps: 
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1) Make sure a program plan and a contract plan are open in cPet. 

2) Open the program plan's submission events. 

3) Click Tools > Import Events from Contract Plan ( ). 

4) In the Select a Contract Plan dialog, choose the contract plan containing the submission 

events you would like to import (Note: The contract plan must be open in cPet). 

5) The contract plan's submission events will be listed under the program plan's. A header 

row will indicate which events are from the contract plan. 

  

 

  

Note the following when importing events: 

  

The contract plan events will be kept in a separate category than the program plan's. 

The Sort and Renumber tool will be applied to all events. However, the contract plan and 

program plan events will not intermix. 

The multi-check tool  and the fill down tool  can be used across rows pertaining to 

both the program plan and the contract plan. Select the desired events and use any of the edit 

tools. 

New rows will be added to the program plan's events. New events cannot be inserted under 

the contract plan category. 

If all the events from the contract plan are deleted, then the contract plan and program plan 

headers will be deleted. 

You can import events from multiple contract plans - each will appear in its own category. 
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3.31 SELECT A CONTRACTOR 

This dialog appears after browsing for a contractor on the Create Contract Plan dialog. 

Choose which contractor to use to create a new contract plan based on the specified 

plan's RDT. Prior to completing this step, you must have assigned a contractor to the 

chosen plan through the Contractor Selection Dialog. 

  

3.32 SELECT A COST REPORT DIALOG 

Use this dialog to select a cost report for a particular submission event in the Validation 

Wizard. You may browse for a cost report that is not currently open in cPet. Or you may 

choose to select a different cost report than is listed in the Validation Wizard. 

  

  

3.33 SELECT DOCUMENT VERSION DIALOG 

The Select Document Version dialog will pop up when you are creating a new cost report. 

Choose whether the document follows the 2003, 2007, or 2011 version. 

  

3.34 SELECT PLAN 

The "Select Plan" dialog may appear for one of two reasons: 

1) While creating a contract plan or program plan. 

2) While inserting WBS elements or submission events. This dialog may appear after 

clicking Edit > Insert WBS from existing plan on a plan's WBS Editor. This feature 

inserts the selected plan's entire WBS under the selected element in the active plan's WBS 

Editor. Alternatively, this dialog may appear after clicking Tools > Import events from 

existing plan on a contract plan's Submission Events. This feature inserts the selected plan's 

entire submission events under the selected element in the contract plan's Submission Events. 
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All program plans and contract plans that are open in cPet are listed in the dialog. To use a 

plan that is not shown, close the dialogs, select File>Open, choose the desired plan, and then 

return to the Select Plan dialog. 

3.35 SELECT REPORTS TO COMPARE 

The Select Reports to Compare dialog appears after performing one of the following actions: 

1) Click Tools > Compare Cost Reports. 

2) Select a contract plan, 1921, or 1921-1 that is open in cPet, right-click, and choose 

Compare Cost Reports. 

The plans and cost reports which are open in cPet are listed. Choose which contract plan will 

be used for comparison. Select the Earlier Report and Later Report. cPet will pre-select 

the Earlier/Later Report based on the Report As Of date. If you reverse this selection, cPet 

will highlight the check boxes in pink. 

Click OK after you have decided which documents to compare. Depending on your selection, 

the 1921 Cost Report Comparison window or the 1921-1 Cost Report Comparison 

window will open. 

Tip: You can select 1921's of either document version (2003, 2007, or 2011). However, 

1921-1's must both be of the 2007 or 2011 version. Any 1921-1's of the 2003 version will 

have check boxes that are disabled in the Select Reports to Compare dialog. 

  

  

  

3.36 SUBMISSION EVENTS DIALOG 

The Submission Events window displays the CSDR Submissions for the plan. 

  

Use the toolbar at the top of the window to add and manage submission events. A brief 

explanation of the toolbar is given below. 
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Delete a submission event 

  

Check Selection - Use the shift or control key to select a few submission events in a 

certain column. Then click this icon to check all the items in the selection. 

  

Uncheck Selection - Use the shift or control key to select a few submission events in a 

certain column. Then click this icon to uncheck all the items in the selection. 

  

Add submission event(s) 

  

Add Type – Adds either “Blank” or “Like Current” events 

  

“Blank” = Adds new rows 

“Like Current” = Copies rows from selected row 

  

Fill Down Value – When several rows are selected, clicking this icon 

checks/unchecks the boxes in the column according to the first row. This icon can 

also be used to copy dates down a column. 
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Fill Down Date Value – When multiple rows are selected, clicking this icon 

generates dates down the column. These dates are set apart from each other by a 

certain increment of time. 

  

Insert a row before the selected event 

  

Insert a number of rows (quantity depends on numerical value in toolbar) 

  

Add a row to the end of the submission events list 

  

Add a number of rows to the end of the submission events list (quantity depends on 

numerical value in toolbar; same 

as  icon) 

  

Sort and Renumber – Arranges the submission events by As of Date and designates an 

Event Number for each. 

  

Import Events from contract plan - (Found only on program plans); Contract plan 

events can be imported into a program plan's events. See Import Events from Contract Plan 

for more information. Icon found under the Tools menu. 

  

Import Events from existing plan - (Found only on contract plans); Program plan 

events can be imported into a contract plan's events. See the icon found under the Tools 

menu. 

  

To check/uncheck all the events in a column, right click on the column header and select  

or  , respectively. 



Dialogs 

179 

  

Tip: From the Edit menu, you can Select All. This command can be particularly useful if 

you would like to either check/uncheck all the submission events, or delete them all. 

  

A brief explanation of the fields in the submission events window is given below. 

  

The Event # lists the number assigned to the event. For imported plans, this number is 

copied from the DD 2794 Excel version of the plan. If the events are not in order, the Sort 

and Renumber icon  can be used to numerically order these events. For new plans, the 

Sort and Renumber icon assigns a number to the events depending on their order in the 

submission events window. 

  

For imported plans, the submission events and their dates and required reports will appear as 

they did on the DD 2794. However, invalid dates will not import and will be left blank. cPet 

provides a warning in the conversion results upon importing a plan. An example of an invalid 

date is 4/31/06 (April has only 30 days). Dates will also not import if they are in the incorrect 

format. The format for dates is as follows: 

  

2003 Version    DD/MM/YYYY 

2007 Version    YYYYMMDD 

  

The table below compares the report names across different versions of the DD 2794. The 

naming conventions between the versions may be slightly different, and some versions may 

have columns for additional reports. 

  

Required Reports 

2003 2007 2011 

  CWBS Dict. CWBS Dict. 

1921 1921 1921 



cPet Help Manual 

180 

1921-1P1 1921-1 1921-1 

1921-1P2 1921-2 1921-2 

2630-2 SRDR Initial SRDR Initial 

2630-3 SRDR Final SRDR Final 

    1921-4 

  

  

For imported plans, the following information will already be listed in the submission events. 

However, for newly created plans, continue to fill in the information for the submission 

events of the CSDR plans. 

  

Fill in the Event name associated with the CSDR submission. 

  

Fill in the As of Date for the CSDR submission. This is the date that the data are reported. 

  

Fill in the Due Date for the CSDR submission. This is the date that the report is due. The 

Due Date is generally 60 days after the As of Date. cPet automatically generates a Due Date 

once the As of Date is chosen. 

  

Note: Incomplete events, header rows, or invalid dates will be marked pink, but this color can 

be changed in the cPet Display Options. 

  

  

3.37 SUBMISSION VALIDATION 

A submission can be validated in one of two ways: 

  

1)  In the main window of cPet, select a contract plan and click Tools > Validate 

Submission. 
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2) Click Tools > Run the Validation Wizard and select, "Validate a cost report submission, 

and generate a validation memorandum." 

  

Either of these two methods results in a validation wizard dialog that displays validation 

results for the contract plan, the 1921, and the 1921-1. 

  

The following icons indicate the severity for each validation: 

  

OK - No problems 

  

Warning - Moderately significant problems 

  

Error - Severe problems 

  

The validation results may be grouped in the following six categories: 

  

Contract Plan (includes errors regarding blank codes or repeated elements on the contract 

plan’s WBS Editor itself) 

1921 vs Contract Plan (validates required/nonrequired and reported/missing elements) 

1921 Internal (validates numeric data within the 1921) 

1921-1 vs Contract Plan (validates required/nonrequired and reported/missing elements) 

1921-1 vs 1921 (compares data in the 1921-1 against the 1921) 

1921-1 Internal (validates numeric data within the 1921-1) 

  

Note: If you run the Validation Wizard and choose any non-default answers to the validation 

questions, cPet will add one or both of the following categories to the Validation Results: 

1921 Additional Validation Data and 1921-1 Additional Validation Data. These 

categories will list any comments you wrote in response to the validation questions. 

  

Contract Plan 
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Possible validation errors for a contract plan are listed in the table below. 

  

Contract Plan Validation Results 

Error Description 

Blank WBS Element Code found for WBS element 

from Contract Plan 

Every WBS Element must have a code. Auto-

numbering is made easy by clicking Tools > WBS 

Numbering within the contract plan's WBS Editor. 

Repeated WBS Element Code found for WBS 

elements from Contract Plan 

Each WBS Element must have a unique code. 

  

  

1921 vs Contract Plan & 1921 Internal 

Please see 1921 Validation Results for details. 

  

1921-1 vs Contract Plan, 1921-1 vs 1921, & 1921-1 Internal 

Please see 1921-1 Validation Results for details. 

  

  

The dialog is laid out in three columns: The Location, Description, and Error Magnitude: 

  

The Location column displays the validated item. 

  

The Description column lists the type of error found. Click on an error to view the 

associated details in the Reading Pane at the bottom of the window. You can hide this 

Reading Pane by clicking the  icon at the top of the dialog. 

  

The Error Magnitude represents the difference between related costs. 
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Tip: For these numeric validations,  only the error with the greatest magnitude will be 

reported for each WBS Element (and for each page, if relevant). In fixing the major error, 

many smaller errors will most likely be fixed as well. 

  

Click the Filter icon  to sort the validation results by Location or by Error Magnitude. 

Results are listed by Location by default, which means that within each category, the errors 

appear in order of their WBS Element Code. If you choose to sort by Error Magnitude, then 

the numeric errors will be listed with the error of largest magnitude first. Click Hide 

Warnings to hide the warnings  and only display the errors . 

  

The information found in the Validation Results can be exported to Excel by clicking . 

  

Once you are satisfied with the validation results, you may continue to accept or reject the 

submission in the Validation Wizard and generate a validation memorandum. 

  

  

3.38 WBS EDITOR DIALOG 

The WBS Editor displays the list of required reporting elements in a hierarchical fashion. 

  

If creating a new program or contract plan, cPet may inquire if the WBS Editor should be 

filled in according to the Weapon System Type specified on the Basic Info. Refer to the 

General tab of the cPet Options to turn on or off this warning. 
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Use the following icons to add, edit, and move WBS items: 

  

Undo 

  

Redo 

  

Add a sibling to the selected element 

  

Add a child to the selected element 

  

Delete an item 

  

Copy a WBS element 

  

Cut a WBS element 

  

Paste a WBS element (note that elements can be pasted into cPet or into Excel) 

  

Indent an item 

  

Unindent an item 

  

Move an item up in the list 

  

Move an item down in the list 
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Provides the option of assigning a WBS number to each item, or clearing the item 

numbers 

  

Free Edit Mode - Turn on Free Edit mode to add, delete, or arrange WBS 

elements easily. See below for more details 

  

Expand All (Found under the View Menu)- All the elements in the WBS tree will be 

displayed 

  

Collapse All (Found under the View Menu)- All the elements in the WBS tree will be 

collapsed to that only the root element(s) is displayed 

  

Check (Found under the Edit Menu) - Use the shift or control key to select a few WBS 

items in a certain column. Then click this icon to check all the items in the selection 

  

Uncheck (Found under the Edit Menu) - Use the shift or control key to select a few WBS 

items in a certain column. Then click this icon to uncheck all the items in the selection 

  

Insert Standard WBS (Found under the Edit Menu). Provides the option to insert a 

standard WBS according to either MIL-HDBK-881A or MIL-STD-881C (as specified at the 

top of the WBS Editor). 

  

From the Edit Menu of contract plans, you may also Insert WBS From Existing Plan. This 

function inserts all of the WBS elements found on the WBS Editor of the selected parent 

plan. 
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Tip: From the Edit menu, you can Select All or Select Child Elements. These commands 

can be particularly useful if you would like to delete groups of elements from a standardized 

WBS. 

  

Tip: Elements can be copied from the WBS Editor and pasted into Excel. Likewise, 

elements can be copied from Excel and pasted into the WBS Editor. 

  

Free Edit Mode 

  

The Free Edit Mode may be useful when creating new WBS elements or rearranging the 

indentation structure of the elements. Click the icon on the toolbar to turn on 

the Free Edit Mode (the button will turn orange). In Free Edit Mode, parent/child 

relationships among WBS elements are relaxed so that individual elements can be indented 

and moved without changing the indentation or position of other elements. The WBS 

elements will still appear indented under each other, but the Expand ( ) and Collapse ( ) 

icons will no longer be present. The purpose of the Free Edit Mode is to visually organize the 

WBS with ease. Without this mode turned on, a newly added element may not appear where 

you would like it to be in the tree structure. 

  

There are a few things to note when using the Free Edit Mode: 

  

After changing the WBS in Free Edit Mode, the WBS indenture structure will be 

maintained after the mode is turned off. 

WBS elements are indented by four spaces. However, if you indent an element by a single 

space, cPet will interpret this element as being indented by four spaces. 

If you indent an element by more than four spaces, cPet will ignore these extra spaces. If 

you close and reopen the WBS Editor, the element will appear indented by the normal four 

spaces. 

  

WBS Editor in Relation to the DD 2794 
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The WBS Element Name column is shown on the left of the WBS Editor. For contract and 

subcontract plans, the summary elements are listed at the end of the WBS Editor (i.e. 

"Subcontractor G&A" through "Total Cost [Through Reporting Contractor's G&A & Profit 

or Fee]" for 2003 plans, and "Subtotal Cost" through "Total Price" for 2007 and 2011 plans). 

  

On program plans, the WBS Element Code column lists each item with an element code. 

  

On contract plans, the Program Plan WBS Element Code corresponds to the code of the 

element found on the program plan. The WBS Element Code corresponds to number of the 

element on the contract plan. 

  

For imported plans, the WBS Editor will import the appropriate checks in the Reports 

Required field of the DD 2794. 

  

For newly created plans, click the required reports for each element. 

  

Clicking the N/A box for a WBS element automatically erases all checks in that particular 

row. 

  

A WBS item will be highlighted if it is an only child (see below). The color of the warning 

depends on the Display Colors in the cPet Options. 

  

Tip: A WBS item will be highlighted if it does not have any columns checked. 

  

The table below compares the report names across different versions of the DD 2794. The 

naming conventions between the versions may be slightly different, and some versions may 

have columns for additional reports. 

  

Required Reports 
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2003 2007 2011 

  CWBS Dict. CWBS Dict. 

1921 1921 1921 

1921-1P1 1921-1 1921-1 

1921-1P2 1921-2 1921-2 

2630 SRDR SRDR 

    1921-4 

  

  

Refer to the Cost and Software Data Reporting (CSDR) Manual (DoD 5000.04-M-1) for 

more information on reports. 

  

For a brief explanation of the fields on the DD 2794 form, refer to Instructions for 

Completing DD Form 2794, Cost and Software Data Reporting (CSDR) Plan. 

  

  

3.39 WBS NAMING DISCREPANCIES 

The WBS Naming Discrepancies dialog pops up after clicking on a WBS element hyperlink 

in the 1921 Cost Report Comparison or 1921-1 Cost Report Comparison window. The 

purpose of this dialog is to show how the WBS element name is not consistent across the 

contract plan, the Earlier report, and the Later report. See the example below. 
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3.40 VALIDATION WIZARD DIALOG 

The Validation Wizard provides a guide to validating cost reports under a specific 

submission event. At the end of the Validation Wizard, a validation memo and the validation 

results will be generated. The Validation Wizard can be accessed directly by clicking Tools > 

Run Validation Wizard. The Validation Wizard is also used when you (1) select a contract 

plan and click Tools > Validate Submission or (2) click Tools > Validate Submission in 

the submission events window. See Validating Cost Reports for more information on 

different ways to access the Validation Wizard. 

  

Welcome to the Validation Wizard 

  

By clicking Tools > Run Validation Wizard, the Welcome to the Validation Wizard 

screen will appear. 

  

There are two options: Validate a cost report submission and generate a validation 

memorandum, or Validate a single cost report. 

  

Validate a Cost Report Submission 
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Pick a Submission Event 

  

If you choose to Validate a cost report submission, the Pick a Submission screen will 

appear. The contract plans and their submission events are listed. Note that the contract plans 

are listed according to their order in the main window of cPet. 

  

Select a submission event. cPet will list the 1921's and 1921-1's that most closely match the 

As of Date of the submission event. 

  

Click  to open a cost report that is not listed in the Validation Wizard. 

  

Click Next when you have selected a submission event and located the appropriate cost 

reports. 

  

Guided Validation 

  

cPet provides two options: Answer guided validation questions or Skip guided validation 

questions. 

  

If you choose the first option, you are presented with a series of questions pertaining to the 

contract plan and the cost reports. 

  

If you choose to skip the questions, you jump to the Submission Acceptance screen, and the 

validation results window appears. See 1921 Validation Results, 1921-1 Validation Results, 

1921-2 Validation Results, and 1921-3 Validation Results for information on each of the 

errors. 

  

Submission Acceptance 
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You may Accept, Accept Conditionally, or Reject the submission based on the validation 

results. After clicking Next on the Submission Acceptance screen, the Additional 

Information screen appears. 

  

Additional Information 

  

Enter the P.O. Name, Office Code, Date Received, and Resubmission question to complete 

information used in the validation letter. Click Next to proceed to the Completing the 

Validation Wizard screen. 

  

Completing the Validation Wizard 

  

Choose the location to save the validation letter and validation results. If you would like to 

change the file name or file path where the documents will be saved, click Browse. Click 

Reset to Default to set the file name/location back to the original. 

  

Click Open files in their respective applications if you want to immediately view the 

documents. 

  

Click Finish to generate the memo files. 

  

The Validation Letter will open in Microsoft Word. Any information that was not filled in 

on the Additional Information screen will be marked in red. 

  

The Validation Results will open in Microsoft Excel. The validation errors are displayed as 

they were in the Validation Results dialog. 

  

  

Validate a Single Cost Report 
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If you choose to Validate a single cost report, the Pick a Cost Report screen appears. 

  

Pick a Cost Report 

  

All the plans and cost reports appear as they do in the main window of cPet. Select a cost 

report to validate and click Next. 

  

Guided Validation 

  

cPet provides two options: Answer guided validation questions or Skip guided validation 

questions. 

  

If you choose the first option, you are presented with a series of questions pertaining to the 

contract plan and the cost reports. 

  

If you choose to skip the questions, you jump to the Completing the Validation Wizard 

screen. 

  

Completing the Validation Wizard 

  

The Validation Wizard will generate a validation letter and report. If you would like to 

change the file name or file path where the documents will be saved, click Browse. 

  

Click Finish to view the validation results. See 1921 Validation Results, 1921-1 Validation 

Results, 1921-2 Validation Results, and 1921-3 Validation Results for information on each of 

the errors. 

  

Tip: The Validate a Single Cost Report option does not generate a validation letter. In 

addition, the validation results are not exported to Excel as they are when you select the 

Validate a Cost Report Submission option. 
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4: REFERENCES 

4.1 HELPFUL LINKS 

General Links: 

Defense Cost and Resource Center (DCARC) 

Cost and Software Data Reporting (CSDR) Manual (DoD 5000.04-M-1) 

CSDR Overview and Policy 

  

DD 2794 Links: 

DD Form 2794 Instructions and Blank Template 

  

Cost Report Links: 

DD Form 1921, 1921-1, 1921-2 and 1921-3 Data Item Description and Blank Templates 

  

http://cade.osd.mil/
http://cade.osd.mil/Files/Policy/500004m1.pdf
http://cade.osd.mil/CSDR/CSDROverview.aspx
http://cade.osd.mil/CSDR/Planning.aspx
http://cade.osd.mil/CSDR/FormsReporting.aspx
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5: GLOSSARY 

1 

1921: The DD Form 1921 (known as "Cost Data Summary Report") provides both recurring 

and nonrecurring costs for certain WBS Elements on a contract plan. A 1921 can be 

imported under a contract plan or subcontract plan. 

1921-1: The DD Form 1921-1 (known as "Functional Cost-Hour Report") provides recurring 

and nonrecurring costs. The 1921-1 data correlates with the 1921 data, except that the 

1921-1 provides a more detailed breakdown of costs. A 1921-1 can be imported under 

a 1921. 

B 

Basic Information: Displays the header fields for a plan or cost report. Can be accessed by 

clicking View > Basic Info. 

C 

Child Element: Refers to a lower level item that is indented under a parent element. In the 

WBS Editor, an element that is an only child (i.e. an element that has no sibling 

elements) will be marked red. 

Contract Plan: A contract plan includes the data reporting requirements for a particular 

contractor. Multiple contract plans can be imported under a single program plan. 

Alternatively, several subcontract plans can be imported under one prime contract 

plan. 

Contractor Maintenance: Add, edit, or delete contractor names, divisions, or locations from 

the Contractor Selection list. Changes will be saved only in the user’s copy of cPet. 

Contractor Selection: Displays a list of available contractors. A contractor must be selected 

before a contract plan is imported under a program plan. Similarly, a contractor must 

be selected before a subcontract plan is imported under a prime contract plan. 
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Conversion Results: Displays a list of errors found upon importing a plan or cost report. 

Cost Data: Cost data is presented on a recurring/nonrecurring basis on a 1921 or 1921-1. 

The cost data can be viewed by clicking the $ icon on the toolbar of cPet's main 

window. 

Cost Report: Refers to a 1921 or 1921-1. 

Cost Type: The Cost Type may be either Non-Recurring, Recurring, or Total. 

E 

Export: The user can export a plan to PDF or Excel. If the plan is exported to PDF, the 

document follows the DD 2794 format. 

F 

Flat File: Displays cost report information in an Excel file. Data from a cost report in cPet 

can be exported to a Flat File. The user can then edit this information in Excel and 

import back into cPet. 

I 

Import: Convert an Excel file to an XML file and view using cPet. 

L 

Link Documents: Associate one plan with another. For example, a contract plan can be 

linked to (or indented under) a particular program plan. 

M 

MIL-HDBK-881 Appendix: See Weapon System Type. 

N 
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Narrative Text: Enter the information found at the bottom of the DD Form 2794 in the 

Narrative Text tab of the Basic Info window. Default headings for a program plan are 

Program Overview, Contracting Approach, and Quantity Overview. The default 

heading for contract plans is "Special Contractor Instructions." However, any of these 

headings can be modified or deleted, and additional headings can be added. 

O 

Open: The Open command allows you to open a previously imported file (in XML format). 

P 

Parent Element: Refers to the top element in a hierarchical structure. A parent element has 

children elements indented at lower levels. 

Prime Contract Plan: The prime contract plan acts as the parent plan for one or more 

subcontract plans. The prime contract plan is imported directly under the program 

plan. 

Prime Contractor: The prime contractor is equivalent to a parent contractor. Multiple prime 

contractors can be assigned to a program plan. A prime contract plan is imported or 

created under a prime contractor. See "Subcontractor" for comparison. 

Program Plan: A program plan includes the data reporting requirements for the complete 

program. A program plan can have several contract plans and subcontract plans. 

R 

RDT: Displays the WBS Elements assigned to a particular contractor. Useful when creating 

a contract plan. If a program plan's RDT is filled in, the contract plan's WBS Editor 

can be auto-completed. 

S 
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Sibling Element: Refers to an element that exists at the same level as another element in a 

hierarchical structure. 

Subcontract Plan: A subcontract plan is indented under a prime contract plan. Multiple 

subcontract plans may be imported under one prime contract plan. 

Subcontractor: A subcontractor is the child of a prime contractor. Add several 

subcontractors to a contract plan before importing or creating subcontract plans. 

Submission Events: Displays the Submission Events, their dates, and the required forms for 

each. 

Summary Elements: Refers to the items following the WBS elements on a contract plan. 

These items are not assigned a WBS element code. For 2003 plans, these are 

"Subcontractor G&A" through "Total Cost (Through Reporting Contractor's G&A & 

Profit or Fee)." For 2007 plans, these are "Subtotal Cost" through "Total Price." 

V 

Validation: Verifies that the cost reports present accurate data that is required by the contract 

plan’s submission events. Cost reports are validated according to completeness, 

consistency, and numerical accuracy. 

Validation Wizard: Displays all the submission events from the contract plans open in cPet. 

Allows the user to choose the submission event to be validated. The cost reports with 

the closest As of Date to the submission event are displayed. The Wizard guides the 

user through an optional series of questions relevant to the validation. At the end of 

the wizard, cPet automatically generates a validation letter (in Word) as well as the 

validation results (in Excel). 

W 

WBS Editor: Displays the WBS Elements, their item numbers, and the required forms for 

each. 
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Weapon System Type: The Weapon System Type provides a basis for the elements in the 

WBS Editor. The Weapon System Type must follow one of the nine MIL-HDBK-881 

specifications: Surface Vehicle System, Space System, Sea System, Ordnance 

System, Missile System, Electrical/Automated Software System, Aircraft System, 

UAV System, or System of Systems. 
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